LADSPA lowpass filter

This topic contains 1 reply, has 2 voices, and was last updated by  Heiner Moderator 6 months, 3 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 17. Februar 2018 at 23:56 #34038

    Hello,

    I am trying to use the Justboom Amp Zero as crossover. Therefore I have to route the signal of one stereo-channel to both amp-channels. This is working fine by adding the following to my asound.conf:

    pcm.mono {
     type plug
     slave {
    #  pcm "lowpass"
       pcm "dshare"
      channels 2
     }
     ttable.0.0 0.5
     ttable.1.0 0
     ttable.0.1 0.5
     ttable.1.1 0
    }

    Then, in the max2play-Menu I choose mono as soundcard in the extended settings of squeezelite.

    The problem comes up, when I want to add an additional lowpass filter, for example by adding:

    pcm.pluglp {
            type ladspa
    slave.pcm "dshare";
    path "/usr/lib/ladspa"
    plugins[
    {
            label lpf
            id 1041
            input {
                    controls [ 150 ]
            }
    }
    ]
    }

    When choosing pluglp as soundcard, squeezelite won’t start.

    (Of course I want to daisychain mono and pluglp in the end)

    Is there anybody, who might have an idea how to solve my problem? I have been trying to figure out this for days…

    1. März 2018 at 17:43 #34165

    Hi Silax,

    You can use our Lowpass filter integration and its structure as model for yours (reuse and replace our pcm with yours). Just click „install“ in the last paragraph of our Audioplayer plugin and it is installed. You can also check out our github for more details.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here