[SOLVED] KODI Passthrough DTS 5.1

Max2Play Home 2016 (en) Forums Max2Play Add-ons [SOLVED] KODI Passthrough DTS 5.1

This topic contains 4 replies, has 3 voices, and was last updated by  Mbydeen 5 months, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 26. April 2017 at 17:38 #28572

    Hi,
    I updated to Max2Play KODI 17.1 from OpenELEC 16, and I cannot get the audio passthrough working. Here is what I want to accomplish:
    – 2 sound cards: 1) HDMI and 2) HiFiBerry
    – Play KODI on HDMI (synch disabled) DTS & Dolby Passthrough to my receiver
    – Play Squzelite on HiFiBerry Stereo

    After endless configurations, I can play KODI in PCM stereo to HDMI, and Squzelire in stereo to HiFiBerry. What’s not working is playing KODI DTS 5.1 passthrough. Any help or pointing me to additional information will be greatly appreciated.

    AlleyCat

    27. April 2017 at 8:26 #28581

    Hi

    have you checked out the Audiosettings in KODI: https://www.htpcbeginner.com/kodi-audio-settings/
    It works fine on my Raspbery.

    Squeezelite over HifiBerry and KODI over HDMI. But Squeelzelite an KODI can’t run at the same time

    • This reply was modified 5 months, 3 weeks ago by  std.
    • This reply was modified 5 months, 3 weeks ago by  std.
    27. April 2017 at 13:20 #28593

    Hi,
    Thanks for the reply. Yes,I checked the settings. I turned off the video sync, and followed instructions by the KODI community. Can I downgrade to KODI 17 for testing? I think I should try to downgrade the existing build to check if the problem is with KODI libraries or Jessie.
    Where can I find instructions for downgrade KODI files, or perhaps to try to install an older version of Max2Play?

    Enjoy your vacation,

    Thanks,
    AlleyCat

    27. April 2017 at 22:50 #28603

    Please find an update. I downloaded Max2Play rev. m2p_rpi3_hifiberry_235_wps.img and the passthrough works with no problems. I set in KODI the number of channels to 7.1, and I am getting 5.1 PCM steams from FLAC and other DTS Dolby HD sources. It looks like there is something wrong with the new KODI build.

    Regards,

    AlleyCat

    2. May 2017 at 12:45 #28658

    @ STD

    Now you can run Kodi and the squeezelite player will be disabled automatically.

    @ AlleyCat

    It is good to know that your problem is solved 🙂

    Best Regards,
    Mohammad Mbydeen

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here