Kodi not starting after a "apt-get update/ apt-get upgrade"

Max2Play Home 2016 (en) Forums Max2Play on ODROID U3/C1 Kodi not starting after a "apt-get update/ apt-get upgrade"

This topic contains 2 replies, has 2 voices, and was last updated by  mkkyah 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 22. March 2016 at 12:41 #19403

    Hi, I have done a “apt-get update/ apt-get upgrade” on my U3 through ssh.After a restart kodi fails to start with following error:
    Trying to launch … NOT successful Click here to show detailed information
    sudo: unable to resolve host OdroidLMS
    Stopping Shairport
    /sbin/start-stop-daemon: warning: failed to kill 1837: No such process
    sudo: unable to resolve host OdroidLMS
    sudo: no tty present and no askpass program specified
    /usr/lib/kodi/kodi.bin: symbol lookup error: /usr/lib/kodi/kodi.bin: undefined symbol: eglGetDisplay
    /usr/lib/kodi/kodi.bin: symbol lookup error: /usr/lib/kodi/kodi.bin: undefined symbol: eglGetDisplay
    /usr/lib/kodi/kodi.bin: symbol lookup error: /usr/lib/kodi/kodi.bin: undefined symbol: eglGetDisplay
    /usr/bin/kodi –standalone has exited in an unclean state 3 times in the last 2 seconds.
    Something is probably wrong

    edit: I get this error also if I run update/upgrade from “Advanced setup odroid u3” tab.

    • This topic was modified 8 months, 2 weeks ago by  mkkyah.
    29. March 2016 at 17:31 #19516

    Hi mykkah,
    We do not recommend doing any apt-get updates with the U3 anymore. The product is not produced by Hardkernel anymore and the new software stops being supported.

    1. April 2016 at 16:40 #19574

    It’s sad to hear that.
    I have a problem with a very popular Kodi add-on. Quasar addon from official Kodi video addons forum is crashing by starting Kodi and they suggest to fix this by following, which breaks my Max2Play and Kodi:

    Firstly, install:
    sudo apt-get install libstdc++6
    This should already be installed by default, but try it anyway. If it doesn’t solve it, just do the following:
    sudo add-apt-repository ppa:ubuntu-toolchain-r/test
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get dist-upgrade

    Do you offer a way to fix that libstdc++6 issue?

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here