Kodi not running

Max2Play Home 2016 (en) Forums Max2Play Add-ons Kodi not running

This topic contains 1 reply, has 2 voices, and was last updated by  Heiner Moderator 2 years, 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 6. Juni 2018 at 17:33 #36102

    There’s a „solved“ thread possibly dealing with this, but I don’t read german, so apologies for any duplication.

    I installed the Kodi plugin a long time back on my RaspberryPiB+, but never used it. Now I want to, but can’t get it to work. I’ve updated both m2p and Kodi to latest versions and checked my hdmi settings, but all to no avail.

    The first time I tried to update Kodi, I got this read-out:

    Installations package: kodiupgradepi
    Installation started - This Messages refreshes every 3 seconds to show current installation status. When finished this message disappears.
    Get:6 http://archive.mene.za.net wheezy/contrib armhf Packages [15.1 kB]
    Ign http://raspberrypi.collabora.com wheezy/rpi Translation-en_GB
    Ign http://raspberrypi.collabora.com wheezy/rpi Translation-en
    Ign http://archive.mene.za.net wheezy/contrib Translation-en_GB
    Ign http://archive.mene.za.net wheezy/contrib Translation-en
    Ign http://archive.raspberrypi.org wheezy/main Translation-en_GB
    Ign http://archive.raspberrypi.org wheezy/main Translation-en
    Get:7 http://mirrordirector.raspbian.org wheezy/contrib armhf Packages [35.0 kB]
    Get:8 http://mirrordirector.raspbian.org wheezy/non-free armhf Packages [73.6 kB]
    Get:9 http://mirrordirector.raspbian.org wheezy/rpi armhf Packages [592 B]
    Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en_GB
    Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en
    Ign http://mirrordirector.raspbian.org wheezy/main Translation-en_GB
    Ign http://mirrordirector.raspbian.org wheezy/main Translation-en
    Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en_GB
    Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en
    Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en_GB
    Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en
    Fetched 7,823 kB in 48s (160 kB/s)
    Reading package lists...
    --2018-06-06 15:50:40-- http://kodiupgradepi/
    Resolving kodiupgradepi (kodiupgradepi)... failed: Name or service not known.
    wget: unable to resolve host address 

    kodiupgradepi‘
    ERROR! Given HTTP-Link to Kodi package does not exist! Please check URL kodiupgradepi
    finished

    Installation complete!

    Status: Kodi (Video) not running`

    I restarted Kodi, with the ‚Reinitialise Display‘ box checked, and got this:

    Restart Desktop-Manager completed (initialized Display)
    Trying to launch ... successful with ID 29712
    Status: Kodi (Video) not running

    This is one of several instances where launch was reported successful with an ID number, but ‚Status‘ remained stubbornly „not running“

    Most of the time my display screen has stayed blank, but after one Kodi restart attempt I got a Raspberry boot-up screed, ending with a login prompt. I noticed that while almost all the lines were [Ok], there was one warning:

    [warning] kernel lacks cgroups or memory controller not available ...

    Rebooting and restarting Kodi a third or fourth time I got this:

    Trying to launch ... NOT successful Click here to show detailed information
    Status: Kodi (Video) not running

    At least it’s consistent!

    But when I clicked on the „show detailed information“ link, nothing happened. I tried right-clicking and opening in a new tab, which opened another copy of the ‚Kodi/XBMC – Status, Start & Stop‘ page, but which contained this:

    `Kodi / XBMC – Status, Start & Stop

    Trying to launch … successful with ID 4229
    Status: Kodi (Video) not running`

    I’m very confused. Could someone kindly assist?

    7. Juni 2018 at 17:09 #36111

    Hi nick,

    Kodi comes preinstalled, so there is no need to install it. Upgrading is also not necessary as our newest image has the most up to date version, while older versions have the correct version Kodi to work with it. I assume updated an older wheezy-based system (RPi development has by now jumped from jessie to stretch, which is the most current version) to a version of Kodi that is not compatible with it anymore.

    Depending on how much you have set up on your wheezy image, I would recommend burning our new image.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here