Kodi: no video playback

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Kodi: no video playback

Tagged: ,

This topic contains 28 replies, has 6 voices, and was last updated by  MvD42 premium 1 year, 1 month ago.

Viewing 29 posts - 1 through 29 (of 29 total)
  • 21. September 2015 at 8:54 #15748

    Hello!
    I’m running max2play (updated to the latest version) on a Raspberry Pi 1 model B.
    I wanted to use Kodi and it launches correctly, I added video sources (from NAS) and everything seemed to work. But when I try to play any files, there is no video playback, just a black screen (no video, no audio). Only the GUI shows.
    I tried fiddling with interlacing settings, but to no avail.
    Any help appreciated.
    Thanks

    22. September 2015 at 15:11 #15769

    Hi Sciamano,
    First to make sure you can get video playback, please try playing a youtube video. You can also check if a normal HD video file will play to find out if your format was the problem. Here is a good example video: http://distribution.bbb3d.renderfarming.net/video/mp4/bbb_sunflower_1080p_30fps_normal.mp4
    It could also be because your videos are mpeg-2 which needs a license key for Raspberry Pi’s. You can activate it in the Raspberry Settings.

    23. September 2015 at 14:43 #15790

    same problem here. (RP2, max2play 2.21, pre-installed kodi running –> 14.2)
    black screen while fullHD videos or a rotating array of coloured squares appears.
    Normal videos (SD) are working properly.

    Video-Source (mkv, h264) cannot be the problem, cause same videos are working fine one separate raspberry pi 2 (without max2play) running openelec kodi 14.1 and without any special licences…

    idea: in kodi 14.1 there is an option, which is missing in 14.2: in Settings -> Appearance -> File lists -> “Support browsing into archives”. maybe this causes the problem (afaik mkv is a container format)?

    23. September 2015 at 15:53 #15793

    I have tried more files, with different resolutions and codecs. None play.
    I was only able to play one file which, after setting the interlacing mode to auto first, and then to off, magically started to show.
    But then, as soon as I hit stop and tried to play it again: black screen, no playback at all (no video, no audio) again.
    None of the videos are mpeg-2, therefore it’s not a licensing problem.
    I’ll try to watch a youtube video and see what happens. I’ll report as soon as I manage to try.
    As for MvD42 above, all the files play correctly on a different device using openELEC.

    • This reply was modified 1 year, 2 months ago by  Sciamano72.
    30. September 2015 at 9:27 #15890

    During the last days i didn’t found a solution for the problem. Maybe kodi 15 solves the problem. Does anybody know when kodi 15 with max2play on raspberry pi will be published or an update will be available? Otherwise i need to buy 3 additional RPs…. :/

    2. October 2015 at 14:13 #15961

    Hi,

    you may try to install a newer Kodi version with this (make sure you have a backup of your SD-card):

    cd /opt
    sudo apt-get remove kodi-bin
    wget http://steinerdatenbank.de/software/kodi-15.tar.gz
    tar -xzf kodi-15.tar.gz
    cd kodi-15
    sudo ./install

    If this works, we will provide an update button on the Kodi page of the Max2Play web interface, to make upgrading easier.

    2. October 2015 at 14:17 #15963

    OK thanks, i will try this asap and report!

    4. October 2015 at 13:08 #15978

    hey guys.

    results of the first try:

    cd /opt
    sudo apt-get remove kodi-bin
    wget http://steinerdatenbank.de/software/kodi-15.tar.gz
    tar -xzf kodi-15.tar.gz
    cd kodi-15
    sudo ./install

    –> works fine

    removing kodi 14, download, installing kodi 15…. no problem.
    but starting kodi after updating doesn’t work.
    the start screen from kodi 15 isengard appears frequently, but no menu. start screen loop.
    i will test it again, with a fresh max2play installation.

    greetings

    sorry for my bad english. once again in german:

    Also das deinstallieren/installieren usw. ging problemlos.
    Nach einem Neustart erscheint das kodi logo und erlischt wieder, erscheint und erlischt…. kodi bootloop also.
    Auch manuelles beenden und starten über die Weboberfläche verschafft keine Abhilfe.
    Ich teste noch ein bisschen weiter mit einer frischen Installation von max2play 2.22….

    Grüße!

    4. October 2015 at 13:57 #15979

    Dear Forum, dear M2P team,

    the concept you have sounded attractive to me, so I thought I would try it out. After 3 hours of fiddling around I am kind of dissapointed:

    – In your newest version (image 2.12), Kodi does not play video
    – after an online update it shows version 2.21 – no change to the kodi video playback issue
    – kodi reports an old version (14.1), so I thought I’ll try to update. On the web interface (http://max2play), an url can be provided to update – when I enter there a kodi update url from the kodi team, an update seems to happen – only to find out that this will result in errors, and kodi will no longer start

    I have an rpi 2, connected over hdmi on a tv which display full hd 50hz

    I am sorry to say, but this is really frustrating.

    Do you have a working m2p version with kodi? Where can I find it? What is the correct procedure to update the shipped kodi version to a newer one?

    5. October 2015 at 9:59 #15988

    Allright guys, i got it to work using a fresh max2play v2.22 image. (I didn’t start kodi 14 before running the update!):

    step by step:

    – download the max2play image v2.22
    – install it on sd-card
    – start the PI, expand the image using the max2play web-surface
    – do the steps described before written by flysurfer
    ATTENTION STEP 3: “wget http://steinerdatenbank.de/software/kodi-15.tar.gz
    use “wget steinerdatenbank.de/software/kodi-15.tar.gz” instead!
    – restart the PI
    – configure kodi as your wishes

    Seems like update does not work, when using kodi 14 before (like my first try… )

    greetings

    P.S.: I’m using a synology diskstation to store my movies. The PI grabs them via NFS with Gigabit-Lan.

    • This reply was modified 1 year, 2 months ago by  MvD42.
    • This reply was modified 1 year, 2 months ago by  MvD42.
    5. October 2015 at 11:26 #16015

    Hi MvD42,

    thanks a lot for the Update and your testing! I also tested some videos and everything is playing fine for me. I discovered no problems with running the Update after playing some videos in the “old” kodi 14 version. But if kodi is not starting as expected, you may see the Log-File with Debug-Information on the kodi page of the Max2Play web interface (at the bottom of the page) in the next Max2Play Version. The current Beta already has this feature. I will add an update Kodi button to the webinterface for the Raspberry PI based on this version.

    @theangryguy: what kind of videos did you test (format)? Do you have test files that are linked somewhere? Please try the Youtube-Video Addon for Kodi or files like this http://distribution.bbb3d.renderfarming.net/video/mp4/bbb_sunflower_1080p_30fps_normal.mp4 (more on http://bbb3d.renderfarming.net/download.html) to make sure your setup is OK (power supply, network, access rights, etc.). This videos should play flawless. To update to Kodi 15.1 you may use the shell commands I posted above, but this won’t change much in your case if videos just don’t play. The updater on the Kodi page of the web interface of Max2Play is currently only working with the ODROIDs (U3, XU4, C1), as it is a little more difficult on the Raspberry Pi to update Kodi – but there will be an option in the next release.

    Cheers,
    Stefan

    13. October 2015 at 20:33 #16345

    Hey there,

    today i tried to install PVR IPTV simple client (v1.11.5) using kodi 15 isengard.
    No problems while installing and configurating.
    But when i tried to start he TV option in Kodi, an error message appears “can’t load dll”
    Any ideas how to solve this?

    14. October 2015 at 12:05 #16354

    Hi MvD42,

    the Raspberry did not have the support for the PVR-Addons from our Max2Play-builds yet … until NOW 😉

    You may update to the latest Beta of Max2Play on the Settings page in the Web interface and then you have to:
    – install Kodi again even if you already have version 15 (just start the installation on the Kodi-tab of Web interface)
    – install the PVR-Plugins Repository from the Addon installer on the Kodi-tab in Max2Play Web interface, which now also work for the Raspberry
    – activate the desired PVR-Plugin in Kodi: System -> Addons -> Install from Repository (Choose Max2Play Repository)
    – enable Live TV in Settings

    This feature will be available in the next Release version 2.23 and is now in Beta testing.

    • This reply was modified 1 year, 1 month ago by  flysurfer.
    14. October 2015 at 12:28 #16356

    wow cool! oneca again: i will test it. 😉
    What about streaming addons like xstream? i didn’t got that to work as well, because the addon was not installable….

    14. October 2015 at 15:01 #16358

    I don’t know anything about xstream, but YouTube, Zattoo, twitch and other apps are working without problems and can be installed as video add-ons in kodi.

    14. October 2015 at 15:08 #16359

    I tried to install the xstream-Addon via repository from http://xstream-addon.square7.ch

    direct link: http://xstream-addon.square7.ch/link_counter.php?url=http://xstream-addon.square7.ch/repo/repository.xstream/repository.xstream-1.0.5.zip

    • This reply was modified 1 year, 1 month ago by  MvD42.
    14. October 2015 at 15:24 #16365

    As I said – I don’t know anything about this special add-on, but when adding other repositories, these must:
    – be build with the current platform version of kodi (kodi 15 in that case)
    – offer ARM-binaries (if they use binaries, and some do) to run on the Raspberry Pi/Odroid. That’s why we built the PVR-Addons and offer them for download in our Repository

    And please do not link any stuff that might violate copyrights…

    14. October 2015 at 15:55 #16368

    Hey flysurfer,

    ok i think ich will just test it again.
    Xstream i definitely compatible to RPis and Kodi 15….

    ok sorry. Will never do it again 🙂

    14. October 2015 at 18:54 #16371

    it’s me again.
    Testet PVR IPTV simple client using your tutorial.
    same error as described before: “unknown error. can’t load dll” when trying to activate LiveTV.

    14. October 2015 at 18:59 #16372

    Can you try the pvr Demo addon to see if that works?

    14. October 2015 at 19:12 #16373

    tried it. same error message as before

    15. October 2015 at 12:03 #16380

    If the demo plugin does not work – something during your installation went wrong. If you use a current sd-card-image (e.g. Max2Play version 2.22) and follow the points I wrote above, it should work (just tested it again to make sure it really does).

    IMPORTANT: as this is still in BETA-Mode you MUST update Max2Play to the current Beta before doing the update on Kodi (click on Beta Update on Settings Page!).

    15. October 2015 at 12:18 #16384

    ok that’s weird.
    Steps i did:
    – burnt the Image on MicroSD –> so i used a fresh M2P-Installation
    – changed IP to static, changed network-name, registered to M2P, expanded the image
    – updated to beta (affirmated by hint on webinterface that i am using a beta version)
    – updated Kodi and started to make sure kodi 15 is running
    – added pvr-repository
    – started kodi to test

    I will do the steps again, without changing IP and stuff and without starting kodi before PVR-repository is added.
    Maybe this helps. I will report next days.

    • This reply was modified 1 year, 1 month ago by  MvD42.
    18. October 2015 at 14:39 #16420

    ok, had time to test again.

    installed the now offical m2p v2.23 image.
    updated kodi
    updated pvr addons
    started

    The demo pvr client starts without any problems. but PVR IPTV simple client does net start.
    It says “Add-on couldn’t be loaded. An unknown error has occured. Can’t load Dll”

    Where can i find the logfile?

    • This reply was modified 1 year, 1 month ago by  MvD42.
    19. October 2015 at 14:25 #16427

    Hi,

    I recreated a repository for the Raspberry Pi now, as some addons did not work when using the repository with the ODROID builds.
    Now all you need to do, is a Update to latest Beta and then you will find the “PVR-Addons for Raspberry Pi” installer on the Kodi tab of the web interface. With this repository it should work (got at least no DLL-Error when testing). Make sure to remove the the ODROID Repository and uninstall the addons before trying the new repository.

    Thanks for your feedback and ongoing testing!

    19. October 2015 at 17:43 #16431

    Hi,

    @MvD42: It worked for me! Thank you very much! Spend hours to find a solution. -.-

    @M2P: Please fix the RPI-Image or make a not for others! Thank you for your awesome yob!

    Regards

    Tim

    21. October 2015 at 1:14 #16449

    hey guys.

    @ xardas: nice to hear 🙂 what worked for you precisely? which part of this thread?

    @ flysurfer: my pleasure 🙂 M2P is awesome, you do a great job. i’m feeling like a beta-tester^^ but the the best part is the following: you are located in Leipzig, Käthe-Kollwitz-Straße right? So we are neigbours =D

    testet it with a fresh image v2.22
    -updated to 2.23, reboot
    -updated kodi, reboot
    -updated to beta, reboot
    -installed RPi PVR repository, reboot
    -started kodi

    Only neccesary settings were set.

    can’t install any of the PVR-addons including demo plugin. i’m getting always a “installation failed”
    i varied the updated process as described before (p.e. tried to update kodi in beta) and testet it a view times. no success.

    good news:
    mananged it to install the xstream plugin. was my fault.

    21. October 2015 at 13:52 #16465

    Hi MvD42,

    I am sorry… well – indeed you are a Beta-Tester. We did not have the PVR-Addons for the Pi yet and we do not have the hardware to test them… During my testing I forgot to set up the repository the right way for the PI packages. This did not occur when I had the Odroid packages installed before. Now I fixed the Repository and you can install the Addon. The “installation failed” should not come up anymore.

    Thanks for your help!

    21. October 2015 at 19:40 #16466

    woooooooohooooooooooooooooooooooooo!!
    it works! big big thanks!!
    *dance* 🙂

    now i can setup my entire project!! :

    5 PIs
    – 2 of them via LAN & dLAN, used with Kodi (TV, movies, series, streaming) & Squeezebox Player (using USB-soundcard)
    – 2 of them via WLAN, used as Squeezebox Player
    – 1 of them via LAN, used as Squeezebox Server

    all medias are saved on a Synology DS212.

    Thanks Max2Play for providing the base. You are awesome!

Viewing 29 posts - 1 through 29 (of 29 total)

You must be logged in to reply to this topic.

Register here