Kodi + Netflix

Tagged: 

This topic contains 2 replies, has 3 voices, and was last updated by  Hogo premium 7 months, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 5. März 2019 at 17:27 #44663

    Hello.

    I have a Raspi 3B+ with a DigiOne soundcard.

    I installed Kodi 18 Leia through M2P web interface

    I installed Netflix’s Kodi plugin v1.0.1 through Kodi’s interface but it gives me an error.

    Did anyone face the same issue? Did anyone manage to fix it?

    Best,

    Notroot

    7. März 2019 at 17:11 #44695

    Hi Notroot,

    I don’t think there is a plugin by Netflix for Kodi.

    If it’s this solution, you can try following their course of action, mainly looking at and copying the log from Kodi:

    Something doesn’t work
    If something doesn’t work for you, please:

    Make sure all prerequisites are met
    Enable verbose logging in the plugin settings
    Enable the Debug log in you Kodi settings
    Open an issue with a titles that summarises your problems

    18. Februar 2022 at 22:23 #52064

    I had the same problem.
    The Netflix addon is installed from the castagnaIT repo. I had this repo on my NAS and installed the repo & addon directly in kodi, not via the max2play repo installation function.

    The error log reads as this:

    2022-02-18 19:31:08.462 T:1630507232   ERROR: [plugin.video.netflix (0)] Background services do not start due to the following error
    2022-02-18 19:31:08.476 T:1630507232   ERROR: [plugin.video.netflix (0)] Traceback (most recent call last):
                                                  File "/home/pi/.kodi/addons/plugin.video.netflix/resources/lib/run_service.py", line 68, in init_servers
                                                    self._init_server(server)
                                                  File "/home/pi/.kodi/addons/plugin.video.netflix/resources/lib/run_service.py", line 89, in _init_server
                                                    (self.HOST_ADDRESS, select_port(server['name']))
                                                  File "/home/pi/.kodi/addons/plugin.video.netflix/resources/lib/services/msl/http_server.py", line 95, in __init__
                                                    self.msl_handler = MSLHandler()
                                                  File "/home/pi/.kodi/addons/plugin.video.netflix/resources/lib/services/msl/msl_handler.py", line 76, in __init__
                                                    self._init_msl_handler()
                                                  File "/home/pi/.kodi/addons/plugin.video.netflix/resources/lib/services/msl/msl_handler.py", line 100, in _init_msl_handler
                                                    self.msl_requests = MSLRequests(msl_data)
                                                  File "/home/pi/.kodi/addons/plugin.video.netflix/resources/lib/services/msl/msl_requests.py", line 36, in __init__
                                                    super(MSLRequests, self).__init__()
                                                  File "/home/pi/.kodi/addons/plugin.video.netflix/resources/lib/services/msl/msl_request_builder.py", line 32, in __init__
                                                    from .default_crypto import DefaultMSLCrypto as MSLCrypto
                                                  File "/home/pi/.kodi/addons/plugin.video.netflix/resources/lib/services/msl/default_crypto.py", line 29, in <module>
                                                    from Crypto.Util import Padding
                                                ImportError: cannot import name Padding

    Solution: sudo apt install python-pycryptodome

    • This reply was modified 7 months, 2 weeks ago by  Hogo.
Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here