Kodi: FullHD (H.264/AAC) Aussetzer / lag in display of full HD video

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Kodi: FullHD (H.264/AAC) Aussetzer / lag in display of full HD video

This topic contains 0 replies, has 1 voice, and was last updated by  klama 6 months, 2 weeks ago.

Viewing 1 post (of 1 total)
  • 30. January 2017 at 6:39 #26397

    Ich bin etwas überrascht dass in Kodi die Einstellung Hardwarebeschleunigung für den OMX Player abgeschaltet ist. Dies führt dazu dass es bei Wiedergabe von FullHD Videos die den H.264 MP4 Codec verwenden zu regelmäßigen Aussetzern kommt un man Videos in dieser Auflösung nicht wirklich störungsfrei ansehen kann. Bei Abruf der Systemleistung während des Abspielens wird klar dass das Problem darauf zurückzuführen ist, dass alle vier Prozessorkerne des Pi komplett ausgelastet sind (>99% Systemleistung). Das sollte eigentlich nicht der Fall sein. Die Hardwarebeschleunigung läßt sich unter System -> Video -> Settings level: Expert | Acceleration bzw. Beschleunigung und Aktivieren der Hardwarebeschleunigung für alle Wiedergabe Medien (OMXPlayer, etc.) einschalten. Ich würde vorschlagen dass diese Option in zukünftigen Distributionen von Max2Play als Voreinstellung aktiviert wird. Nach Aktivieren fällt die Auslastung der Prozessorkerne während der Videowiedergabe selbst bei 1920 x 1080 @ 30 fps auf 1-2 Prozent ab und die Videos werden ohne Ruckeln wiedergegeben.

    I’m surprised that hardware-accelerated video playback isn’t activated in Kodi by default. As a consequence, playback of H.264 fullHD video is laggy and watching of high quality video becomes impossible. Software-decoding of high-resolution video drives the utilization of all four processor cores to about 100% as reported by the system performance meter. Activating hardware acceleration decreases the use of the processor down to about 1-2%. This can be achieved by selecting: System -> Video -> Settings level: Expert | Acceleration and then activating all settings that involve hardware acceleration (e.g. omxplayer). I would kindly suggest to activate this setting as a default in all future distributions of max2play.

    Best,
    Klama

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

Register here