Kodi audio output – Enable Passthrough

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Kodi audio output – Enable Passthrough

Tagged: , ,

This topic contains 2 replies, has 2 voices, and was last updated by  karoshi premium 1 year, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • 31. October 2015 at 19:36 #16667

    Hi everyone,

    I have a question relating to audio output on Kodi.

    I have a Raspberry Pi2 and HifiBerry Digi+. I am using the Max2Play HiFiBerry Image (Raspberry PI). I will be using this Pi for watching movies.

    In the Kodi System Settings if I select the “Enable Passthrough” option it is greyed out to “PI: HDMI”. I would like to change the passthrough to the HifiBerry soundcard but I can’t.

    This person has a similar issue on a Hifiberry but is NOT using Max2play:
    http://support.hifiberry.com/hc/en-us/community/posts/201845791-Kodi-no-passthrough

    There is a patch but I don’t know if installing this will mess with the Max2Play installation or future Max2Play updates.

    Ideally I would like to output audio to both HDMI and also to the HifiBerry Digi+. But I believe this is a totally separate issue and may not be possible. The reason I want to do this is sometimes i want to listen to audio via my TV (HDMI) and sometimes via surround sound (via my HiFiBerry Digi Soundcard).

    However as a first step if I can get the enable passthrough set to the HiFiBerry Digi I would be really happy.

    Any help or advice would be most appreciated. Thanks so much!

    11. November 2015 at 16:32 #16848

    Hi karoshi,
    Sorry for your issues. We are looking into it and it seems like the problem is that Kodi recognizes the Digi as an analog output. We will try to find a fix for this to put in a later update. Right now, we would recommend using the HDMI output since it also puts out the same signal the Digi does. If you want you can also of course try and implement the fix from your link, but that should be a demanding task. For Kodi, HDMI should be the perfect solution.

    12. November 2015 at 0:23 #16865

    Hi Heiner,

    Many thanks for the reply I really appreciate it.

    My surround processor doesn’t have HDMI inputs as it is old, but since it gives a high quality sound I really would like to use it with the Hifiberry/Pi. I will take your advice though and use HDMI for now with my TV sound.

    Thanks again for such great software. Really enjoying Max2play.

    Cheers for now

    Karoshi

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Register here