[SOLVED] Kodi (17.1) streams music, but not to the amplifier

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Kodi (17.1) streams music, but not to the amplifier

This topic contains 9 replies, has 3 voices, and was last updated by  Mbydeen Moderator 2 weeks, 6 days ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 28. April 2017 at 14:19 #28617

    Hello,
    Kodi (17.1) streams music, but not to the amplifier, only to the TV.
    Details:
    – Raspberry PI 2
    – HiFiBerry Digi+ standard
    – Max2Play V2.42 with Squeezelite
    – JustBoom Smart Remote
    – Audio-amplifier, connected to soundcard via electric digital cable.
    – TV, connected to raspberrypi by hdmi-cable.
    Problem: as said above, under KODI music is streamed only to the TV, not to the amplifier. In the KODI-preferences there are only four options:
    Audioausgabegerät:
    PI: HDMI
    PI: Analogue
    PI: HDMI and analogue
    ALSA: Default (bcm2835 ALSA bcm2835 ALSA)
    Chosen is the fourth (ALSA) option.
    Although the HiFiBerry card is installed and works correctly under Squeezelite, it is not shown in the Kodi-options.
    The extended options for Squeezelite under „Audioplayer“ are:
    „sysdefault – snd_rpi_hifiberry_digi, – DEFAULT AUDIO DEVICE, card=sndrpihifiberry“
    Where is my mistake? Can you help me?

    goestr

    2. May 2017 at 11:33 #28654

    Hi goestr,

    Could you please check the following link:

    https://www.max2play.com/en/wiki/kodixbmc/

    Best Regards,
    Mohammad Mbydeen

    4. May 2017 at 12:41 #28696

    Hi Mohammad Mbydeen,
    many thanks for giving me link!
    The main informations in this link were
    1. use the actual version of KODI,
    2. disable any kind of audio-players,
    3. disable the onboard-audio in case of additional sound cards.
    I use the KODI-Version 17.1, which is the latest version.
    max2play disables automaticly the Squeezelite-player, if KODI is enabled.
    Disabling the onboard-audio seems a problem to me, because in the „Raspberry Einstellungen“ there is only the choice between Standard, Earphone-connection and HDMI. There is no possibility to disable onboard-audio.
    I choose „Earphone-connection“ to avoid audio being streamed over HDMI, but in the KODI-preferences (Audio output device) was no difference against the statements in my first mail.
    So the open question is: how can I disable onboard-audio?
    Thanks for help,
    goestr

    4. May 2017 at 15:52 #28707

    very easy: Goto page “Raspberry Einstellungen” and enable checkbox at “Deaktiviere integriertes Audio bei RPi3”.
    this is working fine on my raspi3 with kodi. took some time to get that 😉

    ignore that hdmi configuration, does not affect anything. the problem ist, that kodi uses first soundcard, which is rpi builtin bcm. Disable that and your soundcard will become the first in system and become visible for kodi.

    enjoy!

    4. May 2017 at 18:34 #28708

    Hello mtk,
    thank you for this hint! It brought the solution. The funny thing is that I use a RasPi 2 and the option is for the RasPi 3.
    But nevertheless it works.
    Being new to this forum I cannot find the button for “solved”. Have you got an idea?
    Thanks!

    goestr

    4. May 2017 at 18:57 #28710

    🙂
    its somehow misleading that they call it for “RPi3”, it just disables buitin driver for BCM chip, which is used for HDMI. An that is working on all kind of rpi.

    Concering a solved button I cannot help. Seems to be a simple worpress site. If there is any ticket mechanism like “github or co” I dont know …

    5. May 2017 at 14:06 #28718

    mtk,

    maybe on the RPI3 the problems are worse. But I agree that it would be enough to write “Deaktiviere integriertes Audio” in the RPI-preferences.

    There must be a possibility to change the topic, because there are topics in this forum with [Solved]. So lets close this topic between us two.

    Again many thanks for your qualified help!

    goestr

    8. May 2017 at 12:00 #28741

    Hello goestr,

    We have edited the Wiki article, you should disable only MPD music player,”if you have installed it” in order to start Kodi. And as mtk mentioned, you can disable the onboard audio, by going to “Raspberry Settings” and disable it.

    We have fixed the option for Disable Build-In-Audio on “Raspberry Settings”, to make it more clear.

    Thank you for your feedback, we will mark this thread as “SOLVED”.

    Best Regards
    Mohammad Mbydeen

    • This reply was modified 2 weeks, 6 days ago by  Mbydeen.
    8. May 2017 at 12:12 #28744

    Hi @ all
    FYI: the way I described is working also with MPD. So if you are planning to use MPD also, better disable onboard sound … 🙂 makes live at this point much more easier. You will loose hdmi sound but you dont need it any more if there is a sound path via soundcard.

    michael

    8. May 2017 at 14:05 #28749

    @ mtk

    You can run MPD and Kodi in the same time if you have an additional sound card, for example, use the builtin audio output for the MPD and the sound card output for the Kodi.

    What I meant, that kodi and MDP cant use the “same” audio output.

    Best Regards,
    Mohammad Mbydeen

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here