Kein Ton via HDMI

This topic contains 8 replies, has 2 voices, and was last updated by  Heiner Moderator 2 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 20. Dezember 2018 at 21:30 #42929

    Hallo,

    hatte schon im Forum gesucht, aber keine Lösung finden können:
    ich nutze den Raspi ohne separate Soundkarte mit Squeezelite. Über Klinkenausgang bekomme ich Ton, würde aber gerne HDMI nutzen.
    Es ist mir aber bisher nicht gelungen damit eine Soundausgabe zu erzeugen.
    Ich habe in den Einstellungen die Soundausgabe auf HDMI umgestellt, bei den erweiterten Optionen des Squeezelite auch schon diverse Einstellungen versucht (Soundkarten). Leider alles ohne Erfolg.
    Wäre super, wenn mir da jemand einen guten Tipp geben könnte.

    Gruß
    Michael

    3. Januar 2019 at 10:31 #43032

    Hallo Michael,

    Starte einmal den Pi neu mit dem Audiogerät über HDMI bereits angeschlossen und angeschaltet. Sollte das nicht helfen, kopier bitte einmal deine debug info vom Audioplayer hierher.

    10. Januar 2019 at 16:49 #43425

    Hallo Heiner,

    habe ich jetzt mal versucht, kein Erfolg.
    Debug Info kommt unten.
    Leider habe ich jetzt nach zurückstellen auf Kopfhörer leider auch keinen Ton mehr …
    Raspi schon mehrmals neu gestartet.

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.
     
    
    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC
     
    
    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o dmix:CARD=ALSA,DEV=1 -a ::32:0 -C 5
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=ALSA
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=--webport 8081
     
    
    #### SQUEEZELITE -l ####
    Output devices:
      null                           - Discard all samples (playback) or generate zero samples (capture)
      equal                         
      plugequal                      - Equalizer for plughw:0,0
      default:CARD=ALSA              - bcm2835 ALSA, bcm2835 ALSA - Default Audio Device
      sysdefault:CARD=ALSA           - bcm2835 ALSA, bcm2835 ALSA - Default Audio Device
      dmix:CARD=ALSA,DEV=0           - bcm2835 ALSA, bcm2835 ALSA - Direct sample mixing device
      dmix:CARD=ALSA,DEV=1           - bcm2835 ALSA, bcm2835 IEC958/HDMI - Direct sample mixing device
      dsnoop:CARD=ALSA,DEV=0         - bcm2835 ALSA, bcm2835 ALSA - Direct sample snooping device
      dsnoop:CARD=ALSA,DEV=1         - bcm2835 ALSA, bcm2835 IEC958/HDMI - Direct sample snooping device
      hw:CARD=ALSA,DEV=0             - bcm2835 ALSA, bcm2835 ALSA - Direct hardware device without any conversions
      hw:CARD=ALSA,DEV=1             - bcm2835 ALSA, bcm2835 IEC958/HDMI - Direct hardware device without any conversions
      plughw:CARD=ALSA,DEV=0         - bcm2835 ALSA, bcm2835 ALSA - Hardware device with all software conversions
      plughw:CARD=ALSA,DEV=1         - bcm2835 ALSA, bcm2835 IEC958/HDMI - Hardware device with all software conversions
    
     
    
    #### SHAIRPORT (SYNC) VERSION ####
    3.1.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc
     
    
    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed
     
    
    #### OUTPUT SOUND DETAILS CARD 1 ####
     
    
    	
    10. Januar 2019 at 16:58 #43426

    Ton via Klinke läuft wieder, mußte über erweiterte Optionen die Soundkarte wieder auf default umstellen

    Gruß
    Michael

    11. Januar 2019 at 16:51 #43530

    Hallo Michael,

    Wir werden dies versuchen hier nachzustellen. Bei der Option „hw:CARD=ALSA,DEV=1“ kommt bei dir auch kein Ton über HDMI an? Hast du ggf. ein anderes Gerät mit HDMI-Eingang zum Testen, um dies als potenzielle Fehlerquelle ausschließen zu können?

    12. Januar 2019 at 12:45 #43552

    Hallo Heiner,

    auch direkt an einem TV angeschlossen bekomme ich keinen Ton (Bild ist da)
    Wenn ich auf „hw:CARD=ALSA, DEV=1“ umstelle läuft im Squeezeplayer (Squeezelite) nicht mal die Fortschrittsanzeige.
    Bei anderen Einstellungen (Default, Sysdefault) läuft die Fortschrittsanzeige, sobald ich eine Einstellung mit Dev=1 wähle geht es nicht mehr.
    Hier nochmal die Debug Info für „hw:CARD=ALSA,DEV=1“

    Gruß
    Michael

    
    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.
     
    
    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC
     
    
    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o hw:CARD=ALSA,DEV=1 -a ::32:0 -C 5
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=ALSA
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=--webport 8081
     
    
    #### SQUEEZELITE -l ####
    Output devices:
      null                           - Discard all samples (playback) or generate zero samples (capture)
      equal                         
      plugequal                      - Equalizer for plughw:0,0
      default:CARD=ALSA              - bcm2835 ALSA, bcm2835 ALSA - Default Audio Device
      sysdefault:CARD=ALSA           - bcm2835 ALSA, bcm2835 ALSA - Default Audio Device
      dmix:CARD=ALSA,DEV=0           - bcm2835 ALSA, bcm2835 ALSA - Direct sample mixing device
      dmix:CARD=ALSA,DEV=1           - bcm2835 ALSA, bcm2835 IEC958/HDMI - Direct sample mixing device
      dsnoop:CARD=ALSA,DEV=0         - bcm2835 ALSA, bcm2835 ALSA - Direct sample snooping device
      dsnoop:CARD=ALSA,DEV=1         - bcm2835 ALSA, bcm2835 IEC958/HDMI - Direct sample snooping device
      hw:CARD=ALSA,DEV=0             - bcm2835 ALSA, bcm2835 ALSA - Direct hardware device without any conversions
      hw:CARD=ALSA,DEV=1             - bcm2835 ALSA, bcm2835 IEC958/HDMI - Direct hardware device without any conversions
      plughw:CARD=ALSA,DEV=0         - bcm2835 ALSA, bcm2835 ALSA - Hardware device with all software conversions
      plughw:CARD=ALSA,DEV=1         - bcm2835 ALSA, bcm2835 IEC958/HDMI - Hardware device with all software conversions
    
     
    
    #### SHAIRPORT (SYNC) VERSION ####
    3.1.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc
     
    
    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed
     
    
    #### OUTPUT SOUND DETAILS CARD 1 ####
     
    
    	
    14. Januar 2019 at 15:06 #43589

    Check bitte mal in deinen Raspberry Einstellungen ob build in audio aktiv ist. Wenn nicht aktiviere es und starte neu. Wenn schon, deaktiviere es, starte neu, aktiviere es wieder starte nochmal neu.

    16. Januar 2019 at 21:22 #43763

    Das hat leider nichts bewirkt:
    Die Option „Disable Build-In-Audio“ war nicht aktiv, so sollte es ja auch sein.
    Habe es dann mal aktiviert und nach Neustart wieder deaktiviert.

    17. Januar 2019 at 17:22 #43840

    Sehr seltsam, kannst du einmal die Wiedergabe über Kodi und dessen Auswahloptionen für Audiogeräte checken, um sicherzugehen dass mit dem HDMI alles in Ordnung ist?

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here