JustBoom Amp Hat wird nicht erkannt / is not recognized

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI JustBoom Amp Hat wird nicht erkannt / is not recognized

This topic contains 17 replies, has 3 voices, and was last updated by  Heiner Moderator 3 months, 3 weeks ago.

Viewing 18 posts - 1 through 18 (of 18 total)
  • 10. Juni 2018 at 16:18 #36143

    Hallo zusammen,

    unter Kodi wird auf dem Gerätemonitor unter den Audioeinstellungen JustBoom nicht zur Auswahl angeboten, nur
    a) HDMI
    b) Analog
    c) HDMI und Analog
    – keine weiteren Einträge

    Der Kernel ist gemäß Anweisung upgedated (Systeminfo auf Gerätemonitor: 4.14.44 V7+)

    Unter Hardware-Informationen wird der JustBoom auf dem Gerätemonitor NICHT angezeigt. Ist das so korrekt, oder müsste dieser dort erscheinen?

    Offensichtlich wird der JustBoom systemseitig nicht erkannt!?

    Was mache ich falsch, was ist zu tun?

    =======
    Hello everybody,

    under Kodi, JustBoom is not available for selection on the device monitor under the audio settings, only
    a) HDMI
    b) Analog
    c) HDMI and analog
    – no further entries

    The kernel is updated as instructed (System info on device monitor: 4.14.44 V7 +)

    Under Hardware information, the JustBoom is NOT displayed on the device monitor. Is that correct, or should it appear there?

    Obviously the JustBoom is not recognized by the system !?

    What am I doing wrong, what to do?

    12. Juni 2018 at 16:00 #36170

    Hi chrimoe,

    Please deactivate build in audio in the Raspberry Settings and make sure that the Amp HAT is selected properly in the JustBoom plugin.

    12. Juni 2018 at 21:05 #36173

    Hello Heiner,
    Thanks for your answer, but what you suggested is already done before.
    Are there possibly other reasons?
    Or do I have to reckon with a defect of the Justboom card?
    What is likely?

    13. Juni 2018 at 16:37 #36184

    Hi chrimoe,

    Our new Stretch image already has the compatible kernel for JustBoom cards preinstalled (we will get rid of this info for the next version, thanks for making me aware of this error). Please try burning a new image, just selecting JB Amp HAT and rebooting.

    14. Juni 2018 at 20:34 #36199

    Hi Heiner,
    thanks for your answer.
    In the past, I have taken the image for the 7″ touch display, because I have one installed and on the max2play sites ja recommended to take this image! Have I done a mistake?

    Now I habe a request for you: Please can you explain the differences between both versions. I would like to avoid having other problems with the stretch version, eg. with my touch display oder installing other plugins.

    Thanks for your understanding in advance.

    Christian

    17. Juni 2018 at 20:46 #36226

    Hello,

    I have flashed the sd card with the newest image (stretch).

    Beforehand: I follow the configuration instructions eg. for Kodi from the Justboom page to!

    I am sorry to say it, but this image are a little bit buggy: It’s not able to reboot correctly eg. after choosing the audio card. The RPI try to initialize to the network, every 15 seconds without a value (endless loop!!!). A break is only pooible with a switch off of the whole device!

    In addition, I can only following entry on the KODI configurations screen for the audio devices: ALSA (without a device to the Justboom card). If I choose that, nothing happens, no sound. The hardware is connected without any failure, it’s aproved many times.

    What should I do?

    18. Juni 2018 at 21:25 #36247

    Hello support,

    despite the new image, a kernel update is offered. Is it necessary to install the kernel update. Without this, a reboot isn’t possible, the RPI crashes!!!

    To finish my hifi project, I need urgently answers / support!!!

    19. Juni 2018 at 14:18 #36257

    Hi Christian,

    If you write new posts, your topic gets automatically bumped up the chain and I will get to it later as I answer chronologically. Please edit your post instead the next time and I will be able to answer you more quickly. 😉

    – Both the 7 inch image (jessie) and the new image (stretch) should work. With jessie, you need the kernel upgrade, with stretch you do not.

    – for Kodi, you need to deactivate build in audio in the Raspberry Settings and reboot

    – your Pi should not crash after reboot, could you share the error message you receive?

    – for the 7″ Touchscreen you need the RPi Display plugin, after selecting and installing the 7″ RPi Display and rebooting, it should work right away.

    19. Juni 2018 at 20:08 #36262

    Hi Heiner,

    thanks for your support.

    All topics you have listed, I have donebefore!

    Following situation:
    With a fresh flashed image (stretch) the device start with a hint to dhcp (row in start sequence).

    Further, when all settings are done and a reboot is necessary the RPI crash: The RPI tried to start the network time synchro in an endless loop as descriped in my last post. My only chance is to switch off the device.
    When I start the RPI after the crash manuel, at first the RPI reports a sdcard failure (three lines). After this the boot sequence runs normal.

    BUT: I can’t choose in the Kodi settings my justboom, only hdmi and analogous, although I can see in the max2play web interface at the RPI settings that the justboom is set!!!

    In the Kodi/XBMC tab „Autostart“ is set.

    If I try to connect to the RPI via putty with the formaly known user and password the access will be denied. In the past it’s was possible!

    Slowly I despair!!!!!

    20. Juni 2018 at 13:51 #36274

    Hi chrimoe,

    You select the audio output device for kodi in kodi’s own settings under audio.

    You can enter SSH with user pi and pw max2play. if you want to execute commands as root, use the command „sudo su“.

    Does playback from Squeezelite or Shairport work? Is the selection for JustBoom listed in the Squeezelite’s sound card selection?

    7. Juli 2018 at 22:22 #36480

    I have opened a new entry for my problem(s).

    The just boom is NOT listed! What is going wrong???

    11. Juli 2018 at 11:36 #36529

    As mentioned, this sounds like a hardware issue. I look forward to checking the card out myself.

    21. August 2018 at 21:30 #37077

    Hi there,

    I seem to have a similar issue – identical hardware spec (RPi3 JB Amp HAT) – installed newest (stretch) image, updated everything (didn’t go for beta release yet), disabled build-in audio and having no joy of trying to get the speakers to speak.
    I’m trying to get ympd to play anything for now, just so I’m sure i got it working right before I dive into trying to setup everything else.
    The difference is that I’m in possession of 2 Amp HATs and both are acting exactly the same so unless there was a dodgy batch of VER 1.1 HATs from JustBoom and I happened to get both or its a software issue somewhere.
    Any advice on what else I could try/test? Also my system is not installed on Class10 sd card and rather on Class4 but I hope it should make any difference for the hardware to be usable.

    Thanks

    A

    22. August 2018 at 12:04 #37103

    Hi alex,

    We do recommend Class 10 or higher, first of all.

    Please try the advanced option Squeezelite, select „none“ in the sound card selection, reboot, select JB Amp HAT, reboot and copy the Squeezelite debug info here.

    22. August 2018 at 22:36 #37147

    Hi Hiner,

    I’ve just started with fresh install on class10 card.
    On first boot chosen to my amp card and proceeded with reboot.
    Upon reboot it loops on network time synchronization but as far as I can remember it was something to do with bad entry in config.txt (had to comment out justboomdac or something similar).
    After successful boot I’ve activated my license – proceeded with updates to max2play (to 2.46), reboot, disabled build in audio, reboot (few actually due to that bug with network time sync). Upgraded kernel to 4.14, reboot, apt-get update/upgrade, got error – unable to get some packages – try –fix-missing (probably a mirror is down or something). Done apt-get update/upgrade manually, reboot.
    Set ‚advanced‘ in JustBoom, and here’s the debug from squeezelite:

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.2 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.
     
    
    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC
     
    
    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpijustboomd -a 80:4:: -o hw:CARD=sndrpijustboomd -V Digital -Q
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=sndrpijustboomd -t hardware -m hw:CARD=sndrpijustboomd -c Digital
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=--webport 8081
     
    
    #### SQUEEZELITE -l ####
    Output devices:
      null                           - Discard all samples (playback) or generate zero samples (capture)
      equal                         
      plugequal                      - Equalizer for plughw:0,0
      default:CARD=sndrpijustboomd   - snd_rpi_justboom_dac,  - Default Audio Device
      sysdefault:CARD=sndrpijustboomd - snd_rpi_justboom_dac,  - Default Audio Device
      dmix:CARD=sndrpijustboomd,DEV=0 - snd_rpi_justboom_dac,  - Direct sample mixing device
      dsnoop:CARD=sndrpijustboomd,DEV=0 - snd_rpi_justboom_dac,  - Direct sample snooping device
      hw:CARD=sndrpijustboomd,DEV=0  - snd_rpi_justboom_dac,  - Direct hardware device without any conversions
      plughw:CARD=sndrpijustboomd,DEV=0 - snd_rpi_justboom_dac,  - Hardware device with all software conversions
    
     
    
    #### SHAIRPORT (SYNC) VERSION ####
    3.1.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc
     
    
    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: MMAP_INTERLEAVED
    format: S32_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 882
    buffer_size: 3528
     
    
    #### OUTPUT SOUND DETAILS CARD 1 ####
     
    
    
    23. August 2018 at 9:46 #37183

    Hi alex,

    Looks good, the parameters with justboom_dac in the name are the driver for the Amp. You can select sysdefault:CARD=sndrpijustboomd - snd_rpi_justboom_dac, - Default Audio Device for Squeezelite and this should route the audio output directly through the Amp. You can install the LMS with one click, do the first steps by skipping and test some radio station’s playback to make sure the output works.

    23. August 2018 at 23:45 #37237

    Success!
    I can report the sound coming out of my speakers, installed LMS and this part is working fine.
    Thanks for advice. Now I’ll get onto figuring out how to get kodi to use the amp instead of HDMI output but that’s whole different topic.

    Thanks

    24. August 2018 at 15:06 #37264

    Hi alex,

    Great to hear! Deactivate build in audio (RPi Settings), reboot, select none in JB plugin, reboot, select JB AMP HAT in JB plugin, reboot.

    Kodi only displays the first sound card slot. By deactivating the build in audio, the amp should jump into the visible options.

Viewing 18 posts - 1 through 18 (of 18 total)

You must be logged in to reply to this topic.

Register here