Just got a new Camera V2 but it don't work.

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Just got a new Camera V2 but it don't work.

This topic contains 3 replies, has 1 voice, and was last updated by  Raymond Day premium 7 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 4. January 2017 at 19:09 #25533

    I put the camera V2 on my Raspberry PI B and I all ready have a camera V1 on my Raspberry PI 2 and that one works real good on it. But it’s the old camera.

    The new one looks like this:

    uploaded it to my Google photo

    I did some settings and now it just stays at a big red Loading for a few sec. then goes back to a little cube that I guess says can’t load.

    Is there some setting or is the Raspberry PI B to slow for the Camera V2?

    -Raymond Day

    4. January 2017 at 19:18 #25535

    When I start it it pops up a windows that says this:

    199.168.2.157:90 syas:

    Error in RaspiMJPEG:
    Restart RaspiMJPEG (.RPi_Cam_Web_Interface_installer.sh start) or the
    whole RPI.

    Then all I can click is OK and it still don’t work.

    4. January 2017 at 19:24 #25536

    I looked on Google for the error and I found this.

    So guess I have to update and I log in to it and it says this:

    The following packages have been kept back:
    kodi kodi-bin
    The following packages will be upgraded:
    apache2-utils base-files bash bind9-host curl dpkg dpkg-dev ffmpeg file
    firmware-atheros firmware-brcm80211 firmware-libertas firmware-ralink
    firmware-realtek fontconfig fontconfig-config ghostscript gnupg gpgv
    gstreamer0.10-alsa gstreamer0.10-plugins-base idle-python2.7 imagemagick
    imagemagick-common java-common libarchive12 libass4 libavcodec53
    libavfilter2 libavformat53 libavutil51 libbind9-80 libc-bin libc-dev-bin
    libc6 libc6-dev libcurl3 libcurl3-gnutls libdns88 libdpkg-perl
    libfontconfig1 libgcrypt11 libgd2-xpm libgme0 libgraphite2-2.0.0 libgs9
    libgs9-common libgstreamer-plugins-base0.10-0 libhogweed2 libicu48 libidn11
    libimlib2 libisc84 libisccc80 libisccfg82 libjasper1 liblwres80 libmagic1
    libmagickcore5 libmagickcore5-extra libmagickwand5 libmpg123-0 libmpg123-dev
    libmysqlclient18 libnettle4 libnspr4 libnss3 libpoppler19 libpython2.7
    librsvg2-2 librsvg2-common libsmbclient libsqlite3-0 libssl-dev libssl-doc
    libssl1.0.0 libsystemd-login0 libtasn1-3 libtiff4 libtiff4-dev libtiffxx0c2
    libwbclient0 libwmf0.2-7 libx11-6 libx11-data libx11-dev libx11-doc
    libx11-xcb1 libxapian-dev libxapian22 libxfixes3 libxi6 libxml2 libxrandr2
    libxrender1 libxslt1.1 libxtst6 libxv1 locales multiarch-support
    mysql-common nettle-dev ntp openssh-client openssh-server openssl
    poppler-utils python-imaging python2.7 python2.7-minimal samba samba-common
    samba-common-bin smbclient ssh sudo tar tzdata unzip vim-common vim-tiny
    wget wpagui wpasupplicant
    124 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
    Need to get 92.6 MB of archives.
    After this operation, 3,652 kB of additional disk space will be used.
    Do you want to continue [Y/n]?

    So I typed Y to say Yes and it’s installing now. I guess reboot and see it that fixes it.

    -Raymond Day

    4. January 2017 at 20:06 #25537

    Rebooted after it updated but that did not help.

    I did what it said on the Link.

    had to find the script did it like this:

    find / -name RPi_Cam_Web_Interface_Installer.sh

    cd /opt/max2play/cache/newplugin/rpicam/scripts/
    ./RPi_Cam_Web_Interface_Installer.sh install

    It said had to reboot then so I did.

    Then I did:

    ./RPi_Cam_Web_Interface_Installer.sh update

    But it said all ready updated but installed it any way and had to reboot again.

    Then I did ./RPi_Cam_Web_Interface_Installer.sh start

    But it did errors and so I guess I fixed the errors putting chmod 777 on /var/www/rpicam/macros/error_hard.sh then is stop the errors it looked like this:

    mmal: mmal_vc_component_create: failed to create component ‘vc.ril.camera’ (1:ENOMEM)
    mmal: mmal_component_create_core: could not create component ‘vc.ril.camera’ (1)
    sh: 1: /var/www/rpicam/macros/error_hard.sh: Permission denied
    mmal: mmal_vc_component_create: failed to create component ‘vc.ril.camera’ (1:ENOMEM)
    mmal: mmal_component_create_core: could not create component ‘vc.ril.camera’ (1)

    Broadcast message from [email protected] (Wed Jan 4 12:54:12 2017):

    The system is going down for reboot NOW!
    mmal: mmal_vc_component_create: failed to create component ‘vc.ril.camera’ (1:ENOMEM)
    mmal: mmal_component_create_core: could not create component ‘vc.ril.camera’ (1)

    Broadcast message from [email protected] (Wed Jan 4 12:54:17 2017):

    The system is going down for reboot NOW!

    Now it keeps rebooting over and over. I am trying to reset the 777 back to 444.

    I did that and now it don’t keep rebooting.

    But the camera still don’t work.

    What else can I do to fix it?

    -Raymond Day

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here