Jivelite will not install on a new Max2play installation

Max2Play Home 2016 (en) Forums Max2Play Add-ons Jivelite will not install on a new Max2play installation

This topic contains 3 replies, has 3 voices, and was last updated by  Heiner premium 1 year, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 2. November 2015 at 22:47 #16684

    Hi

    I am trying a complete fresh install on Raspberry pi 2, Wetterott 2.8″ tft and IQaudio DAC+.

    I dl’d m2p_rpi_2.2, burnt sd card. Booted, Expanded file system, updated max2play, now showing v2.24
    installED LMS Server, raspberry pi settings AND rasperry pi display.

    All works so far!, I can play music out of the dac, from my music disk OK.

    However jIVELITE WILL NOT INSTALL.

    i DL’D the plugin, it is active, but when I click on install in the jivelite page, a yellow box appears saying installion started and the date and time appears thus:- 2015-11-02 19:53:02|

    The screen flashes every few seconds but NOTHING else changes or appears in the yellow box.

    I can leave it for an hour, nothing happens!… if I restart the installation after a few seconds I get the message “Something went wrong deleting progree file”

    I have downloaded jivelite plugin again still same restult.

    Nothing is printed in the debug box. If I look at /opt. there is NO jivelite directory.

    It appears that the Max2play web control is NOT starting the jivelite install script.

    What can I do to correct this?

    regards

    Patrick

    Hi,

    Just tried again.

    D/l’d another copy of Max2play from your site.
    Expanded sd card image manually
    D/ld Jivelite plugin
    Tried to install Jivelite onto m2p v2.2 same result as above NO install
    upgraded m2p to v2.4 tried to install Jivelite still No install

    Left for 30 minutes still nothing!

    P

    • This topic was modified 1 year, 1 month ago by  superpat. Reason: additional info
    2. November 2015 at 23:36 #16685

    I also cannot install Jivelite on a fresh install (updated to the latest version).
    However, I’m having a different issue: after pressing the install button, it loads and runs through the entire install process, even saying that it has completed the install succesfully. Howevr, if I reload the page, it says that Jivelite is not installed. I’ve tried installing it again – same process.
    However, I have noticed that during the install, it throws up an error:

    Cloning into 'jivelite'...
    error: Failed connect to github.com:443; No route to host while accessing https://github.com/ralph-irving/jivelite.git/info/refs
    fatal: HTTP request failed
    /opt/jivelite/jivelite/src/resize.c: No such file or directory

    So, I decided to check if that link was correct, and it took me to a page with the error:

    Please upgrade your git client.
    GitHub.com no longer supports git over dumb-http: https://github.com/blog/809-git-dumb-http-transport-to-be-turned-off-in-90-days

    Is there any way I can fix this? Or do I have to wait for a new release?
    Many thanks.

    EDIT: Ah, given the age of the URL the error page links to, I realise that the error page only appeared because I was accessing the link shown in the Jivelite install log using a web browser (of course).
    Any other thoughts? Given I’ve installed it four times now, and I can access github using my browser, I doubt it’s due to my (admittedly unreliable) internet connection.

    • This reply was modified 1 year, 1 month ago by  jademonkee.
    3. November 2015 at 13:23 #16711

    So, it turns out I can’t reach github from my Raspberry Pi – pings fail.
    Digging a little deeper, someone mentioned that it could very well be related to my netmask setting (as per https://www.raspberrypi.org/forums/viewtopic.php?f=91&t=48866). Indeed, as github is a 192.x.x.x address, if my netmask was 255.0.0.0, then it would assume that github was on my local network.
    Indeed, taking a look at the WIFI/LAN settings page I see that my netmask is 255.0.0.0
    I had the option to “Set fixed LAN IP-Address (eth0)” enabled, and disabling this option set the net mask back to the correct 255.255.255.0
    I can now reach github. Hooray!

    3. November 2015 at 17:12 #16751

    hi superpat,
    please make sure, before installing Jivelite, that the filesystem has been expanded (less than 50 percent used in the debug info under “Settings/Reboot”) and that you do not have any other hardware connected to the Pi since this interferes with the power supply for the installation.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here