Jessie-based image

This topic contains 20 replies, has 6 voices, and was last updated by  q20 premium 1 year, 7 months ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • 1. March 2016 at 15:38 #18905

    Hi q20,
    Good timing on your part! We are just now getting ready to roll out version 2.28 of Max2Play based on Jessie (https://www.max2play.com/en/changelog-max2play/). You can already check it out by updating to the latest beta of Max2Play.

    1. March 2016 at 15:58 #18912

    Hoorah! Will max2play initiate an upgrade to Jessie or will we need to start with a fresh image?

    • This reply was modified 1 year, 7 months ago by  q20.
    1. March 2016 at 17:08 #18942

    The beta is available for download on our download page: https://www.max2play.com/en/max2play-image/
    An update will not suffice.

    1. March 2016 at 19:13 #18952

    Absolutely great news!!!!

    2. March 2016 at 20:16 #19028

    Hello Heiner,

    would this be the right place for errors found in the in the beta?

    Nethertheless here are the first two hints:
    1. rpi-update is not installed in jessie lite
    2. On Raspberry Pi 3 the wps doesn’t work with new integrated WiFi

    3. March 2016 at 16:30 #19074

    OK, I’ve just started testing the 228 beta. Has the root password changed from max2play to something else? I’m unable to authenticate as root over SSH…

    3. March 2016 at 17:16 #19102

    Hallo all!

    @bort: Thank you for your feedback. We will show your obervations (also those you might add in the future) to our developer.
    @q20: Yes, the root access has changed in the new Jessie build. Log in as user “pi” as usual, enter “su” and “max2play” to get root access.

    Maximilian from Max2Play

    4. March 2016 at 20:43 #19119

    Hallo,
    unfortunately, the command apt-get update && apt-get upgrade destroys the system on boot (raspberry pi 3 only).
    Version Beta:
    – 160301 runs
    – 160303 crash

    edit:
    After replacing the micro SD card Samsung 16GB for cheap Medion 16GB from Aldi everything works. Strange because for raspberry pi 2 there was no problems… maybe the problem was with the update by shh.

    Best regards
    Robert

    7. March 2016 at 16:51 #19151

    News:

    • most apps are working with the RPi 3 and the current Beta (make sure to update to latest Max2Play-beta)
    • WPS is currently not working with Raspberry Pi 3 integrated WiFi (thanks Bort for investigating) – I think there are some driver issues that need to be solved. External USB-Wi-Fi sticks are working with WPS.
    • I built a bluetooth addon that wants to be tested – if you like you can get it from http://shop.max2play.com/media/downloadable/beta/bluetooth.tar – this will let you connect to bluetooth speakers and let kodi / squeezelite and other players use it as audio output

    If you want to upgrade to the latest packages, you should call “apt-get update && apt-get upgrade”. This can also be done at the bottom of the web interface on the Raspberry PI Settings Addon.

    I am still testing and preparing to build the final version of Max2Play 2.28. If you experience any problems in the Beta with Kodi 15.2 or other Addons, this is the place to post them 🙂

    All the best
    Stefan

    12. March 2016 at 15:45 #19228

    Now I have got “Version 2.28 Raspberry PI” and and also information: “Your license could not be validated”

    best regards
    Robert

    13. March 2016 at 22:38 #19240

    @bobsilesia – ditto 🙁

    14. March 2016 at 11:14 #19249

    Hi,

    I am sorry, but the licence verification was not available on the weekend due to some changes in our server architecture (bringing SSL encryption). It is now working again. If your licence is not marked as active please remove your email / licence code, click save and enter it again to make sure it is updated and saved.

    @Robert: I had to remove your post about how to bypass validation.

    16. March 2016 at 9:19 #19306

    Since this topic has become a catch-all for the Jessie beta, I thought I’d mention another issue: when attempting to install and run the Squeezebox server, it errors:

    Trying to launch … NOT successful Click here to show detailed information

    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

    sudo: no tty present and no askpass program specified

    Any ideas?

    16. March 2016 at 12:06 #19307

    @q20: never had such an error. Installation and Startup on every testsetup went OK so far. Did you change something else on your SD-Card-image? The error is indicating missing user rights to start the squeezebox server – maybe your installation is broken (SD-card error). In this case you should start with a fresh SD-Card-Image.

    Make sure to install Squeezebox Server Nightly 7.9 (otherwise it won’t start because of missing libraries).

    16. March 2016 at 17:34 #19315

    @flysurfer: bummer… could you maybe think of a quick fix to apply the correct user rights to the startup process? If not, I’ll reinstall. :p

    7.9 nightly was definitely installed.

    16. March 2016 at 17:44 #19317

    @q20: I cannot really help, because there might be different problems that lead to the error. You may change permissions of the launch script by using “sudo chmod 777 /etc/init.d/logitechmediaserver” but I don’t know why this script has not the rights to start… a reinstall is probably the easiest and fastest solution.

    16. March 2016 at 17:54 #19319

    @flysurfer: chmod: cannot access ‘/etc/init.d/logitechmediaserver’: No such file or directory

    I can confirm the file does not exist. Could it be the installer failed? Can I attempt a manual install of the squeezebox server?

    16. March 2016 at 17:59 #19320

    Attempted dpkg -i

    Errors were encountered while processing:
    logitechmediaserver_7.9.0~1458127503_all.deb

    16. March 2016 at 18:03 #19321

    OK, seems the SD card is full. No idea how. I’m going to start again. 🙁

    17. March 2016 at 19:08 #19340

    So, another issue with the beta (and why I ran into issues before); re-sizing the SD card does not work. I’ve tried on both 32GB and 8GB cards without luck. 🙁

    If I attempt to resize using raspi-config:
    mmcblk0p2 is not the last partition. Don’t know how to expand.

    EDIT: after a couple of reboots and updating the max2play beta, it’s all resolved itself…

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.

Register here