Jasper install: ERROR:root:Error occured!

Max2Play Home 2016 (en) Forums Max2Play Add-ons Jasper install: ERROR:root:Error occured!

This topic contains 5 replies, has 3 voices, and was last updated by  Maximilian premium 1 year ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 3. November 2015 at 1:06 #16689

    Hi,

    After installing Jasper, I press the run button.

    This is the log I get:

    Installation startet - This Messages refreshes every 3 seconds to show current status of installation. If finished this message disappears.
    ERROR:root:Error occured!
    Traceback (most recent call last):
    File "/opt/jasper/jasper.py", line 143, in 
    app = Jasper()
    File "/opt/jasper/jasper.py", line 76, in __init__
    with open(new_configfile, "r") as f:
    IOError: [Errno 2] No such file or directory: '/home/pi/.jasper/profile.yml'
    *******************************************************
    * JASPER - THE TALKING COMPUTER *
    * (c) 2015 Shubhro Saha, Charlie Marsh & Jan Holthuis *
    *******************************************************
    
    Process Terminated!

    I get the same error when running it in ssh:
    [email protected] /opt/jasper $ python jasper.py

    And this I get when I run the boot command:
    [email protected] /opt/jasper/boot $ python boot.py

    Traceback (most recent call last):
      File "boot.py", line 9, in <module>
        sys.path.remove(os.path.dirname(__file__))
    ValueError: list.remove(x): x not in list

    Anybody knows what could be the cause of Jasper not wanting to start?

    Note: I am able to let it speak out loud things to me, it’s just jasper that won’t start.

    Many thanks!

    3. November 2015 at 17:56 #16752

    Hi K.Rens,
    We do not have any experience with this application and do not if it is compatible with Max2Play.
    Our image is based on Raspbian, if that helps you.

    4. November 2015 at 23:01 #16781

    Hi,

    I have installed your raspbian image.
    The Jasper (speech) add-on is an official one from your store.
    I purchased a pro license just to be able to install it ­čśë

    Can you check with the developer of this add-on?

    Thank you.

    11. November 2015 at 16:24 #16847

    Sorry for the inconvenience, as stated in our details page on the extension, it is merely an installer of another developer’s software. It is still in alpha status and we cannot offer support for it. We looked into the current installation process and there seems to be an issue with libraries which should be requested according to the developers instructions, but are either not available or available elsewhere.

    11. November 2015 at 16:47 #16854

    Can you let me know which ones are missing?
    Then I can try to find them and compile them manually.

    Thank you

    25. November 2015 at 19:34 #17024

    Hi K.Rens,

    that’s not worth it. On the long run, we plan to drop Jasper (which is maintained insufficiently) and move on to speech control via Google Now and Siri (maybe also Cortana) to enable the interaction between smartphones and Max2Play. Certain additional apps and of course the assistants’ APIs have to be used, though. At the end, we will publish a Max2Plugin that lets you choose your assistant and lists all available commands and necessary instructions to set it up. You might be able to add custom commands as well. But all this will take some time.

    If you have an Android smartphone, you could test it meanwhile with installing the (not free) “Tasker” app. In the max2play-interface, starting a Squeezelite player for example is done by a certain URL shown after clicking the “Start”-button (… Squeezeplayer.php?action=start …). You could link this URL and your command text in Tasker and control your Raspberry Pi with a Google Now speech command from then on.
    Would be great if you shared your experiences with it.

    Maximilian from Max2Play

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here