issues installing max2play on R-pi with digi+

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI issues installing max2play on R-pi with digi+

This topic contains 6 replies, has 2 voices, and was last updated by  Heiner premium 10 months, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 27. January 2016 at 5:22 #18146

    Hello,

    I am having trouble with getting max2play on a Raspberry Pi 2 with a Hifiberry Digi+
    here is what I do and the issue I run into
    Steps to reproduce

    loaded m2p_hifiberry_226_wps.img
    added hifiberry digi/digi+ ( I have the digi+)
    rebooted
    updated info IE my email addy to register, set time zone to america/chicago
    updated via the update button
    rebooted
    removed Kodi
    removed Squeezebox server
    added music player MPD
    added access point
    saved
    installed Access point
    set access point settings
    reboot
    set max usb current under raspberry settings
    reboot
    installed Ampache
    At this point Ampache show it was complete
    I hit the link to refresh the page (or click on any other page) and any page is unavailable. I have polled the power and at this point nothing works, if I hook up a monitor to the r-pi at this point I see a failure
    [ ok ] Starting Samba deamon mbd smbd
    [….] Starting webserver: apache2warning; document root [/var/www/ampache] does not exist
    apache2:could not reliably determine the server’s fully qualified domain name, using 192.168.189.1 for servername
    action ‘start’ failed
    the apache error log man have more information

    FAILED!
    [ ok ] starting periodic command scheduler: cron.

    I have tried a couple time formatting the SD card and reloading teh image each time.

    I know NOTHING about Linux so if you want me to do something to correct this in Linux please be kind and walk me through it step by step 🙂

    I had it working one time but my USB drive wouldn’t mount, assuming that filesystem mount was corrupted I formatted and reloaded the image again and have had this issue since (I realized I didn’t set Max USB current on the one that was working but not mounting)

    I am wondering if this has something to do with either not expanding storage, or if it is the combo of some setting and Max USB current.

    I will try again without setting max usb current to see if this is the issue, if not I will attempt to add in the step to expand the storage.

    Any thought or ideas would be greatly appreciated.

    Bill

    27. January 2016 at 8:23 #18147

    Well
    attempt 2
    loaded m2p_hifiberry_226_wps.img
    added hifiberry digi/digi+ ( I have the digi+)
    rebooted
    updated info IE my email addy to register, set time zone to america/chicago
    updated via the update button
    rebooted
    removed Kodi
    removed Squeezebox server
    added music player MPD
    added access point
    saved
    installed Access point
    set access point settings
    reboot
    expanded file system (USB drive unplugged)
    reboot
    ampache installed
    failed with same issue

    27. January 2016 at 15:05 #18166

    Hi Bill,
    The Ampache server is a big installation and the expansion of the filesystem only really works if you do it as one of your first steps, preferably your first step. Please try expanding first. You can also see if your current setup is problematic with the unexpanded filesystem by checking your free memory under “Settings/Reboot” in the Debug Info.

    28. January 2016 at 4:15 #18179

    OK I tried doing the resize first following these steps and it failed again 🙁
    First here are my specs, Raspberry pi 2, hifiberry digi+, on an 8gb Samsung class 10 SD card

    loaded m2p_hifiberry_226_wps.img
    expanded file system (USB drive unplugged)
    reboot
    added hifiberry digi/digi+ ( I have the digi+)
    rebooted
    updated info IE my email addy to register, set time zone to america/chicago
    updated via the update button
    rebooted
    removed Kodi
    removed Squeezebox server
    added music player MPD
    added access point
    saved
    installed Access point
    set access point settings
    reboot
    ampache installed
    failed same issue

    as I said I got it working one time without without enabling the higher power for the usb ports… This last time I didnt have the usb drive hooked up and without enabling the full power usb.

    Is my SD card goofed up, what am I doing wrong?

    28. January 2016 at 5:16 #18180

    I did a full format (full erease of teh card) and then followed this install order and it worked
    loaded m2p_hifiberry_226_wps.img
    expanded file system (USB drive unplugged)
    reboot
    added hifiberry digi/digi+ ( I have the digi+)
    rebooted
    instlled/started MPD
    installed ampache
    ampache is working

    28. January 2016 at 6:24 #18181

    well i spoke too soon, I tested that both ympd and ampache were functioning, I then added the full power to usb setting and rebooted and added the USB drive and now I am back with a dead r-pi

    this time it is erroring out on mysql the only thing i did different was to add SD card protection.

    29. January 2016 at 17:52 #18242

    Hi bilbo,
    The SD card protection forbids any writing on the SD card which would be necessary if you try to edit anything. This function is only for the use of the Pi as just an audio player.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here