[SOLVED] Is resizing necessary?

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Is resizing necessary?

This topic contains 10 replies, has 4 voices, and was last updated by  Heiner Moderator 3 weeks, 3 days ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • 27. November 2016 at 0:41 #24276

    Should I be worried about:

    <quote>
    Only 287 MB of free space left on the device! Have you already expanded the filesystem?
    </quote>

    I can login via ssh and see the following:

    <quote>
    [email protected]:~ $ sudo fdisk -l

    Device Boot Start End Sectors Size Id Type
    /dev/mmcblk0p1 8192 131071 122880 60M c W95 FAT32 (LBA)
    /dev/mmcblk0p2 131072 7374208 7243137 3.5G 83 Linux
    /dev/mmcblk0p3 7374209 7774207 399999 195.3M 83 Linux

    [email protected]:~ $ cat /etc/fstab
    proc /proc proc defaults 0 0
    /dev/mmcblk0p1 /boot vfat defaults 0 2
    /dev/mmcblk0p2 / ext4 defaults,noatime 0 1
    # a swapfile is not a swap partition, no line here
    # use dphys-swapfile swap[on|off] for that

    ##USERMOUNT
    UUID=47A3440C0A74837B /media/usb0 ntfs defaults,nofail

    [email protected]:~ $ df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/root 3.4G 3.0G 287M 92% /
    devtmpfs 427M 0 427M 0% /dev
    tmpfs 432M 0 432M 0% /dev/shm
    tmpfs 432M 6.1M 426M 2% /run
    tmpfs 5.0M 4.0K 5.0M 1% /run/lock
    tmpfs 432M 0 432M 0% /sys/fs/cgroup
    /dev/mmcblk0p1 60M 22M 39M 36% /boot
    tmpfs 87M 4.0K 87M 1% /run/user/1000
    </quote>

    So, seems that the primary partition size of 3.4Gb is consumed by whatever is part of the max2play image. Can I remove stuff to free up space (use apt for example) or is there a max2play UI way to do this?

    Or do I even need to worry?

    Thanks.

    1. December 2016 at 12:14 #24430

    Hi gstalnaker,
    Have you expanded your filesystem (“expand filesystem” button under Settings/Reboot)? If not, we would recommend doing so.

    2. December 2016 at 22:26 #24523

    Yes, there was an initial expansion early on in the installation process. The warning above is a current warning.

    7. December 2016 at 15:16 #24631

    If your filesystem was already expanded and your sd card is still as full as indicated by the debug info, you might consider deleting some contents you added since the image itself should only fill out ca. 60 per cent even without expanding the filesystem which should half the space occupied to about 30 per cent.
    If you cannot or do not want to delete any new files from your sd card, you might want to consider buying a bigger one and transferring the image if you want to continue with this installation of Max2Play (using the image burner plugin).

    7. December 2016 at 17:33 #24654

    Interesting. I don’t recall adding any content to the SD card. I’ve not added any plugins or used apt to install any software. My music (my content, if I’m reading your reply correctly) is all on a 2Tb USB drive mounted at /media/usb0.

    I asked in my original post: Can I remove stuff to free up space (use apt for example) or is there a max2play UI way to do this?

    My use is as a Logictech Media Server connecting to a SqueezeBox Classic 2/SqueezeboxRadio. I’ve no interest in streaming video, etc. I’m never going to use Kodi/XBMC, so can that be safely uninstalled using apt?

    Thanks for your replies.

    Regards.

    21. December 2016 at 8:54 #25097

    I have the same problem here, and the “only … of free space left” message changed the amount of free space every now and then and now it says that only 0MB of free space are left!

    When I mount my SD-card to my laptop it shows 2 partitions, one with 60 MB (38MB free) and one with 2,66GB space (140MB free). Actually the SD-Card should have 8GB.

    when I click on expand filesystem it says, that it is not possible, because of no valid partition… (or similar – I use the german version, there it says:
    “Expandiere Dateisystem:
    Kein Vergrößern des Dateisystems möglich. Keine gültige Partition zum expandieren gefunden.
    Achte darauf, dass alle USB-Geräte und Speicherkarten getrennt sind und starte neu bevor das Dateisystem expandiert wird!”)

    What should I do?

    21. December 2016 at 15:26 #25112

    Since my Max2Play 4Gb SD card was indeed consumed I ended up re-doing my entire Max2Play system on a new 8Gb SD card. And when I got the very first Expand warning on the very first boot in the Max2Play, the process expanded the primary Max2Play partition to use the entire SD card. So, I now have a 6Gb primary where Max2Play “resides”. It seems, based on both of our experiences, that the Expand function is problematic and not entirely consistent in its operation.

    As you have taken your SD card about of your Pi you can use other tools to manage its partitions than the Max2Play “tool.” I do not know what tools exist for Windows or MacOSX that can do what I’m about to describe because I am a 20-year Linux user and that is what I know best. But the concepts should remain the same no matter what tool you use. If you use Windows/MacOSX, google “partition manager” for tools for those operating systems.

    To do this with a Linux OS, you need an application called “parted” (Partition Editor) installed. Many Linux variants come with parted installed and the Max2Play installation does have it. If you desire a GUI version, then gparted is the application. I confess that this is one application where I prefer the GUI to the command line. The visual representation of the partitions is simply easier to understand. Note that you cannot use your Pi booted to Max2Play to do this because resizing a mounted “in use” partition cannot be done, so you cannot boot your Pi then use parted on the booted OS that is on the Max2Play SD card.

    BUT … if you have a second bootable SD for your Pi, and you can install parted on it, you can boot from it, mount your Max2Play SD card (IF – big IF – you have an SD card reader dongle like I have in which you put your SD card which then plugs into a USB port on your Pi). Doing this might well be worth the effort.

    Concepts:

    1. Mount the SD card (which you know how to do).
    2. Determine which “mounted” disk is your SD Card. On a Linux system run “sudo fdisk -l” to see the mounted disks; the list will show items named like “/dev/sda#/ where # is a number, e.g., /dev/sda1 or /dev/sdb1; the letter before the number will increase with the number of mounted disks, a, b, c, d, etc.
    3. The tricky part here is knowing which of these is your SD card. On a desktop system /dev/sda is usually the main, primary drive, /dev/sdb is often the cd/dvd drive. On my Pi, my USB drive on which is my music, is mounted as /dev/sdb (because my Pi has no CD/DVD drive) and the partition is /dev/sdb1. If I wanted to modify its partitions then /dev/sdb is the disk I would use parted on. A Max2Play SD card will show Linux as its OS and it should not be the /dev/sda disk when it’s mounted on a running OS.
    4. On Linux using gparted to do this: https://www.howtoforge.com/partitioning_with_gparted
    5. If you cannot use gparted but can us another Linux OS on your Pi with your SD card mounted to it (and you’re using parted from an SSH session) then this will be helpful: https://www.gnu.org/software/parted/manual/html_node/parted_31.html You’ll see it’s as easy as (!) seeing the total size of the SD card (shown on the Disk geometry line of the “print” command output, then walking through the Start/End values of the SD card’s partitions).
    6. NOTE – there is always the change, however small, that doing this can bork your SD card. But, in 20 years I’ve never had that happen to me, personally, so I’m comfortable doing this.

    Hope this was of some use.

    • This reply was modified 10 months ago by  gstalnaker.
    21. December 2016 at 18:00 #25119

    thank you very much gstalnaker for your answer. I’ll try it!

    Somehow I also got another answer from “Christoph” in my Emails and it does not show up here. Anyway, if you read that Christoph: yes I tried disconnecting usb devices, but expanding still doesnt work…

    21. December 2016 at 19:24 #25127

    I got the problem solved!
    I used

    sudo raspi-config

    and then chose “Expand root partition to fill SD card”

    after a restart, everything was fine 🙂

    23. September 2017 at 15:33 #31494

    Hi, I’m not sure what I’m missing here but what is a solution?
    I’m on Windows so can’t see content of SD card.. card already expanded

    I haven’t copied anything into SD card.. but running out of space.. I assume its max2play update/install files..
    Any chance you could add function to clear them out form web interface?
    Or suggest some easy solution for Win users which doesn’t requires buying new bigger SD card?

    Thank you 😀

    • This reply was modified 3 weeks, 5 days ago by  Jaca.
    25. September 2017 at 16:58 #31539

    Hi Jaca,

    With a Max2Play 2.44 image, your card should only have ca. 1-2 GB occupied, maximum, after your first boot. The system expands automatically and you can see the space used in the bottom of Settings/Reboot under Debug Info.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here