[SOLVED] IQAudio digiamp+ with 7" touch display not working

Max2Play Home 2016 (en) Forums Max2Play Projects and Builds [SOLVED] IQAudio digiamp+ with 7" touch display not working

This topic contains 5 replies, has 2 voices, and was last updated by  Fifer premium 11 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 8. November 2017 at 0:11 #32338

    Hopefully someone here can help, as I’m stuck. I’ve been happily using Max2Play with my Pi 2 Model B and IQAudio Digiamp+ without an issue for ages. I decided to add a Pi 7″ Touchscreen so I could use Jivelite, so bought the screen, assembled it to my set-up and upgraded to a 2 year licence so I could install the RPi display and Jivelite plug-ins. I just cannot get the screen to show any signs of life. The power jumpers are on the right pins on the Digiamp+ and the display board and the display board is getting 5V, but no matter what I try, there is no sign of life from the display.

    I have also tried without the Digiamp+, but cannot get that to work either. I exchanged my display (thinking it was faulty) but the replacement is just the same. And now, for some reason, I cannot get Jivelite to run although I don’t believe I have changed anything to make that happen.

    Any ideas folks? Sorry for making my first post a frustrating problem.

    • This topic was modified 11 months, 1 week ago by  Fifer. Reason: typo, hear here
    • This topic was modified 11 months, 1 week ago by  Heiner.
    8. November 2017 at 15:22 #32353

    Hi Fifer,

    First thing to try is freshly burn and newly downloaded version of the specific 7″ Touch image: https://www.max2play.com/download/16401/

    This should start the screen from the first boot. If this is not the case, you need to have another look at the cables.

    Make sure the pins are exactly the same as in our tutorial: https://www.max2play.com/en/wiki/7-touch-screen-connect-the-gpio/

    8. November 2017 at 15:26 #32354

    Thanks Heiner

    I’ll try that tonight. I also found something online from someone with a similar problem who solved it by updating the Pi firmware. Will try that if the fresh image doesn’t work.

    9. November 2017 at 0:18 #32371

    Ok, I’m getting somewhere. I updated the firmware (sudo rpi-update) and the display now works, as does Jivelight. Only issue is there is a white bar which flashed on and off at the top of the screen and it makes Jivelight (when on full screen) jump up and down by about 7mm every second. And when choosing menu options (which is hit or miss with the screen jumping), I cannot see a „back“ option?

    9. November 2017 at 12:48 #32373

    Found this. Looks like I need to re-image my SD card as Heiner suggested …

    • This reply was modified 11 months, 1 week ago by  Fifer.
    • This reply was modified 11 months, 1 week ago by  Fifer.
    10. November 2017 at 0:15 #32399

    Sorted – new image fixed it. Thanks.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here