[SOLVED] IQaudIO DigiAmip+ – No Sound

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] IQaudIO DigiAmip+ – No Sound

This topic contains 8 replies, has 3 voices, and was last updated by  Heiner Moderator 2 years, 5 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 27. Mai 2018 at 11:42 #35902

    Hi,

    I am trying to set up a new SD card with the latest Max2Play. I have a Pi 3B with an IQaudIO DigiAmp+, which work with a SD card that I set up a year or so ago.

    I have installed the latest image and I selected the IQaudIO card on first boot. I have also selected the Advanced settings from the IQaudIO page.

    I am unable to get any audio out of the DigiAmp+. I have tried using squeezelite via the squeezebox server, as well as using aplay and mplayer to pick the specific device. Commands at the end of the post.

    The analogue playback and boost are both on 100% and master volume is at 50%. I’ve confirmed these via alsamixer too.

    Any ideas on what I can try? I can confirm that it isn’t a hardware issue, as I can swap out SD cards and everything is fine.

    Commands I’ve tried:
    curl https://ccrma.stanford.edu/~jos/wav/bachfugue.wav | aplay --device hw:CARD=IQaudIODAC,DEV=0
    curl https://ccrma.stanford.edu/~jos/wav/bachfugue.wav | aplay --device plughw:CARD=IQaudIODAC,DEV=0
    mplayer -nolirc -ao alsa:device=hw=0,0 -playlist http://network.absoluteradio.co.uk/core/audio/mp3/live.pls?service=vrhq

    27. Mai 2018 at 21:44 #35906

    I have now used the jessie image and sound is playing through the DigiAmp+. Perhaps this is a bug with the stretch build?

    28. Mai 2018 at 16:31 #35923

    Hi Asheboy,

    Thanks for the detailed post, I will try to recreate your issue here to find a fix.

    5. Mai 2019 at 21:25 #45266

    I’m having exactly the same issue with the latest 2.48 image. My Pi 3B with IQaudio DigiAmp+ was working fine with an older Jessi based image. How can we fix this?

    6. Mai 2019 at 15:03 #45287

    Thank you for chiming in, Lietho.

    I tested with a new image and the NEW IQaudIO DigiAmp+ and could not reproduce your issues. Both playback and the volume sliders (don’t forget to save any changes) worked right after the reboot.

    What version of the DigiAmp+ are both you using? I tried with the NEW DigiAmp+ with protruding terminals.

    6. Mai 2019 at 15:56 #45290

    Update: We were now able to reproduce the error, but only with the legacy DigiAmp+ without the protruding terminals. It seems to be an issue with the assigned GPIO22 which does not show up anymore with newer versions of Raspbian. We have contacted IQaudIO and will keep you up to date on the implementation and any potential fixes. For now, stretch images before 2.48 should still work.

    7. Mai 2019 at 10:30 #45302

    Update Fix:

    There was a conflict with the NEW DigiAmp+’s implementation that we now fixed in the live version of Max2Play. To get this fix on an existing 2.48 Max2Play image, do the following:
    – Make a Beta Update
    – Make a normal update (optional to get back to default Max2Play 2.48)
    – Select „none“ in IQaudIO Plugin
    – Reboot
    – Select „DigiAmp+“ in IQaudIO Plugin
    – Reboot

    The sound card should now be unmuted again and work as expected.

    Anyone updating to 2.48 now, will not be affected by this bug.

    8. Mai 2019 at 7:27 #45314

    Amazing, this works! Thank you very much for this fast and easy solution!

    8. Mai 2019 at 14:02 #45319

    Thanks for following up so quickly and letting us know the fix worked for you! 🙂

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here