IQaudIO DAC+ output quite low

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI IQaudIO DAC+ output quite low

This topic contains 15 replies, has 8 voices, and was last updated by  Heiner premium 4 months, 3 weeks ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • 15. September 2015 at 19:39 #15696

    Hello,
    I’ve noticed that the output of my IQaudIO DAC+ is much lower than the other ‘line level’ devices attached to my speakers, even with volume set to 100% in SqueezeLite or Kodi.
    Is there some other setting that needs to be turned up, too? Like in ALSA?
    Do the volume controls on Kodi/SqueezeLite control the hardware volume playback?

    Further:
    I’ve selected the entry “default – IQaudIODAC, – Default Audio Device, CARD=IQaudIODAC” as the Audio Output for Squeezelite.
    What’s the different with the “sysdefault – IQaudIODAC, – Default Audio Device, CARD=IQaudIODAC” entry just below it?
    Curiously, I’ve noticed that the bcm2385 outputs are marked as CARD=ALSA – I thought that the DAC should be using ALSA? Am I wrong here?

    Thanks for your help

    15. September 2015 at 20:32 #15697

    Ok, following the steps in section 12 of the IQaudIO manual (http://www.iqaudio.com/downloads/IQaudIO.pdf) I found that on page 26 it recommends using alsamixer to set “PCM” to 86% (for approx 0dB output; 100% would be +6dB), and to set “Playback” to 100 and “Playback Boost” to 100 too.
    I did all these, and the sound is closer to what I would expect for a suitable output.
    I still expect it to be a little louder, however, so I set the PCM to 100% and it seems about right now.

    And are you able to set these values as default for the DAC+ for future max2play installations?

    Out of curiosity, I was hoping to add a hardware volume control to the DAC+ – would it then be adjusting the PCM value in ALSA, rather than the Squeezelite volume?
    Is it possible to set SqueezeLite to use the PCM ALSA mixer for volume control from a SqueezeBox remote app?

    16. September 2015 at 16:48 #15708

    Hi jademonkee,
    Thanks for informing us about this problem with the IQaudio card. Regarding your question on sysdefault and default; sysdefault is in there in case you need more system rights to run the card. There is no other fundamental difference in the two.
    Regarding your volume problem, we changed the settings for the IQaudio DAC+ in the Raspberry Settings, so if you update to beta on an new system and directly choose the IQaudio DAC+, the volume will be tuned perfectly. You can also use the sliders in Raspi Settings to make it louder.

    16. September 2015 at 18:03 #15711

    Excellent to hear. Thank you.
    I should also note that, since writing my second post, I decided that setting PCM to 86% as per the IQaudIO instructions resulted in a better volume than 100% PCM.

    18. September 2015 at 15:06 #15732

    Great!
    Thanks for supporting Max2Play

    21. October 2015 at 23:12 #16467

    Waiting for the same dac to be delivered and just bought the M2P premium, can’t wait to start setting it all up 🙂
    May I second the question about app volume control for the squeezelite? Can someone confirm that it uses the hardware volume setting of this dac? Thanks!

    22. October 2015 at 17:55 #16524

    Hi there!

    We have already contacted the manufacturer of IQaudiO DAC+ soundcards to address this issue. We will add specific configurations coming with the next update for Max2Play and are also working on a Max2Play image expecially for IQaudiO DACs.

    Best regards

    Maximilian from Max2Play

    22. October 2015 at 21:12 #16527

    Thanks Maximilian, that’s really great news! I’d have bought the whole kit here hadn’t the headphone jack drawn me towards the Pi-DAC+…

    20. November 2015 at 12:52 #16972

    Hi there!

    Meanwhile, the IQaudIO Pi-DAC+ is available in our store as well as the official IQaudIO Pi-CASE+.

    You also have the possibility to preorder the bundle with our special IQaudIO Max2Play image. The image will be finished soon.

    What do you think about it?

    Best regards

    Maximilian from Max2Play

    21. November 2015 at 4:54 #16981

    Good news! Personally, I prefer the IQaudio over the hifiberry because of its RCA and great sounding headphone out. Curious, though: what options will this specific image bring? The card as such seems perfectly supported by Max2Play now, at least with the premium license. Any more aces up the sleeve that I missed?

    Cheers and keep it up!

    2. December 2015 at 14:05 #17094

    Hi all,

    The new max2play (2.25) shows the volume settings for the iquadio DAC+ in the “raspbberry settings” tab.

    In previous version ot the interface, the optimum value for the master volume was 86. Now the optimum value is 100.

    Is this a consequence of the discussions with IQAUDIO regarding the specifications of the DAC+ ?

    Looking to the iqaudio installation documentation, the analog boost and the analog playback boost should be set to 100. There is nothing about the master volume.

    This doc has been updated recently, I am not sure when , but in previous version the optimum master value was 86.

    Regards

    3. December 2015 at 13:15 #17112

    Hi louroux,
    The 86 value was something we had set from individual experience. However, after having had contact with the proprietor of the IQaudIO sound cards, we have found out that the optimum value for all three parameter’s is 100 percent.

    28. December 2015 at 18:50 #17491

    Hi everybody.
    I have a question regarding the settings of Master Volume in Pi/IQaudIO Settings plugins. I am using a Pi-Dac+ along with a Pi-Amp+ for playing music with Squeeze Server / Squeezelite, but not sure what is the optimal configuration for Master Volume.

    I have set the hardware volume control via -V Digital in Squeezelite command line (advanced settings) and therefore there is a correspondence between shown volume values in Squeezeserver and Alsamixer, but I am not able to find the correspondence with Master Volume, that varies with Squeezeserver volume changes but not in an expected/linear way. Would anyone know how Master Volume settings works with Pi-Amp+.

    Thanks
    Regards

    9. January 2016 at 16:56 #17651

    The correct setting in my case is 96% and not 100%.

    # amixer -c 0 contents
    numid=1,iface=MIXER,name='PCM'
    ; type=INTEGER,access=rw---R--,values=2,min=0,max=215,step=0
    : values=207,207
    | dBscale-min=-103.50dB,step=0.50dB,mute=1

    Note that at step 207 we are at 0dB (-103.50dB + 207 * 0.50dB = 0dB).

    The playback volume should indeed be 100%, which corresponds to 0dB, or 2VRMS (http://www.ti.com/lit/ds/symlink/pcm5122.pdf, page 6). I’m not sure what the playback gain actually does, except for providing an additional 0.80dB analog boost (page 99 in the pdf). It might be at the expense of something else. The default setting is 0, so I leave this one off. It’s a very small difference anyway.

    In my case 96%, 100%, 0% is indistinguishable from my other line output devices. PCM/digital at 100% is clipping the digital signal. But please check it for yourself with amixer -c 0 contents, because I was using another RPi distribution. The device number might be different too, so check that first.

    16. July 2016 at 22:24 #21628

    Hi!
    I, I’m using RaspyPlay4 sound card, and it is supported by Max2Play. Currently, I’m on version 2.33. The issue is that the sound output level is quite low when I’m connecting the sound card to my hifi device. On level 15 (out of 30) other devices in hifi (like CD, or FM radio) the sound is good. To achieve the same loudness while connected to RPi via audio in, I have to turn it to 25 (out of 30).
    I’ve tried to change the audio card to IQAudio card, and there is a volume boost setting on the interface, but when I’m dragging it to 100%, and press the save, after the page refresh, it is still on 0% (and there is no change in loudness).
    I’ve choosen the RaspyPlay4 sound card just, because I saw, it is supported by Max2Play.
    Thanks for your help.

    19. July 2016 at 15:49 #21660

    Hi scheferenc,
    Thanks for pointing out a small issue. We already fixed it in the beta, so you can make a beta update to fix it as well. But it will also be included in the next general update. Regarding the volume boost, we will also makes this a little more clear in a coming update, but the only two settings volume boost recognizes is 0 and 100; turning it either on or off. Thanks for the input and for supporting Max2Play.

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.

Register here