invalid desktop entry


This topic contains 11 replies, has 2 voices, and was last updated by  Bobw premium 4 months, 1 week ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • 17. June 2016 at 7:43 #20708

    Downloaded the image, ordered a premium license
    started up but can not enter the browser
    message invalid desktop entry file

    a bad start!

    17. June 2016 at 14:59 #20716

    Hi Bob,
    Max2Play is controlled over a web interface that can be accessed on any device in your local network like PC, smartphone or tablet. It is not intended for use as a Desktop PC, all configurations can be handled headlessly so that a connection to a screen is not necessary.

    18. June 2016 at 10:00 #20732

    I do not understand what is wrong. I created the image for the Hifi berry and I got than that message and a complete other gui layout.
    Now I switched over to the squeezelite image an a lot of things work.
    But still following problems:
    1. I had to add a max-usb-current=1 entry in the /boot/config.txt file to allow my 2 TB usb disk on the PI.
    2. I do not see the possibility to manage the Hifi-Berry. There is no extra raspberry setup tab as I see in the video tutorial.
    If I try to update the max2player I got message that it is updated to last version
    3 If I try to add a plugin I get the message SSL handshake failed so i have no access to the site
    4. I could scan my music files on the max2play SQB server but on my duet remote after connection with Max2play I get a fixed nessage: problem ,
    can not play filetype for teststream test?rate=1000

    ANY suggestions?

    19. June 2016 at 8:53 #20737

    1. this is OK now
    2. I learned from the tutorial now how to add the setup tab but it is not possible. See point 3.
    3. internet access is possible, other https sites as https/ seem to work, but https to max2player does not!
    found an earlier reaction to adapt the /etc/ssh/sshd_config file but this is OK, no patch needed.
    On windows PC connected to same router access is no problem
    Looked for hours now for a possible solution, but can not find one. PLEASE HELP

    19. June 2016 at 15:48 #20740

    I tried some workaround
    first on windows in browser get url of raspberrysettings tab
    found http://shop/
    entry this url in the field enter htpp/URL of the tab settings-reboot of max2/play
    install new plugin AND THAT WORKS
    After that several actions done upgrade Kernel,Upgrade Packages, new plugin for HifiBerry etc.

    AND NOW EVERYTHING seems OK , the SQB server, the Hifiberry and even the Duet remote. No need for the receiver

    BUT I still have one PROBLEM the OEPS error with the SSL HANDSHAKE

    20. June 2016 at 13:03 #20753

    Hi Bobw,
    Where do you get this SSL Handshake error? You mention that is comes up when you try to install a new plugin. This installation should happen over the web interface under Settings/Reboot. Does the error message appear as a yellow text or in the Debug Info-window?

    20. June 2016 at 16:18 #20766

    Thanks for reaction,

    procedure is as follows

    open the web browser with url from PI (in my case

    max2play gui opens

    select Settings/Reboot tab

    try to do a list from plugins (but I get same error if I try to launch one of all the help functions on the right side)

    a new tab opens in the webbrowser where I read the message Oeps…etc and in that message is mentioned the SSL error. So no yellow text or Debug window. I get the feeling that I am doing something very stupid?

    20. June 2016 at 16:24 #20767

    Hi bobw,
    It sounds like your device is not correctly connected to the internet. Which would explain your issue with the help functions which should all link to different web pages from our website. Please make sure your device has access to the internet to install new add-on’s. By internet access, I do mean the connection of the Pi to the web. Your access to web pages from the device you are accessing Max2Play with does not matter.

    20. June 2016 at 20:35 #20773

    Strange, I can use the webbrowser for other sites with no problem at all, even https.
    On same router (connected by cable as is the raspberry) connection with windows vista
    and Linux and there I can easy connect to your https site., But there I use Firefox as browser.
    Has it maybe some relation with certificates for your https site access?
    The ethernet connection is made on a router connected to another router, maybe I can test tomorrow
    with direct connection to the main router, to see if that makes any difference..

    21. June 2016 at 6:32 #20777

    I did several tests and I am quite sure now it has something to do with the browser on the max2play PI or maybe a general setting on the Pi. I connected it directly to my main router and still same problem.
    In all my other PC configurations (Firefox and not on the PI) access to the PI by the url in the firefox browser access is no problem at all.
    And finally I opened on the pi in the browser a few other sites with https and that was no problem at all.

    21. June 2016 at 12:12 #20792

    The browser on the Raspberry Pi is not intended for use. The whole Max2Play system is supposed to be headless, meaning control and configuration is only made from other devices via the Max2Play web interface.

    21. June 2016 at 13:01 #20793

    That was not clear to me. Maybe it is possible to specify in the documentation that you can not use the pi browser to do so.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Register here