[SOLVED] Interruption of Playback in Squeezeboxserver

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) [SOLVED] Interruption of Playback in Squeezeboxserver

This topic contains 3 replies, has 2 voices, and was last updated by  Heiner Moderator 2 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 26. April 2019 at 17:04 #45155

    Hi,

    I am experiencing problems with interruption of the music stream in my max2play system.It already appeared from time to time last week, but today it got really bad, stopping playing approx. every minute for 10s to 30s approximately. It appers both when streaming radio as well as when playing from local storage or even directly from the USB plugged into the Raspberry Pi server. If I run locally stored music, the time counter in the LMS web interface keeps on running, but than jumps back a few times and than goes on at the point and tiem where it stopped playing.
    I am running max2play in 3 rooms synchronously. The server is connected directly to my router, one player is connected via Power Lan, one via wifi. I tried changing the server to the other Raspberries, but that does not help. The music is synchronous while it runs and also stops synchronously.

    I am running max2play ver. 2.48 on Raspberry Pis with Hifiberry using Squeezebox and Squuezelite.

    On the server, I have the following debug info from the max2play web interface:
    #### FILESYSTEM ####
    Filesystem 1K-blocks Used Available Use% Mounted on
    rootfs 15186900 3903340 10632516 27% /
    /dev/root 15186900 3903340 10632516 27% /
    devtmpfs 470368 0 470368 0% /dev
    tmpfs 94936 592 94344 1% /run
    tmpfs 5120 0 5120 0% /run/lock
    tmpfs 189860 0 189860 0% /run/shm
    /dev/mmcblk0p1 57288 14736 42552 26% /boot
    //DSL-AC87VG-71FE/Stream 1953480700 830216668 1123264032 43% /mnt/Elements/Stream

    #### LOAD AVERAGE ####
    0.31 0.26 0.22 1/115 17886

    #### KERNEL ####
    Linux max2play 3.18.7-v7+ #755 SMP PREEMPT Thu Feb 12 17:20:48 GMT 2015 armv7l GNU/Linux

    #### LINUX-VERSION ####
    Distributor ID: Debian
    Description: Debian GNU/Linux 7.8 (wheezy)
    Release: 7.8
    Codename: wheezy

    There are no errors in the squeezebox log, just a warning on SQL:

    2019-04-26 10:01:51 squeezeboxserver_safe started.
    [19-04-26 10:01:57.6523] main::init (387) Starting Logitech Media Server (v7.9.1, 1522157629, Fri Mar 30 12:27:11 CEST 2018) perl 5.014002 – arm-linux-gnueabihf-thread-multi-64int
    [19-04-26 10:01:58.9821] Slim::Utils::Misc::msg (1252) Warning: [10:01:58.9808] DBIx::Class::ResultSet::update_or_create(): Query returned more than one row. SQL that returns multiple rows is DEPRECATED for ->find and ->single at /usr/share/perl5/Slim/Schema.pm line 1877

    Any help would be highly appreciated.

    Thanks and best regards

    30. April 2019 at 11:48 #45174

    Hi pte,

    Our wheezy-version of Max2Play is a bit older. You can try our brand new 2.48 Stretch version to eliminate this possible source of error.

    However, first check your Settings/Reboot Health Checker when playback drops out to see if your Pi’s vital stats are affected.

    1. Mai 2019 at 7:54 #45195

    Hi Heiner,

    the health check was fine (everything green) during interruption, so I moved the server to the new version as suggested. Looks fine so far!

    Thanks alot!

    Regards

    Peter

    2. Mai 2019 at 13:02 #45202

    Hi Peter,

    Thanks for the quick heads-up. I’ll mark the topic solved.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here