install_max2play.sh

Tagged: , , ,

This topic contains 7 replies, has 2 voices, and was last updated by  Raymond Day premium 7 months, 2 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 18. February 2017 at 20:50 #27015

    How do you install it. I have a NanoPi NEO Air with a NanoHat PCM5102A I think Max2play my work with it.

    I did the install_max2play.sh but I guess there is a lot more to set up then to just run that command.

    Can some one tell how in a all most step-by-step way?

    -Raymond Day

    19. February 2017 at 13:00 #27018

    I got it to work on the NanoPi NEO Air. I put my e-mail in and rebooted it and then no more WiFi! Got a RS-232 on it so worked on getting WiFi working again. Took a wile and got it working.

    Can go to it’s main page now for max2play. But I can’t start Squeezelite.

    I can play a mp3 with the command line and it works like this.

    [email protected]:~# madplay /media/JvB1on1c64.mp3
    MPEG Audio Decoder 0.15.2 (beta) - Copyright (C) 2000-2004 Robert Leslie et al.
              Title: Jordan VS BIRD: One on One
             Artist: Electronic Arts
              Album: commodore 64
               Year: 1988
              Genre: video game
            Comment: From the commodore 64 computer JORDAN VS BIRD: One on one by
                     joe Hellesen, Mark Madland. Electronic Arts (R) 1988
    7122 frames decoded (0:03:06.0), -3.6 dB peak amplitude, 0 clipped samples
    [email protected]:~#

    The info on this sound is here.

    It seems like if I do any settings with Max2play on it then it messes up the WiFi and “This site can’t be reached”. This NanoPi NEO Air seems like it don’t have a stander WiFi. Like nmtui will not work with it just shows blank.

    It be neat to have max2play working good on this. Seems like all most got it.

    -Raymond Day

    19. February 2017 at 15:28 #27022

    Just can’t get it to play on the NanoPi Neo Air.

    Here is a screen shot of things I can pick but seems like none work.

    show a list what I can pick

    The image don’t work to show it right here but click on this link to see it.

    -Raymond Day

    19. February 2017 at 15:32 #27023

    Here is the debut info.

    #### SQUEEZELITE VERSION ####
    Squeezelite v1.8.6-830, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.
     
    
    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT DSD
     
    
    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o hw:CARD=Pcm5102a,DEV=0 -a 80:4:: madplay
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d plughw:CARD=sndhdmi,DEV=0
    USE_USB_DAC=0
    USE_EQUALIZER=0
     
    
    #### SQUEEZELITE -l ####
    Output devices:
      null                           - Discard all samples (playback) or generate zero samples (capture)
      sysdefault:CARD=Pcm5102a       - Pcm5102a,  - Default Audio Device
      dmix:CARD=Pcm5102a,DEV=0       - Pcm5102a,  - Direct sample mixing device
      dsnoop:CARD=Pcm5102a,DEV=0     - Pcm5102a,  - Direct sample snooping device
      hw:CARD=Pcm5102a,DEV=0         - Pcm5102a,  - Direct hardware device without any conversions
      plughw:CARD=Pcm5102a,DEV=0     - Pcm5102a,  - Hardware device with all software conversions
      sysdefault:CARD=sndhdmi        - sndhdmi,  - Default Audio Device
      dmix:CARD=sndhdmi,DEV=0        - sndhdmi,  - Direct sample mixing device
      dsnoop:CARD=sndhdmi,DEV=0      - sndhdmi,  - Direct sample snooping device
      hw:CARD=sndhdmi,DEV=0          - sndhdmi,  - Direct hardware device without any conversions
      plughw:CARD=sndhdmi,DEV=0      - sndhdmi,  - Hardware device with all software conversions
    
     
    
    #### SHAIRPORT VERSION ####
    2.8.6-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc
     
    
    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed
     
    
    #### OUTPUT SOUND DETAILS CARD 1 ####
    closed

    -Raymond Day

    20. February 2017 at 14:59 #27044

    Dear Raymond Day,

    Unfortunately, we do not provide technical support for NanoPi Neo Air neither NanoHat PCM5102A at the moment.

    Regards,
    Mohammad

    26. February 2017 at 12:32 #27237

    Posted it some place else but all I had to do to fix this was a command to install the player. apt install squeezelite and it fixed it.

    But hard to know this I would have to test more but on a reboot it would lose it’s WiFi. I had to edit the /etc/network/interfaces thought the RS-232 to get it back.

    But I plug in a USB to Ethernet on it and got on it like that and unchecked the Load WiFi Interface and rebooted and that worked. Even though the it’s still checked on the Load WiFi Interface.

    So seems like working good now.

    27. February 2017 at 13:56 #27261

    Hi Raymond Day

    Thank you to share your experience with NanoPi Neo Air in our forum, and we are happy that you solved your problem.

    Best Regards,
    Mohammad Mbydeen

    10. April 2017 at 23:01 #28088

    It seems like they changed that install_max2play.sh so it don’t work with other systems. To get it to work have to open it and look at the commands and copy and paste them on the command line. Not all just the ones that look like things it don’t do.

    So I just don’t get why can’t the install_max2play.sh just say other when it don’t find a Odroid or Pi.

    -Raymond Day

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here