Install on a 2TB SSD?

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Install on a 2TB SSD?

This topic contains 3 replies, has 2 voices, and was last updated by  MarioM Moderator 6 days, 20 hours ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 19. Januar 2023 at 19:35 #52600

    I used Raspberry Pi Imager to put it right on a 2 terabyte SSD and it boots up and it works real good I started to copy my music to it but it filled it up real soon so it doesn’t expand it.

    So I turned it off and I used Gparted to expand the last partition.

    But then it don’t boot just keeps a flashing cursor on the top left corner of the screen.
    Could only do the command line and I guess I messed up cuz every time it just boots up to the flashing cursor.
    So I installed Max2play again but on a 32 GB SD card and I updated all and installed the raspberry pi clone but it just don’t boot.

    What is the right way to install max2play on a 2TB SSD and use all the room?

    -Raymond Day

    20. Januar 2023 at 14:37 #52605

    Burn the m2p_buster_rpi-v253.img.zip with Raspberry Pi Imager.

    Says 93% used:

    /dev/root 3.1G 2.7G 217M 93% /

    fdisk -l /dev/sda shows this:

    Disk /dev/sda: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
    Disk model: 2115
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: dos
    Disk identifier: 0x0634f60c

    Device Boot Start End Sectors Size Id Type
    /dev/sda1 8192 532480 524289 256M c W95 FAT32 (LBA)
    /dev/sda2 540672 7000000 6459329 3.1G 83 Linux

    Went to resize it right in max2play but it says this:

    Resize Filesystem: sda2
    No Resize possible – no valid partition found to expand. Contact Max2Play-Support to add support for further file-systems.
    Make sure to disconnect all USB-drives and Memory-Cards and do a reboot before expanding the filesystem!

    Any other way to get this to use all the 2TB space?

    23. Januar 2023 at 17:33 #52607

    It worked I used raspi-config

    Under user pi.

    Advanced Options

    Then the top one „Expand Filesystem“ and it just did it right away and said to reboot and I did and now it shows this:

    [email protected]:~# df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/root 1.8T 2.8G 1.8T 1% /
    devtmpfs 3.7G 0 3.7G 0% /dev
    tmpfs 3.9G 0 3.9G 0% /dev/shm
    tmpfs 3.9G 9.5M 3.9G 1% /run
    tmpfs 5.0M 4.0K 5.0M 1% /run/lock
    tmpfs 3.9G 0 3.9G 0% /sys/fs/cgroup
    /dev/sda1 253M 54M 199M 22% /boot
    tmpfs 783M 0 783M 0% /run/user/0
    [email protected]:~#

    Only 1% used now.

    Not sure how it did it but worked.

    Don’t know why the built in one to Max2play did not work.

    -Raymond Day

    24. Januar 2023 at 14:10 #52609

    Hi Raymond,

    Thank you for sharing your solution with us. The function for expanding the file system in Max2Play is not designed for such large partitions. However, we will check whether we can update this.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here