I hate that it mixes up the Max2play server names.

Max2Play Home 2016 (en) Forums Max2Play Development (Ideas, Wishes) I hate that it mixes up the Max2play server names.

This topic contains 4 replies, has 2 voices, and was last updated by  MarioM Moderator 5 months, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 5. Januar 2022 at 15:12 #51886

    To show what I am talking about I uploaded a short video on YouTube.

    Look in the top right corner it switching.

    Maybe have it just look at the mac address to fix this. I got about 7 or so max2play players. I have to turn some off when it mixes them up.

    At least it plays on the one I pick when the name shows up in the LMS.

    I hope you can fix this. Just get about 7 pies and name them all different names what it mix them up.

    It’s playing on what I name goundedmusic that I renamed and rebooted like 4 times to see if will fix this. Mixies it up with shelf-max2play name.

    Then if I go to play it again it will look like it playing but not I guess it’s playing on the other name one.

    -Raymond Day

    • This topic was modified 5 months, 3 weeks ago by  Raymond Day.
    5. Januar 2022 at 17:06 #51889

    I think I fixed it by doing this command:

    apt install macchanger

    As it installs a menu comes up and I picked Yes. Then press Enter.

    Now it seems like it don’t mix them up now.

    -Raymond Day

    6. Januar 2022 at 13:06 #51896

    Hi Raymond,

    I’m glad you found a workaround for the issue. This will certainly help others who encounter the same problem.

    12. Januar 2022 at 16:32 #51926

    I had my other player turn off and then turn it on and install macchanger.

    But it still mixes it up with „max2play-Justboom“ and „Groundedmusic“ what I named them.

    Can start to play music on „Groundedmusic“ then it will stop because looks like it switched between them.

    Looking at the mac I did this command on both.

    [email protected]:~# macchanger -s eth0
    Current MAC: b8:27:eb:09:fb:06 (Raspberry Pi Foundation)
    Permanent MAC: b8:27:eb:09:fb:06 (Raspberry Pi Foundation)
    [email protected]:~#

    [email protected]:~# macchanger -s eth0
    Current MAC: c2:45:80:ad:4c:47 (unknown)
    Permanent MAC: 00:00:00:00:00:00 (XEROX CORPORATION)
    [email protected]:~#

    So I guess because the Groudedmusic don’t have a Permanent MAC it mixes it up is that right? Can you program it so it looks at the Current MAC address the one you can change? I guess that would fix it.

    -Raymond Day

    13. Januar 2022 at 13:47 #51927

    Hi Raymond,

    We are not responsible for the programming of the Squeezebox server. You would have to ask the developers in the slimdevices forum. But I think it would be better to solve the problem with your Mac addresses instead of changing the whole LMS.
    Do I understand it correctly that macchanger failed to change Groundedmusic’s permanent mac? In this case, you could try the following:
    Open a terminal and type: sudo nano /boot/config.txt Add this line there smsc95xx.macaddr=76:69:2c:38:54:a0 if it does not already exist. And adjust the Mac address accordingly. Then save the file. After a reboot, the Mac address should be active.

    If this still does not work, open the file /boot/cmdline.txt and delete all mac addresses there and then try again with the config.txt.

    If you use the network manager, you should also uninstall it in any case so that it does not interfere.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here