[SOLVED] HowTo disable software volume control with HiFiBerry Digi+ Pro

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions [SOLVED] HowTo disable software volume control with HiFiBerry Digi+ Pro

This topic contains 7 replies, has 2 voices, and was last updated by  Heiner Moderator 1 month, 2 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 7. August 2018 at 19:05 #36847

    Hi,

    Using a Raspi 3B+ with HiFiberry Digi+ Pro I’m wondering if volume control in squeezelite is done by software?

    Because setting extended parameters for squeezlite with „-o hw:0 -V Digital“ does not produce any sound output on the Digi+ Pro, nevertheless „-o hw:1 -V digital“ works.

    Now I’m in doubt if hw:0 is using the wrong soundcard or hw:1 points into nirvana and therefore the software volume control is still active.

    Btw: I would prefer to disable all volume control with Digi+ Pro, because this should be done by the receiver only after DAC. This is also an option on my old Squeezebox Classic, where the sound control widget just has no function any more.

    Thanks for any help,

    Ronald

    8. August 2018 at 10:20 #36856

    Hi Ronald,

    If you have full volume and have the correct hw setting for your sound card slot (you can see it in the debug info) then your Digi works without volume control.

    8. August 2018 at 13:04 #36862

    Hi Heiner,

    What do you mean „works without volume control“?

    What parameters do I have to set in command line?
    Or do I have to set maximum volume in squeezelite to not have any software component alter the stream?

    Because then I’ll never know whether some player control will reduce the volume accidentally or by means and therefore will spill accurate transmission of digital sound data to the receiver.

    Debug Information:

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.
     
    
    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC
     
    
    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o default:CARD=sndrpihifiberry -a 80:4:: -o hw:1 -U Digital -v
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d default:CARD=sndrpihifiberry
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=--webport 8081
     
    
    #### SQUEEZELITE -l ####
    Output devices:
      null                           - Discard all samples (playback) or generate zero samples (capture)
      equal                         
      plugequal                      - Equalizer for plughw:0,0
      default:CARD=ALSA              - bcm2835 ALSA, bcm2835 ALSA - Default Audio Device
      sysdefault:CARD=ALSA           - bcm2835 ALSA, bcm2835 ALSA - Default Audio Device
      dmix:CARD=ALSA,DEV=0           - bcm2835 ALSA, bcm2835 ALSA - Direct sample mixing device
      dmix:CARD=ALSA,DEV=1           - bcm2835 ALSA, bcm2835 IEC958/HDMI - Direct sample mixing device
      dsnoop:CARD=ALSA,DEV=0         - bcm2835 ALSA, bcm2835 ALSA - Direct sample snooping device
      dsnoop:CARD=ALSA,DEV=1         - bcm2835 ALSA, bcm2835 IEC958/HDMI - Direct sample snooping device
      hw:CARD=ALSA,DEV=0             - bcm2835 ALSA, bcm2835 ALSA - Direct hardware device without any conversions
      hw:CARD=ALSA,DEV=1             - bcm2835 ALSA, bcm2835 IEC958/HDMI - Direct hardware device without any conversions
      plughw:CARD=ALSA,DEV=0         - bcm2835 ALSA, bcm2835 ALSA - Hardware device with all software conversions
      plughw:CARD=ALSA,DEV=1         - bcm2835 ALSA, bcm2835 IEC958/HDMI - Hardware device with all software conversions
      default:CARD=sndrpihifiberry   - snd_rpi_hifiberry_digi,  - Default Audio Device
      sysdefault:CARD=sndrpihifiberry - snd_rpi_hifiberry_digi,  - Default Audio Device
      iec958:CARD=sndrpihifiberry,DEV=0 - snd_rpi_hifiberry_digi,  - IEC958 (S/PDIF) Digital Audio Output
      dmix:CARD=sndrpihifiberry,DEV=0 - snd_rpi_hifiberry_digi,  - Direct sample mixing device
      dsnoop:CARD=sndrpihifiberry,DEV=0 - snd_rpi_hifiberry_digi,  - Direct sample snooping device
      hw:CARD=sndrpihifiberry,DEV=0  - snd_rpi_hifiberry_digi,  - Direct hardware device without any conversions
      plughw:CARD=sndrpihifiberry,DEV=0 - snd_rpi_hifiberry_digi,  - Hardware device with all software conversions
    
     
    
    #### SHAIRPORT (SYNC) VERSION ####
    3.1.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc
     
    
    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed
     
    
    #### OUTPUT SOUND DETAILS CARD 1 ####
    access: MMAP_INTERLEAVED
    format: S24_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 882
    buffer_size: 3528
     
    
    8. August 2018 at 14:05 #36867

    If you have the sound card for hifiberry digi enabled, there is no software volume control between digi and your output device by default.

    Squeezelite should not have a built-in volume control.

    8. August 2018 at 15:01 #36869

    Sqeezelite has a volume control widget enabled which is functional. Because Digi+ has no hardware volume control (which makes sense) the only one affecting volume can be software. If I click on the volume control widget, the volume increases / decreases accordingly.
    I’m using the webinterface for this.

    Hardcopy: https://drive.google.com/file/d/1XjcHsfpHqBUIZpKN5nGhNCjamwu9fUY7/view?usp=sharing

    • This reply was modified 1 month, 2 weeks ago by  RonaldR.
    8. August 2018 at 17:14 #36877

    Hi Ronald,

    Sorry about the confusion, the software volume on the Squeezebox Server is functional. Having volume at full capacity will ensure you are not losing any quality from adjustment here.

    If you want to disable the volume control on the Squeezebox Server completely, you can follow these steps

    8. August 2018 at 18:10 #36880

    Thank you, that’s it!

    9. August 2018 at 9:08 #36888

    No problem, glad it helped 🙂

    I’ll close the topic.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here