[SOLVED] How to set the Bitrate in Spotify connect ?

Max2Play Home 2016 (en) Forums Max2Play Add-ons [SOLVED] How to set the Bitrate in Spotify connect ?

Tagged: ,

This topic contains 3 replies, has 2 voices, and was last updated by  Heiner Moderator 2 weeks, 4 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 6. June 2017 at 17:10 #29307

    Hello,
    spotify connect works.
    .. but i don’t know the correct syntax to change the bitrate to 320.

    [-b 320] korrect ??

    7. June 2017 at 12:40 #29334

    Hi sq_ko_lpz,

    You are correct. You can find all parameters in the debug window below the menu, here it is:
    Options:

    -c, –cache CACHE Path to a directory where files will be cached.
    -n, –name NAME Device name
    -b, –bitrate BITRATE
    Bitrate (96, 160 or 320). Defaults to 160
    –onstart PROGRAM
    Run PROGRAM when playback is about to begin.
    –onstop PROGRAM
    Run PROGRAM when playback has ended.
    -v, –verbose Enable verbose output
    -u, –username USERNAME
    Username to sign in with
    -p, –password PASSWORD
    Password
    –disable-discovery
    Disable discovery mode
    –backend BACKEND
    Audio backend to use. Use ‘?’ to list options
    –device DEVICE Audio device to use. Use ‘?’ to list options
    –mixer MIXER Mixer to use

    In your case it would indeed just be:
    -b 320

    7. June 2017 at 13:02 #29335

    Vielen Dank,

    bei mir steht: “,–bitrate 320”

    sieht im Debugfenster (Player) so aus:
    SPOTIFYCONNECT_PARAMETER=–username spotlpz –password “spot703” –device plug:equalUSB ,–bitrate 320

    “-b 320” führt zu:
    Versucht zu starten … NICHT Erfolgreich Hier klicken für weitere Informationen
    error: Option ‘bitrate’ given more than once.
    Usage: /opt/spotifyconnect/librespot [options]

    sieht im Debugfenster (Player) so aus:
    SPOTIFYCONNECT_PARAMETER=–username spotlpz –password “spot703” –device plug:equalUSB -b 320
    Spotify startet nicht mehr.

    ich vermute hier ist etwas mit der interpretation der kommandozeile nicht ok.

    Wieder “,–bitrate 320”. Spotify startet. Ich denke, die 320 sind aber nicht eingestellt. (Spotify Premium ist vorhanden)

    9. June 2017 at 12:57 #29448

    Hi sq_ko_lpz,

    Sorry about the misunderstanding. Our head developer Stefan had already added a line to alter the default from the plugin to 320 from first installation. This is the reason why you receive a message saying that it’s given more than once. We might add some info in the plugin telling new users that this occurs and they don’t have to worry about the error message. Thanks for pointing us towards this issue.

    TL;DR
    The Spotify Connect Plugin automatically sets the playback bitrate to 320

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here