How to replace internal WiFi with external USB Wifi Edimax EW-7612UAn V2 on Pi4

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions How to replace internal WiFi with external USB Wifi Edimax EW-7612UAn V2 on Pi4

This topic contains 5 replies, has 2 voices, and was last updated by  MarioM Moderator 6 days, 23 hours ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 13. November 2021 at 10:59 #51785

    Hello together,
    that’s my first topic here and I hope to provide sufficient info for the issue I’m having.
    I want to replace the on board WiFi of my Pi4 with an external WiFi stick (EW-7612UAn V2) because of instable WiFi connection causing buffering too frequently.

    My Configuration:
    Pi 4
    Rapberry Pi Touch Display 7″
    HiFiberry DAC+ Zero

    At the Raspberry settings page in max2play I disabaled the standard WLAN „Deaktiviere Standard WLAN Oberfläche WLAN0 bei RPi3“.
    Also enabled the maximum power checkbox for USB.

    #dmesg shows that the stick was found
    [ 2.273713] usb 1-1.4: new high-speed USB device number 3 using xhci_hcd
    [ 2.416016] usb 1-1.4: New USB device found, idVendor=7392, idProduct=7822, bcdDevice= 2.00
    [ 2.416036] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 2.416054] usb 1-1.4: Product: 802.11n WLAN Adapter
    [ 2.416071] usb 1-1.4: Manufacturer: Realtek
    [ 2.416089] usb 1-1.4: SerialNumber: 00e04c000001

    It seems that the usb driver is not correctly loaded, I would expect there the driver from realtek rtl8192cu, but instead still the broadcom brcmfmac is loaded.

    [ 5.630657] Console: switching to colour frame buffer device 100×30
    [ 5.636462] vc4-drm gpu: [drm] fb0: vc4drmfb frame buffer device
    [ 5.745971] cfg80211: Loaded X.509 cert ’sforshee: 00b28ddf47aef9cea7′
    [ 5.835872] brcmfmac: F1 signature read @0x18000000=0x15264345
    [ 5.851418] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
    [ 5.851963] usbcore: registered new interface driver brcmfmac
    [ 5.880398] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt failed with error -2
    [ 6.124893] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
    [ 6.135024] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Jan 4 2021 19:56:29 version 7.45.229 (617f1f5 CY) FWID 01-2dbd9d2e
    [ 6.225853] brcmfmac mmc1:0001:1 wlan1: renamed from wlan0
    [ 7.902278] uart-pl011 fe201000.serial: no DMA platform data
    [ 8.403815] Adding 102396k swap on /var/swap. Priority:-2 extents:3 across:813100k SSFS
    [ 8.605876] FS-Cache: Netfs ‚cifs‘ registered for caching
    [ 8.641358] Key type cifs.spnego registered
    [ 8.641393] Key type cifs.idmap registered
    [ 8.643202] CIFS: Attempting to mount //192.168.1.117/music
    [ 8.643316] CIFS: No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3.1.1), from CIFS
    (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3.1.1 (or even SMB3 or SMB2.1) specify vers=1.0 o
    n mount.
    [ 8.643487] CIFS: VFS: Error connecting to socket. Aborting operation.
    [ 8.643520] CIFS: VFS: cifs_mount failed w/return code = -101

    Any help or hint would be really appreciated!

    Thanks a lot in advance,
    Michael

    16. November 2021 at 14:31 #51789

    Hi Michael,

    Please follow these steps:

    1. connect dongle and LAN cable to Pi, boot up
    2. install the Remote Control Plugin
    3. install „ShellInABox“ in the Remote Control Plugin
    4. click „Open Console Fullscreen“
    5. login: pi; password: max2play
    6. execute the following commands in this order:
    sudo wget http://downloads.fars-robotics.net/wifi-drivers/install-wifi -O /usr/bin/install-wifi
    sudo chmod +x /usr/bin/install-wifi
    sudo install-wifi if that doesn’t work, try: sudo /usr/bin/install-wifi you should see that the driver for your dongle has been recognised and installed
    sudo reboot
    7. after reboot disable the integrated Wifi in the Raspberry settings (then reboot again)
    8. set up Wifi and activate WLAN interface
    9. at the top of the Wifi plugin you should see „active“ twice as well as an IP address
    10. shut down the Pi, disconnect the LAN cable and reboot
    11. the Pi should connect to the router via WLAN.

    Does that solve your problem?

    16. November 2021 at 23:26 #51793

    Hello Mario,
    thank you very much for your support on this topic!!
    I followed your instruction and got the below message when running the wifi-install.
    Do you have any advise? In understood that the Edimax-7612UAn basically runs with the driver rtl8192cu.
    But the scrit seems not to support that, only rtl8192eu is supported.
    Any idea?

    *** Raspberry Pi wifi driver installer by MrEngman.
    *** Performing self-update
    *** Relaunching after update

    *** Raspberry Pi wifi driver installer by MrEngman.

    Your current kernel revision = 5.10.17-v7l+
    Your current kernel build = #1403

    Checking for a wifi module to determine the driver to install.

    Your wifi module is unrecognised.

    **** Unable to identify your wifi module ****

    The script only works for wifi modules using the rtl8188eu, rtl8188fu, rtl8192eu, rtl8812au, rtl8821cu, 8822bu, mt7610 and mt7612 drivers.

    Looking for your wifi module the script detected the following USB devices:-

    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 004: ID 7392:7822 Edimax Technology Co., Ltd
    Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    If you are certain your module uses one of the drivers the script installs check the output of command
    ‚lsusb‘ shows your wifi module. If lsusb shows your wifi module try running the script again. If the
    script fails to detect your wifi module again the driver may need updating to add your module USB id.

    If lsusb does not show your wifi module you will need to resolve that issue before the script can be
    used to install the driver you need.

    Thanks again for all your efforts in advance!
    Best regards,
    Michael

    19. November 2021 at 13:35 #51798

    Ok, apparently there is no installation from MrEngman for this driver.
    Maybe this forum post will help you: https://forums.raspberrypi.com/viewtopic.php?t=264202 A similar problem is discussed there. You may need to modify the /etc/network/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf files to make your dongle work.

    20. November 2021 at 14:11 #51804

    Hello Mario,
    once again thanks for great help!!
    This has unfortunately not solved the issue. Still the driver was not loaded when booting. And I guess this is the real issue.
    [ 5.372559] brcmfmac: F1 signature read @0x18000000=0x15264345
    [ 5.390612] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
    [ 5.391647] usbcore: registered new interface driver brcmfmac

    Therefore I searached the web a bit and tried following to understand if the driver is supported already. And yes it is:

    [email protected]:~ $ modprobe -c | grep -i „7392.*7822“
    alias usb:v7392p7822d*dc*dsc*dp*ic*isc*ip*in* rtl8192cu

    I loaded the driver manually
    [email protected]:~ $ sudo modprobe rtl8192cu

    Now it also shows up at loaded modules
    [email protected]:~ $ lsmod
    Module Size Used by
    rtl8192cu 86016 0
    rtl_usb 20480 1 rtl8192cu
    rtl8192c_common 65536 1 rtl8192cu
    rtlwifi 114688 3 rtl_usb,rtl8192c_common,rtl8192cu
    mac80211 802816 3 rtl_usb,rtlwifi,rtl8192cu

    And it seems well connected, WiFi Stick has Blue LED on and I can access via WiFi with remote console! Great!
    [ 215.944073] rtl8192cu: Chip version 0x11
    [ 216.021062] rtl8192cu: Board Type 0
    [ 216.021248] rtl_usb: rx_max_size 15360, rx_urb_num 8, in_ep 1
    [ 216.021303] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw_TMSC.bin
    [ 216.021534] ieee80211 phy1: Selected rate control algorithm ‚rtl_rc‘
    [ 216.030062] usbcore: registered new interface driver rtl8192cu
    [ 216.260990] rtl8192cu: MAC auto ON okay!
    [ 216.289774] rtl8192cu: Tx queue select: 0x05
    [ 218.137860] wlan0: authenticate with 84:d8:1b:8c:97:0c
    [ 218.160930] wlan0: send auth to 84:d8:1b:8c:97:0c (try 1/3)
    [ 218.185617] wlan0: authenticated
    [ 218.195944] wlan0: associate with 84:d8:1b:8c:97:0c (try 1/3)
    [ 218.235049] wlan0: RX AssocResp from 84:d8:1b:8c:97:0c (capab=0x1431 status=0 aid=5)
    [ 218.338625] wlan0: associated

    But the question is now: how to make sure that it also is done automatically while normal boot?
    Any hint would really be appreciated!

    Thanks a lot,
    Michael

    25. November 2021 at 14:18 #51811

    Hi Michael,

    In this case, you could add the command sudo modprobe rtl8192cu in /etc/rc.local before exit. This way the command will be executed when the Pi starts up.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here