How to play external Audio CD

Max2Play Home 2016 (en) Forums Max2Play Add-ons How to play external Audio CD

This topic contains 3 replies, has 2 voices, and was last updated by  Robert premium 11 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 17. August 2015 at 15:23 #15386

    Hi,

    I have a RPi and using the HDMI output connected to my amp. The LMS server runs on my QNAP NAS. It works well, the only missing stuff is to play audio CD from an external CD driver. It is possible? If yes, how? Where to connect the external drive? To RPi or to NAS? It is possible to auto play CD to one of the player?

    thanks in advance.
    Best,
    Ferenc

    1. September 2015 at 21:58 #15567

    Hi,
    I’ve installed the LMS 7.9.0 on M2P, activated the CDPlayer plugin, but sill, I cant play CD-roms. I can see these in logs:

    Sep 1 21:37:47 Etkezo kernel: [ 7.108118] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
    Sep 1 21:37:47 Etkezo kernel: [ 7.239424] usb 1-1.2: New USB device found, idVendor=13fd, idProduct=0842
    Sep 1 21:37:47 Etkezo kernel: [ 7.257158] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    Sep 1 21:37:47 Etkezo kernel: [ 7.275794] usb 1-1.2: Product: USB Mass Storage Device
    Sep 1 21:37:47 Etkezo kernel: [ 7.292480] usb 1-1.2: Manufacturer: TSSTcorp
    Sep 1 21:37:47 Etkezo kernel: [ 7.305044] usb 1-1.2: SerialNumber: SATASLIM00003010c98
    Sep 1 21:37:47 Etkezo kernel: [ 7.320953] usb-storage 1-1.2:1.0: USB Mass Storage device detected
    Sep 1 21:37:47 Etkezo kernel: [ 7.343665] scsi host0: usb-storage 1-1.2:1.0
    Sep 1 21:37:47 Etkezo kernel: [ 7.370614] snd-rpi-iqaudio-dac sound: snd_soc_register_card() failed: -517
    Sep 1 21:37:47 Etkezo kernel: [ 7.462765] platform sound: Driver snd-rpi-iqaudio-dac requests probe deferral
    Sep 1 21:37:47 Etkezo kernel: [ 7.560626] snd-rpi-iqaudio-dac sound: ASoC: CODEC DAI pcm512x-hifi not registered
    Sep 1 21:37:47 Etkezo kernel: [ 7.584905] snd-rpi-iqaudio-dac sound: snd_soc_register_card() failed: -517
    Sep 1 21:37:47 Etkezo kernel: [ 7.603842] platform sound: Driver snd-rpi-iqaudio-dac requests probe deferral
    Sep 1 21:37:47 Etkezo kernel: [ 8.350608] scsi 0:0:0:0: CD-ROM TSSTcorp CDDVDW SE-T084P TS00 PQ: 0 ANSI: 0
    Sep 1 21:37:47 Etkezo kernel: [ 8.464384] sr 0:0:0:0: [sr0] scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
    Sep 1 21:37:47 Etkezo kernel: [ 8.487984] cdrom: Uniform CD-ROM driver Revision: 3.20
    Sep 1 21:37:47 Etkezo kernel: [ 8.511525] sr 0:0:0:0: Attached scsi CD-ROM sr0

    It seems, CDrom drive has been recognized, but I dont know, what is the path (ie. /dev/cdrom does not exists). Ho can I get it works?

    Thanks,
    Ferenc

    2. September 2015 at 22:32 #15593

    Hi,

    I’m going forward on this route: trying to install cdda2wav, but no success. Can somebody help me there please? I’ve gopt the cdda2wav tar.gz file, extracted, tring to run these commands:
    ./configure
    make
    make install

    Configure went well, but using the make command, I’ve got this error:

    Making all in scsilib
    make[1]: Entering directory '/mnt/cdda/scsilib'
    Compiling scsitransp.c ...
    In file included from ./scsitransp.c:34:0:
    ./standard.h:173:12: error: conflicting types for ‘getline’
    /usr/include/stdio.h:671:20: note: previous declaration of ‘getline’ was here
    In file included from ./unixstd.h:32:0,
                     from ./scsitransp.c:36:
    /usr/include/unistd.h:554:12: error: conflicting types for ‘fexecve’
    ./standard.h:129:12: note: previous declaration of ‘fexecve’ was here
    In file included from ./scgio.h:27:0,
                     from ./scsitransp.c:51:
    ./btorder.h:30:2: warning: suggest not using #elif in traditional C [-Wtraditional]
    In file included from ./scsitransp.c:51:0:
    ./scgio.h:30:2: warning: suggest not using #elif in traditional C [-Wtraditional]
    ./scgio.h:37:1: error: unknown type name ‘error’
    ./scgio.h:37:12: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘of’
    ./scgio.h:37:12: error: unknown type name ‘of’
    ./scgio.h:395:22: error: field ‘Scb’ has incomplete type
    In file included from ./scsihack.c:39:0,
                     from ./scsitransp.c:146:
    ./scsi-linux-sg.c: In function ‘scsi_send’:
    ./scsi-linux-sg.c:367:1: warning: traditional C rejects ISO C style function definitions [-Wtraditional]
    ./scsi-linux-sg.c:542:10: warning: missing terminating " character [enabled by default]
    ./scsi-linux-sg.c:543:20: warning: missing terminating " character [enabled by default]
    Makefile:315: recipe for target 'scsitransp.o' failed
    make[1]: *** [scsitransp.o] Error 1
    make[1]: Leaving directory '/mnt/cdda/scsilib'
    Makefile:330: recipe for target 'all-recursive' failed
    make: *** [all-recursive] Error 1
    [email protected]:/mnt/cdda#
    

    Any idea?

    2. January 2016 at 16:26 #17533

    Hi

    The easiest way (the first 4 steps are done only once 😉 )

    1/ Install foobar2000 on your PC / laptop.
    2/ Install the UPNP MediaRendererOutPut plugin to foobar2000.
    3/ Activate DLNA audio client in Max2Play
    4/ In foobar2000, select the output device max2play-DLNA
    5/ Insert CD in the PC / laptop and play it with foobar2000 with a cristal sound quality 🙂

    I know that is not exactly what you were trying to do but it is easy and works great 🙂

    • This reply was modified 11 months, 1 week ago by  Robert.
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here