How to make airplay work

Viewing 4 posts - 1 through 4 (of 4 total)
  • 29. April 2016 at 23:41 #20002

    I have a Raspberry Pi 2 with a HiFiberry amp+ card and I am trying to set up the system so that will allow me to stream music from both Android and IOS devices to my speakers. I used the max2play ‚advanced‘ installation option but for seem reason, I can’t make it work. Could somebody please provide some step-by-step instructions? The Squeezebox server is installed and up and running. As far I understand, there are two options to make airplay work: 1) through the Shairtunes2 plugin for the Squeezebox; and 2) by running Shairport under the ‚Audioplayer‘ tab. Are these mutually exclusive? And which would you recommend in my case? Also: how can I indicate that the music has to go to the speakers via the amp+ card?
    So here’s where I got: when I install the shairtunes plugin and then reboot, I have no idea whether it worked (how can I check?) and my IOS devices don’t see max2play. When I start Squeezelite and Shairport (what should I put the soundcard on in the advanced options in both cases?)they do start. I have also put them both on autostart. In this case, I DO see max2play on my IOS devices and I can activate it, but I still her nothing on the speakers that are attached to the amp+ card.
    Last question: with this setup, how can I stream music from an Android device?
    Any help would be greatly appreciated – thanks!


    2. Mai 2016 at 13:43 #20013

    Hi Stephan,
    First, you need to activate your sound card, if that has happened, you should find options default and sysdefault with the name of your sound card (hifiberry_amp) in the list of available outputs. Choose sysdefault for one of your players, you cannot have both players running with the same output. We would recommend Squeezelite since it should be available for both Android and iOS with apps like iPeng for iOS and Squeezer for Android. You can see if the shairtunes plugin is installed in your Squeezebox Server Interface’s Settings.

    2. Mai 2016 at 14:06 #20015

    Thanks Heiner. By activating my sound card, you mean in the Raspberry Settings? I just did that Amp+ Activated (just posting for others who nay have the same problem). And then I do indeed see hifiberry option in the advanced options of squeezelite. . Thanks also for specifying that we have to use different options (sysdefault and default) for different players!

    • This reply was modified 8 years, 1 month ago by sdspieg.
    2. Mai 2016 at 14:20 #20018

    Hi Stephan,
    Please only use the sysdefault option. You can only put out through one player at a time, so do not select the Amp+ for both or have one deactivated.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here