How to get the "usb 3d sound" to work?

Max2Play Home 2016 (en) Forums Max2Play on ODROID U3/C1 How to get the "usb 3d sound" to work?

This topic contains 3 replies, has 2 voices, and was last updated by  Raymond Day premium 1 year, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 18. September 2015 at 23:26 #15740

    I like this but have to have the TV on just to hear the audio. So wanted to plug in some speakers.

    Plug in a USB 3D sound I have.

    I think it installed the driver the LED light flashed and then stayed on. Can I set the audio out put to it too. So it goes to it and the HDMI LCD?

    Here is the “Debug Information” that looks like it added when I plug it in:

    #### SQUEEZELITE -l ####
    Output devices:
      null                           - Discard all samples (playback) or generate zero samples (capture)
      pulse                          - PulseAudio Sound Server
      dmixer                         - DMixer for hw:0,0
      default                       
      plugdmixer                    
      plugequal                      - Equalizer for DMixer
      equal                         
      headphonesplug                
      bs2b                          
      headphones                    
      sysdefault:CARD=odroidaudio    - odroid-audio,  - Default Audio Device
      dmix:CARD=odroidaudio,DEV=0    - odroid-audio,  - Direct sample mixing device
      dmix:CARD=odroidaudio,DEV=1    - odroid-audio,  - Direct sample mixing device
      dsnoop:CARD=odroidaudio,DEV=0  - odroid-audio,  - Direct sample snooping device
      dsnoop:CARD=odroidaudio,DEV=1  - odroid-audio,  - Direct sample snooping device
      hw:CARD=odroidaudio,DEV=0      - odroid-audio,  - Direct hardware device without any conversions
      hw:CARD=odroidaudio,DEV=1      - odroid-audio,  - Direct hardware device without any conversions
      plughw:CARD=odroidaudio,DEV=0  - odroid-audio,  - Hardware device with all software conversions
      plughw:CARD=odroidaudio,DEV=1  - odroid-audio,  - Hardware device with all software conversions
      sysdefault:CARD=Device         - Generic USB Audio Device, USB Audio - Default Audio Device
      front:CARD=Device,DEV=0        - Generic USB Audio Device, USB Audio - Front speakers
      surround21:CARD=Device,DEV=0   - Generic USB Audio Device, USB Audio - 2.1 Surround output to Front and Subwoofer speakers
      surround40:CARD=Device,DEV=0   - Generic USB Audio Device, USB Audio - 4.0 Surround output to Front and Rear speakers
      surround41:CARD=Device,DEV=0   - Generic USB Audio Device, USB Audio - 4.1 Surround output to Front, Rear and Subwoofer speakers
      surround50:CARD=Device,DEV=0   - Generic USB Audio Device, USB Audio - 5.0 Surround output to Front, Center and Rear speakers
      surround51:CARD=Device,DEV=0   - Generic USB Audio Device, USB Audio - 5.1 Surround output to Front, Center, Rear and Subwoofer speakers
      surround71:CARD=Device,DEV=0   - Generic USB Audio Device, USB Audio - 7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
      iec958:CARD=Device,DEV=0       - Generic USB Audio Device, USB Audio - IEC958 (S/PDIF) Digital Audio Output
      dmix:CARD=Device,DEV=0         - Generic USB Audio Device, USB Audio - Direct sample mixing device
      dsnoop:CARD=Device,DEV=0       - Generic USB Audio Device, USB Audio - Direct sample snooping device
      hw:CARD=Device,DEV=0           - Generic USB Audio Device, USB Audio - Direct hardware device without any conversions
      plughw:CARD=Device,DEV=0       - Generic USB Audio Device, USB Audio - Hardware device with all software conversions
    
     
    
    #### SHAIRPORT VERSION ####
    2.2.5-openssl-Avahi-ALSA-soxr
     
    
    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: MMAP_INTERLEAVED
    format: S16_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 1024
    buffer_size: 8192
     
    
    #### OUTPUT SOUND DETAILS CARD 1 ####
    closed
    18. September 2015 at 23:59 #15741

    Wow I got it working!

    In the tab “AUDIPLAYER” under the “Status: Squeezelite is running with processID ####” Can press “Edit Advanced Options” and I picked from the long list “hw – Generic USB Audio Device, USB Audio – Direct hardware device without any conversions, CARD=Device,DEV=0”

    I guess no way to have it go out both the HDMI and this?

    But this is the nice way I can turn off the screen and still have it hear it now.

    Pic worth 10000 words

    • This reply was modified 1 year, 2 months ago by  Raymond Day.
    21. September 2015 at 13:44 #15751

    Hi Raymond,
    Great that you got the system to work! You can also run multiple instances of Squeezelite with our premium plugin “Multisqueeze”. There you can choose one input HDMI and one for your USB sound card.

    21. September 2015 at 16:22 #15758

    Tested sync for both players to play my Squeezebox Radio and the max2play-XU4. As soon as I clicked “Synchronize” it stop playing but the play list is on both now playing. They just both stopped.

    Got a Intel Compute Stick as a server running the Logitech Media Server. The 32GB one installed Ubuntu on it. Any way it did not “Synchronization” when I click to do that.

    Uploaded this to my Google Photos to show how I did it but did not work.

    Don’t have the “Multisqueeze” on it. I will see if I can install it and test again.

    Just looked it says this:

    “Multisqueeze – run multiple Squeezelite Player simultanous on one device (Raspberry / Odroid). Needs an audiodevice for each player.” I don’t need it to run 2 on one system. So did not install it.

    I see to run it both on the HDMI sound and the USB sound. I have no did that. But I guess that would be the way. Thank you.

    My try it later some time. I put my Odroid-XU4 out of the way now and take some time and work to move it to play it in the HDMI again.

    • This reply was modified 1 year, 2 months ago by  Raymond Day.
    • This reply was modified 1 year, 2 months ago by  Raymond Day.
    • This reply was modified 1 year, 2 months ago by  Raymond Day.
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here