[SOLVED] How to get Airplay working to remote squeezebox

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) [SOLVED] How to get Airplay working to remote squeezebox

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner Moderator 1 week, 2 days ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 9. September 2018 at 9:33 #37727

    Hello,

    I’m trying to get airplay working to a remote hardware squeezebox and seem to be failing.

    I’ve installed Max2Play on a raspberry PI, installed LMS nightly, Shairtunes 2 fork, enabled Shairtunes 2 fork. I have a squeezebox classic in another room that I can then play music to from the LMS music library.

    When I airplay from my iPad, I see max2play as an airplay device and the iPad can appear to play to it.
    The sound can get to the raspberry PI squeezelite player as I can then listen to the airplay music via headphone on the RPI.

    I don’t seem to however be able to send airplay sound to a Logitech squeezebox in another room as only the max2play squeezelite player shows up as an airplay device. Do you know what I should be doing to get the squeezebox to show up as an airplay device via LMS and your Shairtunes fork plugin?

    I’ve tried to synchronise the squeezebox classic with the squeezelite but this didn’t seem to work either.

    I feel this should be possible but for some reason I cannot make it work. I tried to go to the settings page in the Shairtunes fork plugin, but gave a page not found error. Is there a setting I need to set there – maybe I can do via ssh?

    Many thanks (in advance),

    Nick

    10. September 2018 at 11:51 #37738

    Hi Nick,

    Thanks for the request.

    Please make sure you have no other version of shairtunes in your LMS. Please also make sure you have installed the bugfix in the max2play interface menu „Squeezebox Server“ for shairtunes2.

    10. September 2018 at 21:23 #37764

    Hello Heiner,

    That worked a treat 🙂
    Airplay now works and I can get to the settings menu within LMS.

    Many thanks for your help!

    Cheers,

    Nick

    10. September 2018 at 21:50 #37765

    Ah maybe I spoke/wrote too soon…..

    I can do airplay to the squeezebox but every time I change a track I get this loud click/pop/crack noise through the speakers.

    Is this one of the settings (that I can now see) that I should be changing to prevent this?

    Cheers,

    Nick

    10. September 2018 at 22:09 #37766

    OK – solved this one myself. In my installation changing to flac from wav removed the click sound every time a track is changed.

    Cheers,

    nick

    11. September 2018 at 10:22 #37779

    Hi nick,

    Thanks for the quick update, glad to hear your setup is working properly now 🙂

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here