How do I change the dns setting?

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI How do I change the dns setting?

This topic contains 10 replies, has 3 voices, and was last updated by  masel 3 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 19. March 2016 at 21:39 #19370

    I want to change the dns in resolv.conf

    This is almost impossible in putty – I want to use the editor in WinSCP


    How do I get root access ????

    19. March 2016 at 21:56 #19371

    ssh in as pi
    sudo passwd root
    Enter whatever passwd u want
    Then wscp as root

    19. March 2016 at 22:00 #19372


    19. March 2016 at 22:06 #19373


    Doesn’t work.

    sudo passwd root allows successful change


    access is denied on login


    19. March 2016 at 22:38 #19374

    Something else going on
    Did it many times with no problems
    Did you try ssh in as root?
    Did you change anything else?

    19. March 2016 at 22:46 #19375

    No changes. Login as pi, sudo passwd root … changed successfully. Login as root … access denied

    Tried su with root password – changed password again – successful change. Login as root … access denied

    Must need a root login routine enabled.

    19. March 2016 at 23:01 #19376

    Hmmm ….

    To enable SSH login for a root user on Debian Linux system you need to first configure SSH server. Open /etc/ssh/sshd_config and change the following line:
    PermitRootLogin without-password
    PermitRootLogin yes

    Had a look at the file and it doesn’t contain any PermitRootLogin line ???

    19. March 2016 at 23:17 #19377

    Adding the line works.

    What a performance!

    19. March 2016 at 23:21 #19378

    Of Course but never had to
    By default is enabled on most of Linux flavours
    I usually had to do the other way around
    Disable root ssh in

    20. March 2016 at 3:01 #19379

    Apart from the above task …. changing the dns in Jessie requires the following:


    add the line

    name_servers=n.n.n.n (the actual dns nameserver address)

    to /etc/resolvconf.conf

    It should be a lot easier than this!

    • This reply was modified 7 months ago by  castalla.
    • This reply was modified 7 months ago by  castalla.
Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here