Homematic-Plugin: Anmeldung an FritzBox geht seit FritzOS 7.20 nicht mehr

Max2Play Home 2016 (en) Forums Max2Play Add-ons Homematic-Plugin: Anmeldung an FritzBox geht seit FritzOS 7.20 nicht mehr

This topic contains 6 replies, has 2 voices, and was last updated by  MarioM Moderator 1 week, 2 days ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 1. November 2020 at 13:19 #49976

    Hallo M2P-Team,

    ich nutzte die Anwesenheitsüberwachung mit dem Homematic-Plugin mittels FritzBox und Homematic Variablen erfolgreich bis FritzOS 7.0 und nach eurer erneuten Anpassung auch mit 7.1. wieder.
    Seit dem Update meiner FritzBox 7590 auf das aktuelle FritzOS 7.20 werden meine Geräte als abgemeldet vom M2P-Homematic-Plugin erkannt und entsprechend die Homematic-Variablen gesetzt.
    Das Problem besteht sowohl in der aktuellen M2P-Version 2.52 als auch bei der letzten M2P-Beta-Version.

    Im M2P „DEBUG Info“ Fenster bekomme ich z.T. „Fritzbox Anmeldungsfehler“, obwohl das Kennwort korrekt ist und unter „Anmeldung im Heimnetz“ „Anmeldung mit FRITZ!Box-Benutzernamen und Kennwort“ aktiviert ist.
    Beim Umstieg auf FritzOS 7.1 gab es ein ähnliches Problem, bei dem ihr ein FritzOS 7.1 Dataaccess realisiert habt, damit es wieder fiunktioniert und jetzt hat AVM wohl schon wieder etwas geändert.

    Es scheint so, als ob ein neuer „FritzOS 7.2 Dataaccess“ gebaut werden müsste, damit das wieder funktioniert..

    Es wäre toll, wenn Ihr Euch das mal anschauen könntet…

    Danke und viele Grüße

    3. November 2020 at 14:17 #49999

    Hallo holson,

    ich hatte diesen Hinweis bereits an unseren Entwickler weitergegeben. Allerdings ist er leider noch nicht dazu gekommen, sich der Sache anzunehmen. Ich werde ihn nochmal darauf hinweisen und dir hier schreiben, sobald ich etwas neues weiß.

    4. November 2020 at 15:23 #50020

    Hallo holson,

    die Anwesenheitsüberwachung sollte eigentlich mit dem FritzOS 7.2 funktionieren. Unser Entwickler hat es hier vor Ort getestet und konnte keine Probleme oder Änderungen feststellen. Schick uns am besten deine Debug Log. Dort sollte etwas von „sid“ und „challenge“ stehen. Wenn die Anmeldung nicht funktioniert, liegt das ggf. an einer Einstellung deiner FritzBox.

    7. November 2020 at 14:32 #50078

    Hallo Mario,

    Danke für Dein Feedback. Ich habe heute auf FritzOS 7.21 upgedatet und immer noch das gleiche Problem, welches ich seit FritzOS 7.20 habe.
    Anbei mein Versucht, den Fehler zu analysieren und einzugrenzen:
    – ich habe alle Repeater ausgeschaltet, so dass nur meine FritzBox 7590 läuft
    – es gibt nur ein WLAN-Gerät mit dem Namen HolgeriPhone11 und das ist in der FritzBox als verbunden dargestellt
    – ich habe das Kennwort in der FritzBox erneut aus dem Homeatic-Pugin gespeichert
    – Homeatic-Pugin FritzBox-Loop-Time aug 15 Sekunden gestellt

    Hier meine Analyse:
    Wenn ich M2P neu starte, so logt sich das Homeatic-Pugin erfolgreich in die FritzBox ein.
    Es zeigt aber alle Geräte als abgemeldet an, obwohl diese in der FritzBox als verbunden dargestellt werden
    Selbts wenn ich auf meinem iPhone das WLAN trenne und nach 30 Sekunden wieder verbinde, zeigt sich im Homeatic-Pugin keine Status-Änderung
    Nach einer gewissen Zeit kommt dann immer ein Fritzbox Anmeldungsfehler und erst nach einem M2P-Reboot ist die Anmeldung an die FritzBox wieder erfolgreich:

    Anbei das Lofile:
    #### LOGFILE ####
    try FritzOS 7.0 Dataaccess
    try FritzOS 7.1 Dataaccess
    Challenge: |
    SID: | http://192.168.8.1/login_sid.lua?username=max2playeg&response=-a0abe57d520735185f50d35fa4970270
    Fritzbox Anmeldungsfehler
    try FritzOS 7.0 Dataaccess
    try FritzOS 7.1 Dataaccess
    Challenge: 31fe8fb7 |
    SID: a80e5474ac3dec37 | http://192.168.8.1/login_sid.lua?username=max2playeg&response=31fe8fb7-672911a20fc7d3363aae088f42aa8a0e
    try FritzOS 7.0 Dataaccess
    try FritzOS 7.1 Dataaccess
    Challenge: |
    SID: 0000000000000000 | http://192.168.8.1/login_sid.lua?username=max2playeg&response=-a0abe57d520735185f50d35fa4970270
    Fritzbox Anmeldungsfehler
    try FritzOS 7.0 Dataaccess
    try FritzOS 7.1 Dataaccess
    Challenge: e653ed7a |
    SID: 88377cdeeecea46d | http://192.168.8.1/login_sid.lua?username=max2playeg&response=e653ed7a-67c17a706a0ef6dde017d5d10bd0e5c8
    try FritzOS 7.0 Dataaccess
    try FritzOS 7.1 Dataaccess
    Challenge: 80d16dfe |
    SID: fd096e9537242220 | http://192.168.8.1/login_sid.lua?username=max2playeg&response=80d16dfe-3e754c880cd787176f35e2d20d33e94d
    try FritzOS 7.0 Dataaccess
    try FritzOS 7.1 Dataaccess
    Sa 7. Nov 13:14:53 CET 2020 HolgeriPhone11, abgemeldet
    URL http://192.168.8.4/config/xmlapi/statechange.cgi?ise_id=6504&new_value=false
    Sa 7. Nov 13:14:53 CET 2020 Johannas-iPhoneX, abgemeldet
    URL http://192.168.8.4/config/xmlapi/statechange.cgi?ise_id=6787&new_value=false
    Sa 7. Nov 13:14:53 CET 2020 Bens-iPhone, abgemeldet
    URL http://192.168.8.4/config/xmlapi/statechange.cgi?ise_id=44521&new_value=false
    Challenge: 77068343 |
    SID: 6bf8fe2cbbbd47a1 | http://192.168.8.1/login_sid.lua?username=max2playeg&response=77068343-78a1efeb7a1b52159b76a51f2402b08d
    try FritzOS 7.0 Dataaccess
    try FritzOS 7.1 Dataaccess
    Challenge: |
    SID: 0000000000000000 | http://192.168.8.1/login_sid.lua?username=max2playeg&response=-a0abe57d520735185f50d35fa4970270
    Fritzbox Anmeldungsfehler
    try FritzOS 7.0 Dataaccess
    try FritzOS 7.1 Dataaccess
    Challenge: 04c3ba55 |
    SID: 9ec9a19e1c560aa4 | http://192.168.8.1/login_sid.lua?username=max2playeg&response=04c3ba55-f827a90afbbc54b8c429bd5c68f1aa87
    try FritzOS 7.0 Dataaccess
    try FritzOS 7.1 Dataaccess
    Challenge: |
    SID: 0000000000000000 | http://192.168.8.1/login_sid.lua?username=max2playeg&response=-a0abe57d520735185f50d35fa4970270
    Fritzbox Anmeldungsfehler
    try FritzOS 7.0 Dataaccess
    try FritzOS 7.1 Dataaccess
    Challenge: 1d0a389f |

    Habt Ihr eine Idee bzw. könnt Ihr euch das bitte nochmal anschauen?

    Danke und viele Grüße

    10. November 2020 at 17:55 #50110

    Hallo holson,

    Danke für das Logfile. Es scheint so, als ob etwas mit dem Login auf der FritzBox nicht funktioniert. Bitte setze die Looptime mal auf einen Wert größer als 60 Sekunden. Kleinere Werte machen da nicht wirklich Sinn, da es etwas dauert, bis die WLAN-Geräte in der FritzBox als nicht mehr aktiv angezeigt werden. Wahrscheinlich blockiert die FritzBox deswegen den Zugang. Warte beim Testen (z.B. Handy WLAN ausschalten) am besten 5 Minuten und schau dann, ob es funktioniert.

    16. November 2020 at 0:13 #50226

    Hallo Mario,

    Danke für Dein erneutes Feedback!
    Ich hatte im Homeatic-Pugin die FritzBox-Loop-Time nur zu Testzwecken auf 15 Sekunden gestellt; im Normalbetrieb war das bei mir immer auf 60 Sekunden eingestellt und damit hat es früher funktionniert.
    Ich habe jetzt die Zeit auf 120 Sekunden eingestellt
    Der „Fritzbox Anmeldungsfehler“ kommt damit nicht mehr!
    Aber dennoch wird der WLAN-Status nicht korrekt im Homeatic-Pugin angezeigt bzw. als „abgemeldet“; leider bei allen drei Geräten, die ich bisher verwendet habe habe.
    Auch über mehrere Tage hinweg und obwohl ich mein Haus/WLAN mehrfach verlassen habe, wird der Status der Geräte nur als abgemeldet dargestellt.
    Ich habe sicherheitshalber nochmal verifiziert, dass die Geräte in der FritzBox analog zu dem Namen im Homeatic-Pugin lauten.

    Könnt Ihr euch das bitte nochmal anschauen?

    Danke und viele Grüße

    17. November 2020 at 16:52 #50262

    Hallo holson,

    wir werden das Ganze nochmal bei uns testen und geben dir Bescheid, wenn wir eine Lösung gefunden haben. Ich bitte aber um dein Verständnis, falls sich das noch etwas verzögert, da wir aktuell größtenteils im Home-Office arbeiten.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here