Homematic anwesenheit.. geht nicht..

Max2Play Home 2016 (en) Forums Max2Play Add-ons Homematic anwesenheit.. geht nicht..

This topic contains 12 replies, has 6 voices, and was last updated by  flysurfer Moderator 1 year, 9 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • 17. August 2015 at 12:11 #15383

    Ich habe seid ein paar tagen Max2Play mit Lizenz am laufen

    Das ich es nicht schon früher gemacht habe… Airplay zu Squeezeboxe läuft echt super danach habe ich ewig gesucht..
    Einrichtung war auch total einfach…

    Was ich nicht hinbekomme ist die Homematic geschichte…
    das ich über das Homematic Setup anwesenheiten abfragen kann…
    Einstellungen:
    Fritzbox IP : 192.xxx.xxx.xxx
    Fritzbox benutzer : frei
    Fritzbox passwort : das PW von der Fritzbox Oberfläche
    Fritzbox Gerät : Den Gerätenamen der mir in der Fritzbox Oberfläche unter Netzwerk angezeigt wird… in meinem fall **gbquad** (als Test)
    Homematic Variables (ise_id) : Auf der CCU1 ist XML-API installiert.. habe dazu eine Systenvariable erstellt… Variablentyp : Logikwert
    Dann unter dieser Adresse http://Homematic/addons/xmlapi/sysvarlist.cgi die ised_id der Systemvariable gesucht und eingetragen
    FritzBox Looptime : auf 120
    Homematic IP : xxx.xxx.xxx.xxx

    Doch bekomme ich immer abwesend angezeigt im Homematic webinterface.

    Ist es möglich CCU.io zu installieren? und/oder Hyperion um Ambilight darüber laufen zu lassen…?
    So hätte man/ich ein all in one Gerät.. das wäre gar nicht in Worte zu fassen

    Ich freue mich auf Antworten

    17. August 2015 at 17:16 #15388

    Hi schmello,
    Um die Funktion des Homematic Plugins zu testen, kannst du mal auf „Debug Infos“ (im Max2Play Webinterface) klicken und die Homematic-URL die angezeigt wird, manuell (im Browser) aufrufen. Außerdem benötigst du eine relativ neue Fritzbox-Version ab 6.10, damit der Abruf der aktiven Geräte in der Fritzbox funktioniert. Falls es nicht so recht will, kannst du mal den Inhalt der Debug Infos posten.

    20. August 2015 at 9:50 #15434

    Ich habe eine Fritzbox 7490 mit 6.30

    Nach einem neustart der Fritzbox scheint es zu klappen 🙂
    Aber nur dann wenn ich in den Max2Play Settings den Benutzername frei lasse und nur das Passwort von der Fritzbox Oberfläche eintrage..
    Wenn ich einen Benutzer anlege in der Fritzbox mit z.b. Name Test PW Test dann loggt max2play sich nicht ein und in der Fritzbox steht..
    IP blabla falsches Kennwort…

    Ist es denn möglich CCU.io zu installieren? das wäre wirklich genial.. so könnte ich mir einen PI sparen…
    zusätzlich wäre natürlich Hyperion für mein Ambilight der hit 😀
    Aber wenn CCU.io laufen würde reicht das erstmal…

    Achja 😀 da ja jetzt die Anwesenheit funktioniert… ist es auch möglich diese zu loggen und in einem Diagramm darzustellen?
    So könnte man sehen wann wer zu welcher zeit anwesend war… und nachsehen ob die Anwesenheit auch richtig funlktioniert…

    17. September 2015 at 11:48 #15722

    Super, dass es jetzt läuft!

    Es wichtig in den FritzBox Benutzereinstellungen den Punkt „Anmeldung bei Zugriff aus dem Heimnetz“ auf die entsprechende Option zu setzen, die man nutzen möchte. Hier sollte „Anmeldung mit FRITZ!Box-Benutzernamen und Kennwort“ gewählt werden, wenn das Login mit Benutzername und Passwort erfolgen soll. Alternativ (bei Login nur mit Passwort) den Punkt „Anmeldung mit dem FRITZ!Box-Kennwort“ nutzen und im Max2Play Addon den Benutzernamen frei lassen.

    9. Oktober 2017 at 22:20 #31833

    Hallo,
    ich habe es auch versucht.
    Bei mir wird die Variable immer auf „nicht Anwesend“ gestellt.
    Einstellungen:
    Fitzbox 7490 Version 6.9
    Fritzbox IP : fitz.box und 192.xxx.xxx.xxx
    Fritzbox benutzer : frei und Bunutzer eingerichtet
    Fritzbox passwort : das PW von der Fritzbox Oberfläche und ganz weg gelassen
    Fritzbox Gerät : Den Gerätenamen, ip und MAC
    FritzBox Looptime : 10
    Homematic IP : xxx.xxx.xxx.xxx

    Ich habe also schon ein paar Varianten probiert. Auch diverse Neustarts von RPI und Fritzbox halfen nicht.
    Der aufruf über den HTML befehlt funktuiert ohne probleme. Ich denke es liegt an der Komuninkation mit der firtzbox.
    Hier die DEBUG INFO:
    Mon Oct 9 20:38:18 CEST 2017 iPhone, abgemeldet
    URL http://192.xxx.xx.xx/config/xmlapi/statechange.cgi?ise_id=xxxxx&new_value=false

    Über hilfe wre ich erfreut.
    Gruß

    11. Oktober 2017 at 16:43 #31867

    Hallo Batman,

    das klingt nach einem Fehler in der Anmeldung zur Fritzbox. Kannst du noch mal schauen, ob du die Benutzeranmeldung mit Passwort und Benutzername oder nur die Anmeldung mit Passwort in der Fritzbox aktiviert hast.
    WICHTIG: selbst wenn Benutzer angelegt sind steht ggf. auf der Benutzerübersicht ggf. in der FritzBox „Momentan ist die Anmeldung bei Zugriff aus dem Heimnetz deaktiviert. Die angezeigten Benutzer gelten nur für den Zugriff aus dem Internet.“. In diesem Fall ist nur die Anmeldung auch NUR über das Passwort (ohne Benutzername) möglich!

    Um diesem Fehler genauer einzugrenzen habe ich einen „Debug“ Modus in der aktuellen Beta eingebaut (unter Einstellungen -> Beta-Update Max2Play). Dann ist in dem Homematic-Plugin der Punkt „Debug-Modus aktivieren“ vorhanden. Nach einem Neustart erscheinen nun genauere Meldungen im Debug Fenster zum Login an der Fritzbox. Wenn die SID auf 00000000000 steht ist das Login schief gegangen und es liegt an dem oben beschriebenen Fehler.

    Noch eine Kleinigkeit: Die Looptime würde ich als Empfehlung eher auf 60 Sekunden stehen. Das sollte für die Genauigkeit genügen.

    Viele Grüße!

    27. Juli 2018 at 15:53 #36770

    Hallo,

    Funktioniert bei mir nicht!
    habe das System wie oben beschrieben aufgesetzt.

    M2P auf Raspberry PI 3 loggt sich auch in die Fritzbox ein, die Variable wird richtig gesetzt. Dann dauert es ca. 7 min., dann ist mein Handy wieder auf abwesend.
    In der Fritzbox müsste alles richtig eingestellt sein, eingeloggt wird nur mit Kennwort.

    Nach einem Tag und einigem rumprobieren habe ich die Fritzbox upgdatet, jetzt FRITZ!OS: 07.00
    Nun ändert sich die Variable gar nicht mehr. Mehrere Neustarts aller Komponenten bringen auch nichts.

    Mein Handy ist ein Samsung Galaxy A3 – 2017 Android 8.0.0
    Fritzbox 7590, FRITZ!OS: 07.00

    In den Fritzbox-Einstellungen bei „Ereignissen“ kann ich erkennen, dass sich M2P korrekt mit seiner IP einloggt.
    Im logfile des Debug-Modus M2P kann ich auch nichts außergewöhnliches erkennen:

    SID: c90cc1512738093f | http://xxx.xxx.xx.x/login_sid.lua?username=&response=f0e85c34-0cbfba508d70c5d1d9c6b4192c68f63b
    Fri 27 Jul 15:32:45 CEST 2018 Handy-Thorsten-Galaxy-A3-2017, abgemeldet
    URL http://xxx.xxx.xx.x/config/xmlapi/statechange.cgi?ise_id=54380&new_value=false

    Ich vermute, dass es an der neuen Fritzbox bzw. dem neuen OS liegt, oder Android hat mal wieder mit seinem Handy-Tiefschlaf übertrieben.

    30. Juli 2018 at 16:13 #36787

    Hallo thoto,

    Danke für die ausführliche Beschreibung.

    Kannst du gegebenenfalls ein anderes Handy ausprobieren, um dies als Fehlerquelle ausschließen zu können?

    31. Juli 2018 at 13:08 #36800

    Hallo thoto,

    wir haben jetzt mit der FritzOS 7.0 getestet und wie du schon vermutet hast, liegt es an der neuen Firmware der Fritzbox. Die Abfrage der Geräteliste hat sich etwas geändert.

    Wir werden diese Woche noch einen Patch für die Betaversion des Plugins bringen, der das Problem löst. Du solltest also am Wochenende ein Beta-Update durchführen können und anschließend Max2Play neustarten.

    Viele Grüße
    Stefan

    8. Dezember 2018 at 22:14 #42617

    Hallo Flysurfer,

    meine Fritzbox ist jetzt ebenfalls auf 7.01 upgedated worden – und seither geht das Anwesenheits-Plugin nicht mehr 🙁
    Bisher problemlos gewesen und sehr zuverlässig – seit 7.01 kommt beim Debug folgende Meldung:

    Challenge: 8b9f9b2a |
    SID: ce59e4aadf91133a | http://172.20.20.1/login_sid.lua?username=admin&response=8b9f9b2a-1962bc1e1d65ff3c9bcfe2b51cd0fa15
    try FritzOS 7.0 Dataaccess

    Mein Stretch Image ist von Oktober – und auch der Kernel ist upgedated…

    Gibt es schon Lösungen oder Workarounds?

    Danke und Gruß
    Andreas

    10. Dezember 2018 at 11:10 #42627

    Hallo Andreas,

    ich habe bei mir ebenfalls FritzOS 7.01 am laufen und es sollte in der aktuellen Version damit keine Probleme geben. Das Logfile von dir schaut auch gut aus. Zumindest am Login an der Fritzbox scheitert es nicht. Der Punkt „try FritzOS 7.0 Dataaccess“ zeigt auch, dass du die aktuelle Version installiert hast. Ich vermute den Fehler daher eher in der Übertragung zu Homematic.

    Folgendes kannst du versuchen:
    – deaktiviere den Debug Modus in den Einstellungen im Homematic-Plugin
    – jetzt sollte bei Zustandsänderungen eine Aktion protokolliert werden in der Form:

    Mo 10. Dez 10:04:02 CET 2018 Galaxy-S9, angemeldet
    URL http://homematic.fritz.box/config/xmlapi/statechange.cgi?ise_id=6229&new_value=true

    – diese URL zur Homematic Variablenänderung am besten mal im Browser ausführen und schauen was passiert

    Viele Grüße
    Stefan

    10. Dezember 2018 at 21:45 #42640

    Hallo Stefan,

    habe den Link mal direkt über den Browser getestet: das Setzen der Variablen funktionier auf der CCU2.
    Allerdings weiterhin nicht über das Feature in M2P 🙁

    Die ID’s der Variablen und die IP Nummern sind ebenfalls nochmals geprüft, das passt alles…
    Sieht für mich so aus, als würde von der FritzBox keine Antwort zurückkommen?

    Antwort im Debug (habe auch mit einem neuen FB User getestet), gleiche Antwort:
    Challenge: 515372a6 |
    SID: 371430a69ac992d1 | http://172.20.20.1/login_sid.lua?username=homematic&response=515372a6-c733f2c16d2a302da68af19cab0bb7c7
    try FritzOS 7.0 Dataaccess

    Gibt es vielleicht noch einen neuen Parameter im FritzOS 7.01, der aktiviert werden muss?

    Gruß
    Andreas

    11. Dezember 2018 at 17:11 #42691

    Hallo Andreas,

    kannst du bitte mal den Debug Modus deaktivieren, also den Haken im Webinterface in den Einstellungen vom Homematic Plugin entfernen. Dadurch schaut die Meldung im Debug Fenster dann etwas anders aus (siehe das Beispiel was ich mitgeschickt habe). Hier siehst du dann was das Script erkannt hat (An-/Abmeldung).

    Was mir noch einfällt: ggf. Sonderzeichen im Gerätenamen?

    Ansonsten sieht die detaillierte Debug-Ausgabe bei dir genau richtig aus. Es gibt auch für die FritzOS 7.01 keine Änderungen die nötig wären, um den Status eines Netzwerkgerätes abzurufen. Nur für die 7.0 im Vergleich zu 6.X war ein Update nötig.

    Viele Grüße
    Stefan

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Register here