Higher bitrate songs freezing LMS

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Higher bitrate songs freezing LMS

This topic contains 13 replies, has 6 voices, and was last updated by  nickle101 2 months, 1 week ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • 14. November 2016 at 22:15 #23910

    Hi again, title says it all, I am using an rpi3/hifiberry digi+ pro with Logitech media server running Spotify, and having a 1TB usb hard drive attached directly to the rpi3. Everything works fine until I try to play a 24 Bit depth (88,96,192)file from the HD, wav or flac. The file will play for about 45 secs to a minute, then it freezes, and I have to power down/power back up the Rpi3 before I can get it to respond again. I have tried every soundcard setting under the advanced tab for squeezelite in the audioplayer section, all options freeze up when I play a 24 bit file. I have battery power and a 5v/2.5a power supply, still does it regardless of power source. The digi+ pro uses a different driver than the digi+ I am wondering if there is a driver issue with the digi+ pro?

    17. November 2016 at 6:41 #23933

    Never could figure this one out, since the digi+ pro has two separate oscillators, maybe a driver issue? I set up a mountpoint and hooked my HD up to my pc, SMS picks up everything ok over the network, but still cant do high bitrate over Ethernet either. It does not freeze the system completely, but it glitches out and distorts on 24 bit material. any suggestions?

    29. November 2016 at 12:52 #24307

    Hi jnile1,
    Your issue might be due to insufficient power supply. Please try using a USB-HUB for the hard drive, deactivate the built-in audio of the Pi, deactivate Bluetooth (both Raspberry Settings) and set the hw parameter for your sound card: https://www.max2play.com/en/wiki/optimizing-squeezelites-volume-control/

    1. December 2016 at 3:05 #24426

    Tried adding the command line input, no change in performance other than fixing the volume value to where I can only adjust volume via the volume control of the preamp. 24 bit audio still glitches out, wether over the network or directly plugged into the rpi. As for mixer parameters via putty, I believe something is different in digi+ pro. Typing amixer in putty gets this response:
    Simple mixer control ‘tx source’,0
    Capabilities: enum
    Items: ‘s/pidf rx’ ‘aif’
    Item0 ‘aif’

    19. December 2016 at 12:05 #24984

    Dear jnile1,

    Have you already deactivated Bluetooth, as Heiner had mentioned? According to HiFiBerry, this could also be a source of error.

    Best Regards
    Christoph

    19. December 2016 at 13:37 #24989

    Yes, only thing I can think of to change, if possible, is disabling all output save the spidf output. Is this possible?

    21. December 2016 at 18:19 #25123

    Hello jnile1,

    We tested it again and found no problems.

    Have you connected other devices to the Raspberry Pi? Via USB? The power supply may be insufficient.

    Please also look if the kernel is the latest. Under Settings/Reboot you can find this information in the lower part in the DEBUG information. There should be at least version 4.4.19 or higher.

    22. December 2016 at 19:15 #25176

    Hi

    I have just discovered a similar problem. When I try to play a FLAC file (24/96) it crashes the whole Pi requiring a hard restart to get it working again. I also have a Hifiberry dac+pro. A 16/44 file plays with no problem. In the past I have been able to play the 24/96 files, but I have made many updates since I first played them and only stumbled on this problem yesterday.

    Any thoughts?

    Kind regards
    N

    27. December 2016 at 20:59 #25275

    Hello,

    I also have the very same problem and have a HifiBerry DAC+ Pro as well. I have the latest Kernel installed and a 2.5A power supply with only a 7 inch display connected.

    Best regards,

    Marc

    28. December 2016 at 1:09 #25280

    For those looking to disable the bluetooth and the built in audio here is a small guide

    Disabling rpi3 bluetooth

    Here is a link that walks you through disabling rpi3 bluetooth.

    Note: you will either need to use the mouse and keyboard or connect to it remotely with SSH:

    http://raspberrypi.stackexchange.com/a/53369

    Disabling in built in audio using raspi-config

    Built in audio can be disabled using ‘raspi-config’.

    You will need to install it as root or using sudo: (it might already be installed)

    # sudo apt-get install raspi-config

    Walk through the menus and it should have an option for this.

    Disabling built in audio card using command line

    Here is a link

    http://www.instructables.com/id/Disable-the-Built-in-Sound-Card-of-Raspberry-Pi/step2/Configure-Linux-to-NOT-load-Broadcoms-sound-chip/

    It’s pretty straight forward.

    28. December 2016 at 23:48 #25316

    The lockup issue with Squeezelite and an RPI3/HifiBerry DAC+ Pro while playing high bit rate FLAC files appears to be solved for me by simply switching from WiFi to wired Ethernet. I have a Cisco 802.11n WiFi router which should have more than enough bandwidth.

    Any ideas?

    Marc

    5. January 2017 at 16:54 #25573

    Hi Marc, Bernard, jnile and nickle,

    Bernard: Thanks for the quick guide! However, you will find these options in our web interface as well. They are both boxes that can be checked in the Raspberry Settings to deactivate them, respectively.

    Marc, et all: The WiFi connection might not be as stable explaining your issues, depending on the router’s and the Pi’s location.

    6. January 2017 at 6:56 #25592

    Tried every suggestion in this thread so far, still same problem. Tried using a powered usb hub for the external drive, both hard wired to the pi and over Ethernet, same issue both ways, also I used a larger, faster powered external hard drive that I copied all the files onto, same issues as with the other drive, hard wired or over wireless, same issue… Power supply is the ifi ipower 5v 2.5a (2x, one for the pi, one for the usb hub, non back powering) Using the latest beta of max2play and all updates. Maybe it’s my dac? Using a schiit gungnir multibit, there is a relay that flips when switching between bitrates.., but I’m grasping at straws now. Everything works flawlessly and sounds great, except I can’t seem to make 24 bit audio work… I tried all outputs, toslink, spidf, bnc, no difference there. I must be missing something, it can’t be this hard. Can anyone share their setup method if they have gotten it to work? I have a wifi repeater on order, but I don’t have high hopes.

    19. January 2017 at 9:01 #26113

    Since I have solved my wifi instability problems, as described here:

    https://www.max2play.com/en/forums/topic/getting-stable-wifi-with-hifiberry-dac-pro-on-pi3/

    I can now play 24 bit flac files on my hifiberry dac+pro setup. It seems that the dac+pro causes specific interference with the built in wifi which greatly reduces the bandwidth and stability. This interference is only evident at specific frequencies corresponding to specific wifi channels. By fixing my wifi router to broadcast on channel 4, the interference is no longer an issue and the setup now works for 24bit files. I don’t know if channel 4 is a general recommendation, but it works for me.

    kind regards
    Mick

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.

Register here