HifiBerry Digi+ not working

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI HifiBerry Digi+ not working

This topic contains 4 replies, has 2 voices, and was last updated by  Spaetzle 1 week, 4 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 5. October 2016 at 17:41 #23283

    I bought a Raspberry 3 with a HifiBerry Digi+ and a license for Max2Play some days ago.
    I am trying to set it up as “Starter: A simple audioplayer for internet radio and local music (mp3)” with no luck.
    I Expanded the filesystem in a first step, then activated my license and set up the System with the “Starter” option.
    After that I included an NFS share with some music and configured mpd to use it. Worked well as YMPD and an MPD Client show a filled database.
    When I am trying to play some songs nothing works. I can see the following in /var/log/mpd/mpd.log

    Oct 05 16:54 : client: [10] opened from
    Oct 05 17:05 : alsa_output: Failed to open "Max2Play ALSA Device" [alsa]: Error opening ALSA device "default:CARD=sndrpihifiberry" (snd_pcm_hw_params): Invalid argument
    Oct 05 17:05 : output: Failed to open audio output

    Any ideas what is wrong here. I tried to set up the HifiBerry with the free plugin and with the “Raspberry Settings” plugin.

    This is quite frustrating as I bought this bundle in the hope to have an easy to set up package with Max2Play …

    11. October 2016 at 9:28 #23366

    Hello Spaetzle,

    Thanks for your request. Did you reboot the system after choose the HiFiBerry Digi+ in the HiFiBerry plugin menu?

    Best Regards

    11. October 2016 at 11:48 #23373

    Yes I did reboot the Raspi.

    As I tryed out many things I started again today:

      Downloaded m2p_rpi3_hifiberry_235_wps.img.zip, unpacked and put it on the SD Card
      started the PI
      Settings / Reboot – Expand Filesystem
      Settings / Reboot: Entered License Code, Changed Language to german

    Remark: Everything is in english althougt the interface shows that german is selected.

      Menu “HifiBerry” – Selected Digi/Digi+.
      Selected: “Starter: A simple audioplayer for internet radio and local music (mp3)” – Select this setup
      mounted a nfs share with music and changed set up of mpd to the mounted folder

    Now I opend a ssh connection to the PI and looked into /var/log/mpd/mpd.log. After stoping and restarting mpd with the webinterface I get the following output:

    Oct 11 11:44 : client: [0] closed
    Oct 11 11:44 : zeroconf: No global port, disabling zeroconf
    Oct 11 11:44 : client: [0] opened from
    Oct 11 11:44 : alsa_mixer: Failed to read mixer for 'Max2Play ALSA Device': no such mixer control: Digital

    aplay -l shows:

    **** Liste der Hardware-Geräte (PLAYBACK) ****
    Karte 0: ALSA [bcm2835 ALSA], Gerät 0: bcm2835 ALSA [bcm2835 ALSA]
      Sub-Geräte: 8/8
      Sub-Gerät #0: subdevice #0
      Sub-Gerät #1: subdevice #1
      Sub-Gerät #2: subdevice #2
      Sub-Gerät #3: subdevice #3
      Sub-Gerät #4: subdevice #4
      Sub-Gerät #5: subdevice #5
      Sub-Gerät #6: subdevice #6
      Sub-Gerät #7: subdevice #7
    Karte 0: ALSA [bcm2835 ALSA], Gerät 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0
    Karte 1: sndrpihifiberry [snd_rpi_hifiberry_digi], Gerät 0: HifiBerry Digi HiFi wm8804-spdif-0 []
      Sub-Geräte: 1/1
      Sub-Gerät #0: subdevice #0

    The settings for MPD “Music Player Soundcard Settings” in the Webinterface are:
    Sound device: equal – equal
    Audio Format: 192000:24:2
    Mixer Device: hw:1
    Mixer Controler: Digital

    Any ideas what’s going wrong here?


    12. October 2016 at 11:50 #23386

    Hello Spaetzle,

    please try this. Go to the HiFiBerry menu. I think there is, at this time, the Hifiberry Digi/Digi+ the chosen sound card? Change it into none and save this configuration. After this, change it again into Hifiberry Digi/Digi+.

    We have test it and this solves the problem for the moment. We are working on this.

    Best Regards

    12. October 2016 at 16:53 #23404

    Hi Christoph
    OK. It is doing a little more. I can not see an more errors. But there is no sound.
    Is there a trick if I want to use the optical output. The PI is connected to the sound system with the optical output as I have no coax input at the sound system …
    And as it seems I can not use the volume control of mpd. The controller with the client software I am using (gmpc) is unavailable.

    • This reply was modified 1 week, 4 days ago by  Spaetzle.
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here