Hifiberry Digi+ No Sound on Pi3

This topic contains 10 replies, has 3 voices, and was last updated by  Heiner Moderator 6 months, 1 week ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • 22. January 2017 at 1:25 #26182

    I’ve completed full M2P setup including touchscreen, RP3 and LMS 7.9. Everything working fine except the Hifiberry Digi+ card. Neither coaxial nor tosslink are delivering digital signal.
    I’ve checked card is activated in both in the RP3 Settings Tab as well as in the Squeezelite options.
    Everything working fine using the RP headphone output in Squeezelite (but poor sound quality).
    I’ve tried disabling bluetooth and RP internal audio as suggested somewhere.
    I would prefer sticking to digital output.

    Help appreciated!

    22. January 2017 at 10:52 #26187

    Hi javier

    you have selected the soundcard “sysdefault hifiberry…..”, NOT “default hifiberry…….”?

    22. January 2017 at 10:55 #26188

    Yes. Well, in fact I’ve tried them all…
    I get the tosklink on with the red light and communication with the DAC amplifier (it recognizes the sampling rate). But no sound. Green led on the Digi+ is also on. I’ve got the transformer version.

    22. January 2017 at 11:40 #26189

    you have chosen the right input at your Amp?
    I had a stupid mistake at my setup. I´d created an Action for my Logitech Harmony Universal-Remote. Starting the Action set “Mute” at the AV-Receiver. I didn’t know why.
    But first I didn’t recognized it and searched the fault im M2P
    Check your whole setup

    22. January 2017 at 11:47 #26190

    Thanks. I’m affraid I’ve gone all through that too. I’ve tried my pretty old Technics digital amp in two different digital entries (optical and coaxial) as well as my Yamaha AV receiver. I connect the Yamaha to other devices using the toslink so as easy as taking the end of the optical cable while its sounding and plugin it to the M2P.
    I’m afraid nothing is coming out of the Digi+… More than 8 hours already fiddling trying to make it work.

    22. January 2017 at 11:53 #26191

    that is annoying 🙁
    It’s possible that the soudcard is busted. You’d tried the HDMI-Output?

    22. January 2017 at 13:18 #26193

    I can’t make it work. Neither in my Yamaha Receiver nor directly to the HDMI input of my TV. Tried a number of Squeezelite Audio outputs.

    22. January 2017 at 13:34 #26194

    Maybe something related with Squeezelite setup? It seems only the headphones or the hedphoneplug AudioOutputs seem to work?

    22. January 2017 at 13:49 #26195

    BTW:I also updated the Kernels… Could it have to do with that? Some incompatibility with new versions…

    29. January 2017 at 20:28 #26391

    Help would be appreciated!

    16. February 2017 at 18:14 #26993

    Hi javier,
    Sorry about the late response. Please first try the option “force HDMI” in the Raspberry Settings to make sure that your digital works in general with Squeezelite.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here