[SOLVED] Hifiberry DAC+ (Standard RCA) on RPI3 : No sound

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Hifiberry DAC+ (Standard RCA) on RPI3 : No sound

This topic contains 6 replies, has 3 voices, and was last updated by  UpAtMax2Play 1 year ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 17. August 2017 at 19:22 #30684

    Hi all,
    I’m just trying to setup my new RPI with Hifiberry DAC+ (Standard RCA).
    Everything seems to be as it is documented but: There is no signal on the RCA Output :-(.

    Hardware:Raspberry Pi 3 Model B
    Hifiberry DAC+ (Standard RCA)
    Max2Play Version 2.44 (Premium)

    I did the setup like documented, No Error Messages , but no sound on the RCA Outputs:

    I use Squeezelite with Squeezeserver 7.9
    But I have the same problem when I play wav-files with aplay:

    I have no glue whether this is a configproblem (in most cases the problem sits in front the screen :-), driver issue, hardware issue (the green light on the hifiberry card is shining brightly…), but you never know .

    Has someone an indication what might be the problem? and possible solutions? Hints to debug further?

    Some Systemfiles:

    1.) Squeezelite Debug Info:

    ### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.2 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d default:CARD=sndrpihifiberry
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_dacplus, – Default Audio Device
    dmix:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct sample mixing device
    dsnoop:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct sample snooping device
    hw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct hardware device without any conversions
    plughw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Hardware device with all software conversions

    #### SHAIRPORT VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: RW_INTERLEAVED
    format: S32_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 882
    buffer_size: 3528

    #### OUTPUT SOUND DETAILS CARD 1 ####

    2.) Output aplay -l

    **** Liste der Hardware-Geräte (PLAYBACK) ****
    Karte 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], Gerät 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 []
    Sub-Geräte: 1/1
    Sub-Gerät #0: subdevice #0

    3.) /etc/asound.conf

    pcm.!default {
    type hw card 0
    }

    ctl.!default {
    type hw
    card 0
    }

    4.) /boot/config.txt

    ### BOOT CONFIG TXT ####
    # For more options and information see
    # http://www.raspberrypi.org/documentation/configuration/config-txt.md
    # Some settings may impact device functionality. See link above for details

    # uncomment if you get no picture on HDMI for a default „safe“ mode
    #hdmi_safe=1

    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1

    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16

    # uncomment to force a console size. By default it will be display’s size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720

    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1

    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1

    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2

    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4

    # uncomment for composite PAL
    #sdtv_mode=2

    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800

    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on

    # Uncomment this to enable the lirc-rpi module
    #dtoverlay=lirc-rpi

    # Additional overlays and parameters are documented /boot/overlays/README

    # Enable audio (loads snd_bcm2835)
    #dtparam=audio=off
    gpu_mem=128
    dtoverlay=hifiberry-dacplus

    Kind Regard from Munich and thanks a lot in advance

    21. August 2017 at 11:05 #30708

    Hi Grisha,

    Thanks for the detailed logs.

    Your output device seems to be correct. The playback issue might be due to another player. If you have another player active, please deactivate it for the time being (MPD, Spotify Connect). Also, please check your output device and try replacing it if possible for a test to rule it out as a source of error.

    Also, please deactivate build-in audio in the Raspberry Settings and check the advanced options of your Squeezelite. You can add the hardware volume parameters as well: https://www.max2play.com/en/wiki/optimizing-squeezelites-volume-control/

    21. August 2017 at 12:24 #30713

    Heiner,

    thanks a lot for your detailled answer. In the meantime I did further testing. (New image etc.)
    Also tried to deactivate the internal soundcard, and to enable digital volume control.
    Nothing did help.

    So my guess is: The Hifiberry DAC is broken.

    I sent it back today morning, and ordered a new device.

    Hopefully this will work…. If not I will be back with this issue on the board.

    Kind regards
    Grisha

    15. September 2017 at 12:33 #31342

    Hi,-

    i have a similar problem: With only gmrenderer active (no player started) i didn’t manage to switch from RP3 output to the installed DAC+.
    All settings point to the DAC+ on the WEB surface.

    Here the „debug output“:

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.1 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpihifiberry -a 80:4::
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d default:CARD=sndrpihifiberry
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081
    GMEDIARENDER_ALSA_DEVICE=hw:CARD=sndrpihifiberry,DEV=0

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    sysdefault:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    dmix:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample mixing device
    dmix:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample mixing device
    dsnoop:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample snooping device
    dsnoop:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample snooping device
    hw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct hardware device without any conversions
    hw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct hardware device without any conversions
    plughw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Hardware device with all software conversions
    plughw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Hardware device with all software conversions
    default:CARD=sndrpihifiberry – snd_rpi_hifiberry_dacplus, – Default Audio Device
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_dacplus, – Default Audio Device
    dmix:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct sample mixing device
    dsnoop:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct sample snooping device
    hw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Direct hardware device without any conversions
    plughw:CARD=sndrpihifiberry,DEV=0 – snd_rpi_hifiberry_dacplus, – Hardware device with all software conversions

    #### SHAIRPORT VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: MMAP_INTERLEAVED
    format: S16_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 440
    buffer_size: 8820

    #### OUTPUT SOUND DETAILS CARD 1 ####
    closed

    Thanks – Udo

    15. September 2017 at 12:47 #31343

    cmdline „speaker-test -Ddefault:sndrpihifiberry -twav“

    works fine. No Hardware issue.

    So what about gmrenderer? Seems as if she is not willing to use what i told her..

    Thanks – Udo

    15. September 2017 at 12:51 #31344

    [Resolved]

    Hi Udo,

    my issue is resolved. It was a hardware problem. The defect part was not the DAC+ Board, but the Raspberry Board itself. My guess is it was a problem in GPIO. With a replacement raspberry board it worked immediately.

    Kind regards
    Grisha

    15. September 2017 at 12:56 #31345

    Hi Grisha,

    thanks for replying.

    I used the thread title because it described my existing problem and the are so many similar threads in this forum.

    It seems to be a configuration problem in my case because a can use the DAC+ from the command line.

    Thanks & good luck – Udo

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here