Hifiberry Dac+ Pro squeezelite LMS 7.9 nightly DSD fail

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Hifiberry Dac+ Pro squeezelite LMS 7.9 nightly DSD fail

This topic contains 15 replies, has 5 voices, and was last updated by  cobrasu premium 2 months, 3 weeks ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • 19. February 2016 at 13:46 #18594

    Hello together

    first of all great Distro great job of MAX2PLAY 🙂

    I’m very happy with the “all in one Approach”.

    One thing I’m still struggling with:

    DSD/DSF Playback with Hifiberry Dac+ Pro (SACD RIPS or converted files with Audiogate Software)

    I read all the articles and I configured to my best Knowledge everything in the right manner, but still a failure.

    Toggled all possibilities on squeezelite for DSD installed recent nightly build of 7.9
    => just noise or nothing

    Yesterday I installed on a different Card the picoreplayer with the last Version
    => after toggling the volume to 100% in LMS for the picore audioplayer it finally worked.

    Setup is:

    raspberry PI 2
    Hifiberry DAC+ Pro
    (analog and digital part powered separately with Anker AKKU
    LMS 7.9 nightly now installed on a Windows 10 PC
    DSD Plugin activated
    DSD Player in (This player supports native playback of DSD files)
    Filetypes in LMS 7.9 DSF DSF deactivated DSF FLAC DSDPLAY
    => this works

    Setup:

    Same Hardware ecept:
    + USB-Harddisk attached on raspberry
    + LMS 7.9 nightly on MAX2PLAY Image activated/installed
    + squeezelite MAX2PLAY

    Same configuration on LMS 7.9 nightly for raspberry PI

    => fail only noise

    I suspect the following

    When I configure it so, that I get the noise (and in the Background very low volume some Music)
    => still the volume is set to 96% through MAX2PLAY

    Could this be the Problem?
    Picoreplayer sets the volume by Default to 100% I guess.

    Some advice/help would be really nice.

    I know for sure, that the Hifiberry DAC+ Pro doesn’t natively Support DSD/DSF but I have some DSD Files and in my opinion they Sound very good.

    Another Topic is the SMSL Sanskrit PRO Decoder based on the Asahi Kasei AK4490 and XMOS USB Chip
    => in my opinion this could work with MAX2PLAY any thoughts about that.

    I’m asking because I get obe next week 😉

    Yes I’m toying around but isn’t that the fun of it 🙂

    Best regards

    René

    24. February 2016 at 12:51 #18692

    Hi Chief_BSA,

    have you tried out to activate Kimmo’s and Triode’s plugin “DSDPlayer” which is included in LMS 7.9 Nightly?

    Regards
    Maximilian from Max2Play

    26. February 2016 at 16:32 #18783

    Hi Chief_BSA,

    we will setup a PiCore Player soon to find out more about how it handles DSD files and to use its configuration for Max2Play.

    Maximilian from Max2Play

    28. February 2016 at 17:12 #18807

    Hi Maximilian,

    as I wrote before I installed all the necessary plugins.
    LMS is my friend since the Squeezebox came out under the roof of Logitech.

    And without the Triode Plugin you can’t even see the DSD-Files ;-), they are just not recognized(ignored) by LMS.

    Thank You for looking into this.

    At the moment I’m using Daphile with a Netbook and the Sanskrit Pro-B DAC and DSD is very nice 🙂

    I’m looking forward to hear DSD over PCM with the Hifiberry DAC Pro and your very nice and convenient distro MAX2PLAY 🙂

    best regards

    René

    28. February 2016 at 21:34 #18808

    RESOLVED 🙂

    Hello together,

    I played around with all the squeezelite Settings and looked at my Daphile Installation.

    And TATA there I found the right Settings.

    You have to add the following Settings in the MAX2PLAY squeezelite Settings:

    -c pcm,flac,mp3,dsd -r 44100,48000,88200,96000,176400,192000

    Here you specify which filetypes should be known by squeezelite, in my case pcm, flac, mp3 and DSD (but it works without DSD filetype as it’s converted to pcm., but maybe someday there will be a native Hifiberry DSD Support with a different chip.

    Step by step:

    Add this line in the additional start options of squeezelite in the MAX2PLAY Audio part and DSF playback will work.
    -c pcm,flac,mp3,dsd -r 44100,48000,88200,96000,176400,192000

    For sure you have to set up everything according to DSF Playback in LMS.
    – activate DSD Plugin from Triode
    – set volume to fixed in the player settings of LMS
    – set filetypes in LMS accordingly
    DSF
    DSF deactivate
    FLAC dsdplay
    FLAC dsdplay
    FLAC dsdplay

    And I’m hearing at the moment my DSF Files with Hifiberry Dac+ Pro and latest MAX2PLAY Distribution

    I’m happy 🙂

    Best regards

    René

    • This reply was modified 9 months, 1 week ago by  Chief_BSA.
    • This reply was modified 9 months, 1 week ago by  Chief_BSA.
    • This reply was modified 9 months, 1 week ago by  Chief_BSA.
    25. April 2016 at 11:38 #19937

    Hi guys
    Let me join this conversation as I’m experiencing kind of similar (if not the same) issue – but I can’t resolve it with the same results as Rene did.
    I’m using I2S Soekris DAC, latest LMS 7.9 (M2P 2.29) and latest version squeezelite player. with DSD files I can only hear a noise in the speakers and silent music in the background only when I put volume up drastically. I tried different settings, following Rene solution but can’t get it working.
    DSDPlayer plugin doesn’t help and actually with the new LMS 7.9 and new squeezelite player the support for DSD is native – even without DSDplayer plugin I can see DSD settings for Files Formats in M2P Advanced settings.
    Is it because the signal from squeezelite is downsampling? I can play anything else without a problems – even HD files (192/24) but no DSD 🙁
    Apparently people using pico player don’t have such a problems.

    25. April 2016 at 14:36 #19948

    Hi awietek,
    We have not had any experience with the Soekris DAC, yet. Which output option do you have selected in your player options and do other file formats play fine?

    25. April 2016 at 14:46 #19949

    So I had to add to etc/ modules:
    snd_soc_pcm1794a
    snd_soc_rpi_dac

    and changed a line in boot/config:
    device_tree=

    So I can set card in squeezelite player interface as a system default: snd_soc_rpi_dac

    With this setup all works great but DSD.

    The Soekris DAC use pcm1704 chip.

    25. April 2016 at 17:23 #19966

    SO the DAC support DSD->DoP. I understand that I have to use DSDplayer plugin for LMS to get it right – is that correct?
    What settings I have to set on LMS to get the DoP output signal?
    Thanks

    25. April 2016 at 17:44 #19970

    Hello together,

    to be honest I don’t understand the issue.
    In my configuration with the DAC Pro there is no native DSD involved, as the DAC cannot play DSD natively.
    => So I convert all the DSD-Files to PCM
    Even if the DAC can play DSD natively it should play PCM ;-)!
    So if you convert DSD to PCM even your DAC schould play DSD
    => for sure it’s not bative as it’s converted to PCM

    -c pcm,flac,mp3,dsd -r 44100,48000,88200,96000,176400,192000

    With this line squeezelite is converting and resampling to the adequate Samplerate.

    For sure it’s mandatory to tell LMS to handle DSD Files not natively

    => setting DSD as following
    DSF
    DSF deactivate
    FLAC dsdplay
    FLAC dsdplay
    FLAC dsdplay

    Are you sure you have set the volume to a fixed rate in LMS?

    Without that you will fail.

    Just my 50 Cents to this issue.

    Best regards

    René

    25. April 2016 at 23:50 #19971

    Hi
    Thanks for all the tips.
    Volume is 100% fixed. Do you use DSDplayer plugin at all? Are you running LMS also on Raspberry?
    In the files format section I have only option to play DSD and DSF Native or Disabled.
    Thank you

    26. April 2016 at 15:03 #19974

    Hello awietek (or whatever your real name is 😉 )

    yes my LMS is installed on the rapsberry pi connected to a 500GB SATA Disk over USB, I even just upgraded to the Raspberry 3 and after some hickups also this is working flawlessly.
    => had to upgrade the Kernel to bring it to life with rpi-update and after that the problems with distortion and activated Blue-Tooth were gone.

    I activated the DSD Triode Plugin, because I couldn’t see DSD-Files otherwise.
    It may be, that the recent beta of LMS may not need that.
    But without that I also couldn’t configure how DSD Files should be treated in LMS.

    Just hang on and try some configuration in LMS and suddenly and hopefully it works!

    Best regards

    René

    26. April 2016 at 15:10 #19975

    Thanks
    I think that I’ll install older version of LMS back as the problem could be here. Then with DSDplayer plugin I’ll try some settings again.
    Could you just explain to me how did you set the file formats?
    I got DSF and DSD – options with these are Disabled or Native. With the DSDplayer plugin installed and activated I can change it to DSDplay.
    But the with the FLAC file settings I have no option to set it to dsdplay – could bo only Nattive or DIsabled.
    Thanks for your help.
    Arek 😉

    26. April 2016 at 15:25 #19976

    Hello Arek 🙂

    I will look maybe today evening at the settings, then I can give you a more precise description.

    Best regards

    René

    12. September 2016 at 17:33 #22992

    I have same Hi-Fi set as yours,I downloaded Max2play HiFiberry DAC+Pro version and followed your foot steps and I can play all types of music files especially DSF files.and thank you for your tips. Max2play is the best and powerful music apps in the world.I gave up all audio apps such as picoreplayer , volumio,runeaudio…….but Only Max2play.

    • This reply was modified 2 months, 3 weeks ago by  cobrasu.
Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.

Register here