Hifiberry DAC+ ADC not recognised

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Hifiberry DAC+ ADC not recognised

This topic contains 3 replies, has 2 voices, and was last updated by  MarioM Moderator 1 month, 3 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 22. März 2022 at 11:57 #52145

    Good day,

    I attached the hifiberry DAC+ ADC to my Raspberry Pi 4, running LMS / max2play. Audio output runs via USB to a NAD Amp with internal DAC.

    I am planning to use the DAC+ ADC for analog input of my turntable.

    All is updated to the newest SW.

    command arecord -l does not show any hardware.

    **** List of CAPTURE Hardware Devices ****

    command aplay -l shows this:

    **** List of PLAYBACK Hardware Devices ****
    card 0: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
    Subdevices: 8/8
    Subdevice #0: subdevice #0
    Subdevice #1: subdevice #1
    Subdevice #2: subdevice #2
    Subdevice #3: subdevice #3
    Subdevice #4: subdevice #4
    Subdevice #5: subdevice #5
    Subdevice #6: subdevice #6
    Subdevice #7: subdevice #7
    card 1: Audio [NAD USB Audio], device 0: USB Audio [USB Audio]
    Subdevices: 1/1
    Subdevice #0: subdevice #0

    Any hints of how to activate the DAC+ ADC?

    Thank you

    22. März 2022 at 13:42 #52147

    Hi Hans,

    Have you activated the ADC in the HiFiBerry plugin? You probably can’t use the USB DAC and the ADC at the same time. I will test this again and let you know if and how it works.

    22. März 2022 at 17:19 #52149

    Yes, hifiberry DAC+ ADC pro is activated via the Hifiberry Plugin.

    Thank you for getting back to me. Maybe I need to use an extra RPi for the analog input?

    24. März 2022 at 14:10 #52153

    I was able to successfully test the ADC Pro with an external USB DAC on one Pi. To do this, you must do the following:

    – Install the latest kernel version (so that the ADC is supported)
    – Deactivate the integrated audio in the raspberry settings
    – Select the ADC in the Hifiberry plugin
    – Select the USB DAC in the advanced options of Squeezelite (sysdefault)
    – The ADC should be hw:0, the USB DAC hw:1, so you have to enter wavin:plughw:0 as a favourite

    With these settings, the input to the ADC and the output to the USB DAC should work simultaneously.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here