Hifi DAC und Squeezelite sowie Bluetoothprobleme

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions Hifi DAC und Squeezelite sowie Bluetoothprobleme

This topic contains 10 replies, has 3 voices, and was last updated by  std Moderator 1 year, 7 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • 11. Februar 2017 at 18:52 #26840

    Hallo zusammen,

    ich hoffe deutsch ist auch ok, ansonsten formuliere ich es zur Not neu…

    Ich habe mir eine Lizenz für 5 Jahre gekauft und bin super zufrieden bis auf Bluetoothproblem hat bisher echt alles geklappt. Habe jetzt schon mein Wohnzimmer mit Squeezelite und Kodi ausgestattet inkl. FHEM, OpenVPN etc.

    Esszimmer läuft auch schon sowie im Bad ein umgebautes NostalgieRadio mit 16×2 Zeichen Display sowie funktionierende Drehknöpfe 😀 als nächstes folgt ein Radio für mein Bastelkeller mit Touchscreen (vorkonfiguriert ist alles und funktioniert! Sogar mit einem ELO 15″ Touchscreen für die Hausautomation alles super…

    Abgesehen von meinem Bluetoothproblem (was aber keine absolut Prio hat) und dass ich auf einer Hifiberry DAC Nachbaukarte absolut kein Ton bekomme bin ich somit absolut top zufrieden und damit das ganze perfekt wird, hoffe ich hier Hilfe zu bekommen.

    Ich fange mit dem mir am wichtigsten Thema an und zwar die Soundkarte und zwar ist es diese hier:

    http://www.ebay.de/itm/HIFI-DAC-Audio-Sound-Card-Module-I2S-interface-for-Raspberry-pi-B-PCM5102A-/221990523678?

    Laut mehreren Seiten bin ich auf diese Karte gestoßen, weil sie den gleichen Chip hat wie die HifiBerry DAC Karte. Ich habe schon x verschiedene Einstellungen auf der Max2Play Seite vorgenommen jedoch leider ohne Erfolg 🙁 auf diversen Seite stößt man immer wieder darauf, dass man Einstellungen per Hand machen soll, wäre ja kein Problem… z.B. laut dieser Seite:

    https://support.hifiberry.com/hc/en-us/articles/205377651-Configuring-Linux-4-x-or-higher

    Aber wie ich festgestellt habe, schreiben sich eh die Einstellungen der Webseite in diese Configs… Um hier sicher zu sein, dass von dem vorkonfigurierten Image kein Problem besteht, da eben in diese Configs geschrieben wird, so habe ich ein frisches Rasbian Jessy installiert und mich genau an die Anleitung gehalten vom letzten Link… klappt aber leider auch nicht.

    Ich weiß irgendwie nicht weiter. Volumio war ebenfalls beschrieben, dass es damit definitiv gehen soll… dort kann man auch auf der Webseite Hifi DAC auswählen… auch kein Erfolg. Ich verzweifel noch, kann doch nicht sein, dass man das Ding nicht zum Laufen bekommt. Wenn ich danach google finde ich nur Infos zur Version V2.0 welche alle GPIOs verwenden. Bei dieser hier sind noch welche frei. (ist die Version 1.0).

    Hat jemand diese Karte schon zum Laufen gebracht oder kann mir hier jemand unterstützen? Habe mit Soundkarten am Raspberry nur mit USB-Karten Berührungspunkte gehabt welche auch funktioniert haben… übrigens bekomme ich die Karte in der Tat auch angezeigt mit aplay -l Sprich die Einstellung (oder ein Teil davon) von /boot/config.txt scheint wohl gegriffen zu haben, aber kein Ton.

    Falls wichtig… ich teste die Karte gerade auf einem RPi3

    BluetoothThema:

    Bisher nur auf einem RPi B+ getestet und zwar alle updates bis zum heuten Stand. Habe auch von Max2Play die neueste VErsion installiert. BluetoothAddon installiert. Geräte gesucht und auch gefunden (mit mehreren Bluetoothsticks getestet!!! bei allen das gleiche Problem). Direktes Paaren funktioniert leider nicht. Bekomme immer ein Authentifizieurngsproblem… somit habe ich die Geräte auf Konsolenebene gepaart. Hat im ersten Step auch nicht funktioniert… ich musste „Agent“ auf ON stellen, dann konnte ich Paaren und habe auch sofort Sound gehabt… alles gut soweit… es würde auch funktionieren aber irgendwann ist das RPi so übelst ausgelastet, dass es schon ein Kompliment wäre, wenn ich sagen würde, dass der Ton abgehakt wäre. Also Performance ist was anderes, obwohl die Sachen sogar auf einem RPi A laufen sollten? Oder habe ich hier was falsch gemacht?

    Über Webseite konnte ich definitiv nicht Paaren… und es funktioniert immer erst kurz und dann schießt PulseAudio in die Höhe…

    Hat jetzt keine Prio aber vllt. könnt Ihr mir hier helfen?

    Ich danke auf jeden Fall für eure Arbeit!

    11. Februar 2017 at 19:19 #26841

    Hi

    leider kann ich dir nicht weiterhelfen da ich mich weder mit Nachbaukarten auskenne, noch BT bisher zufriedenstellend ans Laufen bekommen habe. Ich denke die Sendeleistung des eingebauten Senders ist wohl icht besonders berauschend
    BT-Hörer damit zu koppen war jedenfalls kein Problem

    Aber es wäre schön wenn du mal eine kleine Anleitung zum Bau deines Bad-Radios it m Display und den Drehknöpfen schreiben könntest, evtl. auch dafür benötigte Skripte zur Verfügung stellen

    • This reply was modified 1 year, 7 months ago by  std.
    11. Februar 2017 at 20:17 #26844

    Hi,

    zum Thema Bluetooth hätte ich dazu sagen sollen, dass ich mein Handy mit Paaren wollte. Sorry, hätte ich schreiben können.

    Zwecks Anregungen werde ich noch Bilder etc. machen müssen, ich melde mich, würde mich dennoch freuen, falls dennoch jemand helfen könnte.

    Danke!

    Gruß

    11. Februar 2017 at 22:20 #26845

    ja

    das Pairen ist ein Problem, hab ich auch noch nicht erfolgreich hinbekommen.
    Hab allerdings auch wenig Leidensdruck da es per Airplay problemlos funktioniert. Hatte mir, um iPeng nutzen zu können, eh ein altes iPhone meiner Frau geschnappt

    Bezüglich BT solltest du dich mal in diesem Thread umsehen und da dann ggf. deine Frage wiederholen: https://www.max2play.com/forums/topic/bluetooth-addon-beta/

    Zwecks Anregungen werde ich noch Bilder etc. machen müssen, ich melde mich,

    das würde mich sehr freuen 🙂

    • This reply was modified 1 year, 7 months ago by  std.
    • This reply was modified 1 year, 7 months ago by  std. Reason: Link vergessen
    11. Februar 2017 at 23:06 #26848

    Ja wie gesagt… das Paaren muss ich nur einmal per Console machen… dann bleibt das und funktioniert auch dauert… daher eher schmerzfrei… nur eben die Perfomance, da das so leider (bei mir) nicht nutzbar ist… fand es halt eine coole Sache… da nicht jeder Zugriff auf mein System hat… aber wer möchte, hätte somit recht easy mal per Bluetooth was rüber schicken können daher wäre das sehr interessant…

    Ich habe übrigens des Rätsels Lösung zwecks der Sound karte 🙁 das Zauberwort ist eher P5 Header… wenn ich das so nutzen möchte, müsste ich das bei dem Pi2, PiB+ oder Pi3 herausfinden, wo die Pins dort sind… denn die Karte (habe ich nicht drauf geachtet) hat nur Anschlüsse für das Pi B.

    Vllt. bekomme ich das noch umgelötet.

    Gruß

    13. Februar 2017 at 14:31 #26875

    Hallo zusammen,

    ich habe die Karte zum laufen bekommen 😉 einfach die P5 Header geschichte umpinnen auf die neuen Raspberrys und wenn man es nicht zu Fuß machen will, einfach Hifiberry DAC (Pi A/B) auf der Max2Play Seite einstellen… that’s it… hat mich jetzt 2 Tage gekostet aber jetzt läufts und kann weiterhin auch alte Soundkarten auf neuen Pi’s verwenden.

    Übrigens… Bilder von meinem einen Projekt:

    So gekauft:

    Inhalt rausgeschmießen bis auf Hauptplatine um dort die Drechknöpfe weiter verwenden zu können:

    Alten Lautsprecher (Tröte) gegen einen Coax JL Audio getauscht

    Gehäuse getrennt, damit der Lautsprecher sein eigenes Volumen erhält und deutlich besser klingt (Wände von innen verstärkt, da diese recht dünn waren) und entsprechend verkabelt (24V Netzteil für 2x 50 Watt Verstärker + Wandler auf 5 Volt) somit habe ich von außen nur ein 230V Stecker

    Von hinten die Platte auch verstärkt, dass der Lautsprecher ein stabiles Gehäuse bekommt inkl. alten WLAN Stick den ich noch liegen hatte mit USB Winkel

    Display (wenn Squeezelite ausgeschaltet ist)

    Display Squeezelite eingeschaltet

    Ich habe hier ein 16×2 Zeichen Display (oben Interpret und unten Titel) Ich habe hier schon ein zweites Display liegen für mein nächstes Projekt in 20×4 Zeichen, funktioniert auch schon.

    Aktuell so im Bad platziert 😀

    Sicher kann man es noch hübscher machen und wird auch noch… (habe noch ein baugleiches hier) aber da ich es kaum erwarten konnte, kennt ja jeder, ist das der aktuelle Zustand und fürs Badezimmer ist der Sound absolut top im Vergleich zur originalen Tröte…

    Freu mich schon aufs nächste Projekt

    Das hier ist übrigens in meinem Wohnzimmer (hinter der Wand alles verbaut)

    Und hier mein Esszimmer:

    Die weißen Lautsprecher standen nur für die Zeit der Renovierung drin

    13. Februar 2017 at 16:02 #26897

    Schicke Umbauten 🙂
    Mit etwas ausfürhlicherer Domumentation bestimmt auch was fürs M2P-Blog 🙂

    13. Februar 2017 at 16:50 #26905

    Landet ja schon mit Doku auf meiner Seite 😉 wenn ich endlich mal dazu komme -.-*

    • This reply was modified 1 year, 7 months ago by  Pampersjoe.
    16. Februar 2017 at 17:56 #26988

    Hi Pampersjoe,
    Wie std bereits erwähnt, wäre dein Projekt in der Tat ein tolles für unseren Blog. Das Gehäuse ist wirklich hübsch und deine Implementierung sieht auch super aus. Falls du Lust an einer Kooperation für einen Artikel hättest (du schreibst auf deutsch, machst Bilder, ich übersetze, formatiere und sende dir einen Entwurf zum Abnicken vorm Veröffentlichen), schreibe mich bitte gern an unter [email protected]
    Wir würden natürlich deine Webseite auch prominent im Artikel verlinken.

    19. Februar 2017 at 9:58 #27017

    Guten Morgen zusammen,

    einverstanden, allerdings gebt mir etwas Zeit bis ich zum Schreiben komme… ich hoffe im Laufe der Woche habe ich etwas zusammengezimmert und vor allem muss ich das ja auch noch auf meine Page mit einbringen, komme momentan leider zu sehr wenig aber einverstanden, mache ich gerne.

    Gruß

    19. Februar 2017 at 13:07 #27019

    danke

    aber mach dir keinen Stress. Ich schreibe ab und an mal Reviews zu Komponenten der Uterhaltungselektronik. Derzeit habe ich ein paar Lautsprecher hier stehe
    Ich weiß daher wie zeitaufwändig sowas sein kann

    Mich würde halt vor allem interessieren wie du das VFD-Display ansteuerst. Find das echt schick, und passt vor allem wesentlich besser zu Retro-Geräten als nen Farbdisplay

    Im Sueezebx-Forum haben wir grad 2 oder 3 User die sich nen Transporter ersteigert haben. Da werd ich echt neidisch. Aber auch gebraucht ist das Ding leider viel zu teuer. Aber die sehen halt echt geil aus, find ich

    • This reply was modified 1 year, 7 months ago by  std.
Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here