Hifi Berry Amp 2 stopped working

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Hifi Berry Amp 2 stopped working

This topic contains 6 replies, has 2 voices, and was last updated by  ih8gates 2 months, 3 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 18. Februar 2022 at 15:16 #52062

    At least, I’m fairly sure that’s the case… I’m running Max2play on a Pi with a Hifiberry Amp 2. It’s been working fine for years. Yesterday, it stopped playing audio. I haven’t changed anything and I don’t think that it rebooted – it just stopped playing audio. The Squeezelite installation on the Pi is still showing up in Logitech Media Server and LMS believes that it is playing (I see the track progress indicator working).

    I’ve tested the speakers with another sound source and they work.

    I saw that there was a Max2play update available, so I applied that. Still no audio.

    What are the best next steps to diagnose the issue?

    My Squeezelite settings:
    Soundcard: sysdefault – bcm2835 Headphones, bcm2835 Headphones – Default Audio Device, CARD=Headphones
    (I messed around with this at first thinking it was the issue… I also tried
    sysdefault – snd_rpi_hifiberry_dacplus, HiFiBerry DAC+ HiFi pcm512x-hifi-0 – Default Audio Device, CARD=sndrpihifiberry
    just in case
    )
    ALSA Parameter: 80:4::
    Command line options: -o hw:1 -C 5 -V Digital

    On the Hifiberry page of the Max2play options, I made sure that I had the correct sound card selected.

    I tried telnetting in and running alsamixer, but the interface was different from what I was used to with the extra sound card, so I left the settings alone.

    Ugg. While getting the info for this post, I rebooted my Pi (using the reboot link in Max2play). Now I can’t get to the web interface for Max2play – I get a 502 error.

    18. Februar 2022 at 15:44 #52063

    Ignore that last bit. It took longer that usual, but the web interface finally loaded.

    23. Februar 2022 at 14:38 #52086

    Hi ih8gates,

    Please try setting the sound card to „none“ in the HiFiBerry plugin and then reboot your system. Then select the Amp2 again and restart the system. Then in the advanced options of Squezeelite the audio output should be set to „sysdefault…hifiberry_dacplus“. Now restart the server and wait until the player is displayed. Does the audio output then work again?

    23. Februar 2022 at 15:33 #52087

    Thanks. I went through these steps but I’m still not getting any sound through my Amp2.

    I set this option as the audio output for Squeezelite:
    sysdefault – snd_rpi_hifiberry_dacplus, HiFiBerry DAC+ HiFi pcm512x-hifi-0 – Default Audio Device, CARD=sndrpihifiberry

    And rebooted at each step. I can see Squeezelite syncing with the Logitech Media Server, but no sound.

    24. Februar 2022 at 13:32 #52093

    Which image is installed on your SD card? Are you already using our new Buster Imager? You can find this information at the bottom of the debug info on the „Settings/Reboot“ page. If you are using an older image such as the Jessie or Wheezy image, please consider burning our latest Buster image to the SD card and rebuilding your system. If playback still does not work then, there is probably a hardware defect.

    24. Februar 2022 at 14:27 #52096

    I’m pretty sure I’m on a recent image. I’ve got a new Hifiberry on its way to me (arriving today, hopefully). I’ll try that next.

    #### FILESYSTEM ####
    Filesystem 1K-blocks Used Available Use% Mounted on
    /dev/root 60935408 2810348 55619572 5% /
    devtmpfs 414364 0 414364 0% /dev
    tmpfs 447644 0 447644 0% /dev/shm
    tmpfs 447644 23936 423708 6% /run
    tmpfs 5120 4 5116 1% /run/lock
    tmpfs 447644 0 447644 0% /sys/fs/cgroup
    /dev/mmcblk0p1 258096 54620 203476 22% /boot
    tmpfs 89528 8 89520 1% /run/user/1000

    #### LOAD AVERAGE ####
    0.02 0.02 0.00 1/232 18399

    #### KERNEL ####
    Linux PorchSpeakers 5.4.51-v7+ #1333 SMP Mon Aug 10 16:45:19 BST 2020 armv7l GNU/Linux

    #### LINUX-VERSION ####
    Distributor ID: Raspbian
    Description: Raspbian GNU/Linux 10 (buster)
    Release: 10
    Codename: buster

    25. Februar 2022 at 2:30 #52098

    Looks like it was a hardware failure! Got my new Hifiberry today and everything’s working fine now. Thanks for your help!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here