hdmi-Ton raspberry 4B stoppt nach 10min

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI hdmi-Ton raspberry 4B stoppt nach 10min

This topic contains 3 replies, has 3 voices, and was last updated by  achtungpfirsich premium 3 weeks, 5 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 13. April 2022 at 12:25 #52185

    Hallo liebe Community,

    Ich nutze den raspberry pi 4B als Ersatz für eine Squeezebox Touch mit mehr Power. Bisher habe ich den pi ohne Probleme nur als Squeezebox Server verwendet für diverse Logitech Squeezeboxen im Haus. Nun wollte ich den pi als Abspielgerät an meinem AV-Receiver per hdmi benutzen. Doch das funktioniert nicht wie gewollt. Pi und AV-Receiver sind per hdmi miteinander verbunden. Der Raspberry läuft immer, den AV-Receiver schalte ich nur bei Bedarf ein um sonst Strom zu sparen. Musik liegt auf einem USB-Stick am pi.

    Problematik:
    Das hdmi-Signal am AV-Receiver wird erst nach einem Neustart des Pis erkannt, dann funktioniert der Sound, allerdings nur für ca. 10 Minuten. Dann verschwindet am AV-Receiver das hdmi-Symbol und der Ton bleibt stumm. Bildausgabe über hdmi ist für mich nicht relevant. Ich steuere per Smartphone-App orangesqueeze. Die Ausgabe über den Digitalausgang einer Squeezebox Touch funktioniert problemlos und ohne Abbrüche. Bisher habe ich Folgendes ohne positive Veränderung der hdmi-Problematik versucht:

    – kürzeres hdmi-Kabel benutzt (1m statt 3m)

    – m2p-Image auf SD-Karte neu installiert (m2p_buster_rpi-v253.img)

    – „hdmi_force_hotplug=1“ in config.txt eingefügt – ohne Erfolg, d.h. hdmi-Signal wird trotzdem erst nach Neustart erkannt; inzwischen ist die config.txt wieder zurückgesetzt

    – Bei Squeezelite ist als Standard Ausgabe „sysdefault“ gewählt

    Ich bin dankbar für Tipps! 😉

    Mein Debug-Bericht von squeezelite:

    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.3 based on v1.8.7-999, Copyright 2012-2015 Adrian Smith, 2015-2017 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=Headphones -a 80:4:: -C 5
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d plug:jack
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    GMEDIARENDERER_ALSA_DEVICE=plug:jack

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    jack – JACK Audio Connection Kit
    pulse – PulseAudio Sound Server
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=Headphones – bcm2835 Headphones, bcm2835 Headphones – Default Audio Device
    sysdefault:CARD=Headphones – bcm2835 Headphones, bcm2835 Headphones – Default Audio Device
    dmix:CARD=Headphones,DEV=0 – bcm2835 Headphones, bcm2835 Headphones – Direct sample mixing device
    dsnoop:CARD=Headphones,DEV=0 – bcm2835 Headphones, bcm2835 Headphones – Direct sample snooping device
    hw:CARD=Headphones,DEV=0 – bcm2835 Headphones, bcm2835 Headphones – Direct hardware device without any conversions
    plughw:CARD=Headphones,DEV=0 – bcm2835 Headphones, bcm2835 Headphones – Hardware device with all software conversions
    usbstream:CARD=Headphones – bcm2835 Headphones – USB Stream Output

    #### SHAIRPORT (SYNC) VERSION ####
    3.3.1-OpenSSL-Avahi-ALSA-soxr-sysconfdir:/usr/local/etc

    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed

    #### OUTPUT SOUND DETAILS CARD 1 ####

    15. April 2022 at 22:57 #52189

    Hört sich nach einem Bildschirmschoner an! Ich hatte ein ähnliches Problem bei einem PI (ich meine mit regulärem Raspberry-OS Betriebssystem), man muß in das Hauptmenü kommen und da den Bildschirmschoner abschalten (am besten eine Funkmaus per USB anschließen), ein Bild wird ja auch bei Max2play ausgegeben mit nicht installiertem bzw. nicht aktiven Kodi. Leider weiß ich den Pfad nicht mehr, das sollten aber die Entwickler wissen.

    20. April 2022 at 12:57 #52192

    Hallo achtungpfirsich,

    ich konnte dein Problem leider nicht nachstellen, bei meinem Testgerät lief die Wiedergabe auch über die 10 Minuten hinaus weiter. Falls es am Bildschirmschoner liegt, könntest du versuchen in den Raspberry Einstellung im M2P Webinterface die Checkbox bei „Deaktiviere Bildschirmschlafmodus auf Desktop“ zu aktivieren.

    29. April 2022 at 21:09 #52202

    Danke Esb963 und MarioM für den Tipp,

    Es lag tatsächlich am Bildschirmschoner! Ich habe daraufhin in raspi-config unter „advanced options“ das „screen blanking“ deaktiviert. Endlich funktioniert der pi wie er soll! 🙂 Danke für die Hilfe!

    VG

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here