Google Music App no audio

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Google Music App no audio

This topic contains 7 replies, has 2 voices, and was last updated by  Tex premium 7 months, 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • 4. January 2017 at 23:07 #25541

    I love your OS and it is working quite well but getting adventurous I installed the Google Music App. I was able to log in to my account and the Squeezebox UI shows the songs playing but no audio. So going to the third party website I discovered you need to edit the code just ever so slightly. I tried to get to the file via Putty but I am not sure if I have privileges to edit the code if I could find it. Just curious if you guys might suggest a solution…

    https://github.com/squeezebox-googlemusic/squeezebox-googlemusic/issues/15

    5. January 2017 at 4:58 #25548

    Well I did resolve it and it was just as the poster at their forum explained the only difference was the path

    /var/lib/squeezeboxserver/Plugins/GoogleMusic/ProtocolHandler.pm

    • This reply was modified 7 months, 2 weeks ago by  Tex.
    6. January 2017 at 16:03 #25616

    I had this same issue and this fix listed above allowed me to listen to my own music, but Im not able to streaming music from Google.

    • This reply was modified 7 months, 1 week ago by  Staudie.
    6. January 2017 at 16:33 #25625

    Hi Staudie

    Not sure what you are saying, as I never had problems streaming my own files and as far as the Google App Max2Play installs it correctly but the app itself misdirects the Google Stream. If I understand correctly the S on the web address makes it secure so as therefore allowing a connection.
    To be sure I am not that happy with Google Music but thought I’d try it as a back up to Spotify if LMS loses it.

    6. January 2017 at 18:55 #25641

    I can stream/play music under “my music” but I can not stream/play any music under “all access”. Ive been using the “I feel lucky” option and radio stations under the all access heading for testing.

    6. January 2017 at 20:28 #25644

    Hi Staudie

    I just tried “I feel lucky” and it doesn’t make music I see the logo but no songs in the window. Everything else works. I had screwed up the Max2Play install by trying to install the GoogleMusic plugin in additional repositories at the bottom of the page. But the only thing that messed up was my playlists weren’t up dating.
    But I am getting all the radio stations the ones I choose & the the ones they offer.
    One thing that bothered me was the Plugin actually scanned my library and now at the Google website I found one of my playlists.
    I am thinking I prefer Spotify it seems to have better selection interface & better quality streams. But they give you 4 months of trial so i plan to try it out.

    • This reply was modified 7 months, 1 week ago by  Tex.
    7. January 2017 at 4:49 #25654

    I wonder if the difference in the installation location has anything to do with it.

    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/GoogleMusic/

    vs

    /var/lib/squeezeboxserver/Plugins/GoogleMusic/

    7. January 2017 at 17:28 #25660

    Hi Staudie

    I think the Max2Play installation of the plugin is good. I am not sure why the ProtocolHandler file was installed where it was, but I am sure Stefan had his reasons. I suspect you have tried all the tricks I would’ve like restarting LMS and unclicking & reclicking the GoogleMusic plugin for the plugin page.
    I don’t think uninstalling the plugin then reinstalling is going to do anything either, though I don’t think you can do that.
    I am always glad when I find posters with the same problems I have because then I might find a solution which was the case of the ProtocolHandler file.
    I would go to the github GoogleMusic board and post a message with your symptoms. And you might post one here with your symptoms and Stefan might know something.
    This plugin is different from the Spotify plugin. I never had a scan of my libraries from that plugin like I did from this one & to find a “playlist” of my at the GoogleMusic web site bothers me…

    • This reply was modified 7 months, 1 week ago by  Tex.
Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here