GMedia Render Issue

This topic contains 18 replies, has 2 voices, and was last updated by  Heiner Moderator 3 years, 1 month ago.

Viewing 19 posts - 1 through 19 (of 19 total)
  • 23. März 2018 at 19:17 #34707

    Thank you very much for this new version.

    However, for some reason, I have some problems with DLNA cast (with gmediarender) with this new release. I use my Android phone to cast with the Media Monkey (play.google.com/store/apps/details?id=com.ventismedia.android.mediamonkey) and Hi-Fi Cast (https://play.google.com/store/apps/details?id=com.findhdmusic.app.upnpcast). Those two apps now seem to connect with the Raspberry Pi 3 but no sound comes out. But casting from my PC with foobar2000 still works. Any idea?

    In summary:

    foobar2000 -> still works
    Media Monkey ->`does not work
    Hi-Fi Cast -> does not work

    26. März 2018 at 14:16 #34734

    Hi chicoinm,

    Are you using the Squeezebox Server dlna plugin or our gmedia render player?

    26. März 2018 at 15:06 #34740

    I am using the gmedia render player.

    26. März 2018 at 17:15 #34761

    thanks for the quick reply, could you also test AllConnect as this was the App I could test here successfully?

    27. März 2018 at 0:01 #34771

    Hi Heiner, I tried with AllConnect and it still doesn’t work.

    Another thing that I noticed is that when casting from my PC, playback is much longer to start. It used to be instantaneous but now it takes 4-5 seconds.

    27. März 2018 at 10:33 #34797

    Hi chicoinm,

    I moved your issue over to a separate thread to keep the Announcement Thread for our Stretch clean.

    This sounds like it might be related to your network. If you have not, please try running the Pi with LMS on an ethernet connection to rule this out as a source of error.

    27. März 2018 at 17:00 #34822

    Ok, I will try that. But what does „LMS“ mean?

    27. März 2018 at 17:35 #34827

    Oh I guess it means Logitech Media Server? Yes, it works with the Squeezebox Server (with files on an USB external drive connected to the Raspberry Pi). I use the Squeezer app on my phone.

    Is there something else I could test or try?

    • This reply was modified 3 years, 1 month ago by  chicoinm.
    28. März 2018 at 10:25 #34835

    Hi chicoinm

    Sorry about the cryptic response.

    The Squeezebox Server has a plugin for DLNA that turns all Squeezelite players into DLNA players as well.

    Make sure to stop all other players as well to rule out any possible interference.

    28. März 2018 at 14:43 #34845

    I see there are a few plugins related to DLNA. Which one should I use?

    28. März 2018 at 15:01 #34846

    In the Squeezebox Server Settings -> Plugins -> UPNP/DLNA Media Interface should active and then your Squeezelite player also becomes a DLNA player 😉

    28. März 2018 at 17:33 #34848

    Ok, I tried this but it still doesn’t work. When I press „play“, it seems to start but after two seconds the track restarts at the beginning. And no sound comes out.

    29. März 2018 at 12:17 #34882

    Hi chicoinm,

    Could you try the AirPlay protocol with AllConnect (you need shairtunes2 as an active plugin in LMS), to make sure this issue is only occurring with DLNA?

    29. März 2018 at 13:41 #34899

    Shairtunes2 does not work in LMS (plugin failed to load).

    29. März 2018 at 14:08 #34900

    Ok this is very weird… First I found out that I had to install the „bugfix for shairtunes2“ in Max2play. I installed it and so the Shairtunes2 plugin loaded correctly in LMS. It still does not work with Allconnect (it seems to play correctly but no sound comes out). But now it works with MediaMonkey!

    However I am not sure if music is cast from my phone or if it plays from the external hard drive connected to the Raspberry Pi as they have identical libraries. But at least it works for now.

    29. März 2018 at 21:53 #34910

    Also, music continues even if the phone is turned off. Is this an expected behaviour?

    3. April 2018 at 9:34 #34937

    Do you mean after you lock the phone or after you completely turn it off?

    3. April 2018 at 13:23 #34945

    I turn it off.

    4. April 2018 at 16:11 #34978

    That is indeed strange. But probably just a longer buffer from your software’s streaming procedure. As long as it does not keep going for minutes, you should be fine.

Viewing 19 posts - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.

Register here