-G : not working

Tagged: 

This topic contains 4 replies, has 2 voices, and was last updated by  Heiner Moderator 2 weeks, 6 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 20. September 2018 at 18:32 #37954

    Hello,

    I urgently would need the option
    -G <Rpi GPIO#>:<H/L>
    Specify the BCM GPIO# to use for Amp Power Relay and if the output should be Active High or Low

    But when I set it for my max2play squeezelite player in the options settings, the service is not starting anymore.
    I only get the Error message

    Versucht zu starten … NICHT Erfolgreich Hier klicken für weitere Informationen

    Option error: -G

    Squeezelite v1.8.3-718, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving. See -t for license terms

    What can I do to use this parameter=?

    Thnaks Erich

    21. September 2018 at 11:03 #37964

    Hi Erich,

    Your info in the yellow text should be more detailed.

    The parameter should look like this (if you want to mute the output of AMP2):
    -G 4:L

    After saving, check the yellow text if it says „Error in GPIO Pin assignment.“

    21. September 2018 at 21:57 #38005

    the error message was only like I wrote – see screenshot

    But when updating max2play as well as the Player, now I can save the -G Option & start the Service 🙂

    So solved – thX

    max2play_g

    22. September 2018 at 12:56 #38007

    edit – When starting the Player, the GPIO gets like expected „High“ – but when pausing, it doesn`t get „Low“ 🙁
    Only when turning the Player off, also the Pin gets Low.

    Is there a way to auto turn off the Player when pressing pause=?
    Or is there a plugin available to run a script on pause? – if not how could I write a hook?

    25. September 2018 at 10:46 #38017

    Hi eriche,

    The parameter -C <seconds> automatically disengages the output device after playback is paused for a few seconds.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here