filesystem mount nfs

Tagged: ,

This topic contains 8 replies, has 5 voices, and was last updated by  Heiner Moderator 2 years, 3 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 4. August 2015 at 13:40 #15275

    Hi,
    I’m trying to add a mount (NFS) for a NAS/Synology.

    I get the error message:
    sudo: unable to resolve host max2play Retrying with upper case share name mount error(6): No such device or address Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) mount error: could not resolve address for SCHUBERT: Unknown error Retrying with upper case share name mount error(6): No such device or address Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) mount: unknown filesystem type ‚cif‘ Retrying with upper case share name mount error(6): No such device or address Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    Mountpoint NOT added! Please refer to the description below!

    Directory created: /mnt/share/schubert
    sudo: unable to resolve host max2play Retrying with upper case share name mount error(6): No such device or address Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) mount error: could not resolve address for SCHUBERT: Unknown error Retrying with upper case share name mount error(6): No such device or address Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) mount: unknown filesystem type ‚cif‘ Retrying with upper case share name mount error(6): No such device or address Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) mount.nfs: remote share not in ‚host:dir‘ format mount.nfs: remote share not in ‚host:dir‘ format mount.nfs: remote share not in ‚host:dir‘ format
    Mountpoint NOT added! Please refer to the description below!

    Debug info:
    10.0.1.65:/volume1/music /mnt/schubert nfs
    10.0.1.65:/volume1/music /mnt/schubert nfs user=user,password=password,sec=ntlm,iocharset=utf8
    //10.0.1.65/volume1/music /mnt/schubert nfs
    //10.0.1.65/volume1/music /mnt/schubert nfs user=user,password=password,sec=ntlm,iocharset=utf8
    //10.0.1.65/volume1/music /mnt/share/schubert nfs user=user,password=password,sec=ntlm,iocharset=utf8
    //10.0.1.65/volume1/music /mnt/schubert cifs user=user,password=password,sec=ntlm,iocharset=utf8
    //SCHUBERT/volume1/music /mnt/schubert cifs user=user,password=password,sec=ntlm,iocharset=utf8
    //SCHUBERT.LOCAL/volume1/music /mnt/schubert cif user=user,password=password,sec=ntlm,iocharset=utf8
    //SCHUBERT.LOCAL./volume1/music /mnt/schubert cifs user=user,password=password,sec=ntlm,iocharset=utf8

    I use the hifiberry image, should I look on the side of the NAS or my PI?
    many thanks.

    4. August 2015 at 17:58 #15276

    It was on the NAS side.
    Thanks for m2p audio player.

    5. August 2015 at 11:28 #15278

    Glad you sorted it out!

    Make sure to set „user“ and „password“ correctly to fit your settings on the NAS. The default values are just to show that there should be set something. Also delete the settings that do not work from the list – otherwise you will always get error messages, even if one of the mounts is working.

    Cheers,
    Stefan

    1. September 2015 at 18:23 #15565

    Hi,

    I have the same issue with my QNAP. I have an nfs share (sch-nas/music). I can see it from an openelec, but when I’m trying to add to M2P, I’ve got an error message:

    sudo: unable to resolve host Etkezo
    Mountpoint NOT added! Please refer to the description below!

    Etkezo is the name of my M2P instance. What I do wrong?

    When I try to this from cli, I’ve got this error message:
    [email protected]:/# mount -t nfs sch-nas:/music /mnt/music
    mount.nfs: rpc.statd is not running but is required for remote locking.
    mount.nfs: Either use ‚-o nolock‘ to keep locks local, or start statd.
    mount.nfs: an incorrect mount option was specified
    [email protected]:/#

    Any idea?

    7. September 2015 at 15:18 #15637

    Hi schferenc,
    Please try using cifs instead of nfs.

    17. Mai 2018 at 19:36 #35750

    for your info,
    i finally succeeded using Remote Control and directly using the following command:

    sudo mount -t nfs <IP Address>:/<DriveVolumeName>/<NameofShare> /mnt/<FolderyouCreated>

    after this, LMS is actually scanning the NAS files!
    so, please, Max2Play needs to correct the Filesystem-Mount function.
    you are making lot of people lot of headaches!

    22. Mai 2018 at 14:41 #35803

    Hi gchip,

    Thank you for the feedback. Could you tell us your error when using our mount menu?

    22. Mai 2018 at 15:14 #35809

    as stated before, even though the Filesystem Mount worked and i could see
    the USERMOUNT entry (using cifs) in /etc/fstab, LMS could not access the NAS folder.

    however, the manual nfs command did work!
    so i manually added the mount command in /etc/fstab and now, all is well.

    i’d like to suggest that you update the Filesystem Mount page to say that
    beginning // is not needed; in fact, it would result in error.
    also, perhaps evaluate the comment about cifs being the preferred choice.
    in my case, nfs was definitely the simpler and only choice that worked…..

    24. Mai 2018 at 10:42 #35853

    hi gchip,

    could you please share the details of both shares you tried to mount, so we can understand what the issue might have been?

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here