[SOLVED] File Manager shows me the usb drive plugged into my rpi3b twice

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] File Manager shows me the usb drive plugged into my rpi3b twice

This topic contains 12 replies, has 2 voices, and was last updated by  Heiner Moderator 1 year, 3 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • 1. Juli 2019 at 5:39 #45987

    how do I undo this?

    • This topic was modified 1 year, 4 months ago by  gresyth.
    • This topic was modified 1 year, 4 months ago by  gresyth.
    • This topic was modified 1 year, 3 months ago by  Heiner.
    1. Juli 2019 at 9:55 #46003

    Hi greysth,

    Does your USB drive have two different partitions?

    Have you tried ejecting the drive, rebooting and connecting it again? If so, do both entries reappear?

    Do both shares contain data or is one empty?

    Have you made a tick at permanent mounting for one of them or both?

    1. Juli 2019 at 23:44 #46098

    Does your USB drive have two different partitions?
    No, just 1
    Have you tried ejecting the drive, rebooting and connecting it again? If so, do both entries reappear?
    Yes and yes
    Do both shares contain data or is one empty?
    the two shares shown are identical. In between them is a light blue vertical strip with a right arrow and a left arrow.
    Have you made a tick at permanent mounting for one of them or both?
    is „Set fixed Mountpoint to prevent directory switching on reboot:“ what you mean?

    2. Juli 2019 at 11:39 #46103

    For the last questions, yes, the tick affixes the mount to a certain path.

    If so, remove this tick and reboot.

    4. Juli 2019 at 3:28 #46113

    I removed it but I still have the drive shown twice.

    4. Juli 2019 at 10:51 #46135

    Previously, I asked which of the drives has the data on it. Have you been able to find that out yet?
    Do both shares contain data or is one empty?

    Also, have you tried removing the stick physical, rebooting and connecting it again?

    5. Juli 2019 at 7:50 #46159

    The two drives shown in File Manager are identical. They show the same data and directory structure. There is only 1 drive connected to the rPi.
    This is a Western Digital My Passport 1TB SSD. It functions perfectly in the rPi and on my PC through Sambashare or plugged into usb on the pc.

    I have physically removed the drive and rebooted.
    I have gone to Filesystem Mount and unmounted the drive. rebooted found no drive listed, re-mounted the drive rebooted and find it again duplicated in File Manager.

    5. Juli 2019 at 9:35 #46161

    Hi gresyth,

    Which version of Max2Play are you using? (Settings/Reboot debug info Kernel and release name „jessie“ or „stretch“)

    Please also make a beta update.

    5. Juli 2019 at 11:00 #46167

    Version 2.49
    Raspberry PI 3

    #### FILESYSTEM ####
    Filesystem 1K-blocks Used Available Use% Mounted on
    /dev/root 7367136 2674260 4364560 38% /
    devtmpfs 443608 0 443608 0% /dev
    tmpfs 448216 0 448216 0% /dev/shm
    tmpfs 448216 13840 434376 4% /run
    tmpfs 5120 4 5116 1% /run/lock
    tmpfs 448216 0 448216 0% /sys/fs/cgroup
    /dev/mmcblk0p1 42136 22498 19638 54% /boot
    /dev/sda1 976727036 405278492 571448544 42% /media/usb0
    tmpfs 89640 8 89632 1% /run/user/1000

    #### LOAD AVERAGE ####
    0.52 0.34 0.38 1/241 9397

    #### KERNEL ####
    Linux max2play 4.19.30-v7+ #1209 SMP Tue Mar 26 13:14:20 GMT 2019 armv7l GNU/Linux

    #### LINUX-VERSION ####
    Distributor ID: Raspbian
    Description: Raspbian GNU/Linux 9.8 (stretch)
    Release: 9.8
    Codename: stretch

    8. Juli 2019 at 10:32 #46179

    Hi gresyth,

    Thanks, so it’s not related to an older version. You are up to date.

    I googled the SSD’s specs and it seems to be formatted in exFAT. Usually, we have not had any issues with this format mounting on M2P.

    Does the double entry of the mount result in any errors or issues for your setup?
    Can you access and play any of the music from the mounts?

    8. Juli 2019 at 19:46 #46201

    From within max2play I can play movie and music from the raw files on the drive.

    I was having an issue of some tv show episodes being duped up to 20+ times and that started after the second drive entry showed up.
    I’ve cleared all my media several times trying to get it sorted out. Now I am at a point that when I add a source it goes through the process but the library still is empty.

    I’ve gotten very frustrated with this and I’m thinking I need to make a new image and start over.

    30. Juli 2019 at 0:11 #46528

    Solved

    Sorry I didn’t get back to you. I was watching a Youtube video about max2play and found the answer.
    What I’ve been thinking was a glitch is a feature. The right hand drive is for copying files. DOH!

    I tried to submit a screen shot with my original post but couldn’t do that. Do I have to earn the ability to show screenshots?

    31. Juli 2019 at 14:25 #46590

    Hi gresyth,

    Glad to hear our videos helped you out! 🙂

    Unfortunately, we cannot offer a picture upload service with the forum. However, you can link to the picture from any popular picture sharing website.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Register here