FHEM Server wird nicht installiert

Max2Play Home 2016 (en) Forums Max2Play Add-ons FHEM Server wird nicht installiert

Tagged: , , ,

This topic contains 8 replies, has 2 voices, and was last updated by  Heiner Moderator 3 months, 3 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 18. May 2017 at 23:24 #28938

    Hallo

    (Hmm, das mit dem editieren meines Beitrags ging wohl schief)

    Ich wollte mit dem FHEM Plugin den FHEM Server auf meinem Raspberry PI 3 installieren, nur leider funktioniert das nicht.
    Das Plugin ist sichbar, aber wenn man auf “installiere FHEM” drückt lädt es nur kurz irgendwelche Dateien und schreibt danach Finished hin.

    Der Server wurde dann aber nicht installiert.

    Ich habe es auch schon mit der Beta-Version versucht, klappt auch nicht.

    Bei einem Installationsversuch bekam ich die Meldung die Installationsdateien zu löschen. Wie geht das, bzw. wo werden diese hingespeichert?

    mfg

    Err http://debian.fhem.de Packages
    404 Not Found [IP: 13.32.22.247 80]
    Ign http://debian.fhem.de Translation-en_GB
    Ign http://debian.fhem.de Translation-en
    Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
    Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
    Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
    Ign http://mirrordirector.raspbian.org jessie/main Translation-en
    Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
    Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
    Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
    Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
    Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
    Ign http://archive.raspberrypi.org jessie/main Translation-en
    Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
    Ign http://archive.raspberrypi.org jessie/ui Translation-en
    Reading package lists…
    Building dependency tree…
    Reading state information…
    Finished – please click here to reload Page to see Changes

    19. May 2017 at 10:22 #28940

    Hallo Fuselx,

    Bitte mache erneut ein Beta-Update, reboote deinen Pi und klick auf “Installieren”.

    Edit: Wir haben die neue Version getestet, erfolgreich installiert und Betrieb nehmen können. Deshalb ist diese nun auch angepasst im normalen Update verfügbar.

    Important: Update your system before installing the FHEM setup.

    • This reply was modified 4 months ago by  Heiner.
    19. May 2017 at 14:18 #28956

    Hallo Heiner,

    danke für die schnelle Antwort!

    Das installieren funktioniert jetzt und man kann auch den Port für den Server einstellen, nur leider kann ich den Server nicht aufrufen.

    Diese Zeilen wurden am Ende der installation angezeigt:
    Hat das was mit meinem Bluetooth Stick zu tun?

    EOF on stdin at conffile prompt
    dpkg: dependency problems prevent configuration of pulseaudio-module-bluetooth:
    pulseaudio-module-bluetooth depends on pulseaudio (= 5.0-13); however:
    Package pulseaudio is not configured yet.

    dpkg: error processing package pulseaudio-module-bluetooth (–configure):
    dependency problems – leaving unconfigured
    dpkg: dependency problems prevent configuration of pulseaudio-module-x11:
    pulseaudio-module-x11 depends on pulseaudio (= 5.0-13); however:
    Package pulseaudio is not configured yet.

    dpkg: error processing package pulseaudio-module-x11 (–configure):
    dependency problems – leaving unconfigured
    Setting up fhem (5.8.14316) …
    Starting fhem…
    Errors were encountered while processing:
    pulseaudio
    pulseaudio-module-bluetooth
    pulseaudio-module-x11

    mfg

    20. May 2017 at 0:21 #28959

    Hallo,

    nach einer Neuinstallation habe ich auf den Fehler gefunden.
    Wenn ich den Raspberry über LAN verbunden habe konnte ich den Server sofort (nach dem Update) aufrufen. Über WLAN nicht


    Das Problem war meine WLAN static IP konfiguration.
    Ich hatte diese unter /etc/dhcpcd.conf eingestellt, was bis jetzt auch so funktioniert hat.
    Für den FHEM-Server muss man die WLAN static IP in /etc/network/interfaces konfigurieren.

    EDIT: Nehme alles zurück, es funktioniert immer noch nicht. Nach einem Neustart konnte man wieder nicht auf den Server zu greifen.
    Der Server läuft aber nur ist es scheinbar Zufall ob man darauf zugreifen kann oder nicht.
    Ob das an Max2play, meiner IP Konfiguration oder an FHEM liegt, weiß ich noch nicht

    mfg

    • This reply was modified 4 months ago by  Fuselx.
    • This reply was modified 4 months ago by  Fuselx.
    22. May 2017 at 11:01 #28983

    Hallo Fuselx,

    Bitte versuche gegebenenfalls ein frisches Image zu testen, da wir mit diesem direkt Erfolg hatten.

    29. May 2017 at 10:13 #29087

    Hallo,

    nach einer Fehlersuche im offiziellen FHEM-Forum habe ich die Lösung zu meinem Problem gefunden:

    Scheinbar hat “Jessie” ein Timing Problem mit dem FHEM Dienst. Der fhem Prozess benötigte 100% CPU (anzeige mit Befehl “top”) und man konnte das Web-Interface nicht aufrufen.

    Gelöst wird das Ganze dann durch bearbeiten der “/etc/init.d/fhem” Datei.
    Man fügt bei # Required-Start $ntp hinzu und vor “perl fhem.pl fhem.cfg” Sleep 10 (kann auch etwas niedriger sein, zb. 5)

    Danach einmal rebooten und es alles funktioniert einwandfrei.

    mfg

    • This reply was modified 3 months, 3 weeks ago by  Fuselx.
    29. May 2017 at 11:27 #29096

    Hi Fuselx,

    Danke für den Nachtrag, ich hoffe es kann anderen Usern mit der gleichen Problematik helfen.

    Bei welchem Pi-Modell konntest du dieses Problem feststellen? Wir konnten auf unserem Testgerät dies nicht reproduzieren.

    • This reply was modified 3 months, 3 weeks ago by  Heiner.
    30. May 2017 at 10:07 #29107

    Hallo,

    ich habe es mit zwei verschiedenen Raspberry Pi 3 Modell B getestet. Im FHEM Forum tritt dieses Problem scheinbar öfters auf.

    mfg

    30. May 2017 at 11:13 #29109

    Okay, danke für das Feedback. Wir werden nochmal versuchen, das Problem hier zu rekreieren.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here